<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="dns-prefetch" href="//fonts.googleapis.com/">
<link rel="dns-prefetch" href="//fonts.gstatic.com/">
<link rel="dns-prefetch" href="//ajax.googleapis.com/">
<link rel="dns-prefetch" href="//apis.google.com/">
<link rel="dns-prefetch" href="//google-analytics.com/">
<link rel="dns-prefetch" href="//www.google-analytics.com/">
<link rel="dns-prefetch" href="//ssl.google-analytics.com/">
<link rel="dns-prefetch" href="//youtube.com/">
<link rel="dns-prefetch" href="//s.gravatar.com/">
<link rel="alternate" type="application/rss+xml" title="Sierra Leone News RSS Feed" href="https://www.switsalone.com/feed/" />
<link rel="alternate" type="application/atom+xml" title="Sierra Leone News Atom Feed" href="https://www.switsalone.com/feed/atom/" />
<link rel="pingback" href="https://www.switsalone.com/xmlrpc.php" />
<!--[if lt IE 9]>
	<script src="https://www.switsalone.com/wp-content/themes/soledad1/js/html5.js"></script>
	<![endif]-->
<title>Sierra Leone News Today | Sierra Leone News</title>
<link rel='dns-prefetch' href='//platform-api.sharethis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Sierra Leone News &raquo; Feed" href="https://www.switsalone.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Sierra Leone News &raquo; Comments Feed" href="https://www.switsalone.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Sierra Leone News &raquo; Sierra Leone News Today Comments Feed" href="https://www.switsalone.com/39042_sierra-leone-news-today-159/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.switsalone.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.7"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='flick-css' href='https://www.switsalone.com/wp-content/plugins/mailchimp//css/flick/flick.css?ver=5.3.7' type='text/css' media='all' />
<link rel='stylesheet' id='mailchimpSF_main_css-css' href='https://www.switsalone.com/?mcsf_action=main_css&#038;ver=5.3.7' type='text/css' media='all' />
<!--[if IE]>
<link rel='stylesheet' id='mailchimpSF_ie_css-css'  href='https://www.switsalone.com/wp-content/plugins/mailchimp/css/ie.css?ver=5.3.7' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='wp-block-library-css' href='https://www.switsalone.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.7' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-theme-css' href='https://www.switsalone.com/wp-includes/css/dist/block-library/theme.min.css?ver=5.3.7' type='text/css' media='all' />
<link rel='stylesheet' id='et_bloom-open-sans-css' href='https://fonts.googleapis.com/css?family=Open+Sans:400,700' type='text/css' media='all' />
<link rel='stylesheet' id='et_bloom-css-css' href='https://www.switsalone.com/wp-content/plugins/bloom/css/style.css?ver=1.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css' href='https://www.switsalone.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='crp-style-rounded-thumbs-css' href='https://www.switsalone.com/wp-content/plugins/contextual-related-posts/css/rounded-thumbs.min.css?ver=1.0.1' type='text/css' media='all' />
<style id='crp-style-rounded-thumbs-inline-css' type='text/css'>

			.crp_related a {
			  width: 150px;
			  height: 150px;
			  text-decoration: none;
			}
			.crp_related img {
			  max-width: 150px;
			  margin: auto;
			}
			.crp_related .crp_title {
			  width: 100%;
			}
			
</style>
<link rel='stylesheet' id='penci-oswald-css' href='//fonts.googleapis.com/css?family=Oswald%3A400&#038;ver=5.3.7' type='text/css' media='all' />
<link rel='stylesheet' id='penci-fonts-css' href='//fonts.googleapis.com/css?family=PT+Serif%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CPlayfair+Display+SC%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CMontserrat%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7COpen+Sans%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%26subset%3Dlatin%2Ccyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext&#038;ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='penci_style-css' href='https://www.switsalone.com/wp-content/themes/soledad1/style.css?ver=7.2.0' type='text/css' media='all' />
<script type='text/javascript' src='https://www.switsalone.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/plugins/mailchimp//js/scrollTo.js?ver=1.5.7'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-includes/js/jquery/jquery.form.min.js?ver=4.2.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mailchimpSF = {"ajax_url":"https:\/\/www.switsalone.com\/"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/plugins/mailchimp//js/mailchimp.js?ver=1.5.7'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/plugins/mailchimp//js/datepicker.js?ver=5.3.7'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var append_link = {"read_more":"Read more at: %link%","prepend_break":"2","use_title":"true","add_site_name":"true","site_name":"Sierra Leone News","site_url":"https:\/\/www.switsalone.com","always_link_site":"false","page_title":"Sierra Leone News Today"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/plugins/append-link-on-copy/js/append_link.js?ver=5.3.7'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/plugins/stop-user-enumeration/frontend/js/frontend.js?ver=1.3.29'></script>
<script type='text/javascript' src='//platform-api.sharethis.com/js/sharethis.js#product=ga&#038;property=5c6f580819573f001129a74c'></script>
<link rel='https://api.w.org/' href='https://www.switsalone.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.switsalone.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.switsalone.com/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='GEF Small Grants Stories: Swamp Farms increase Food Security, and Prevent Deforestation in Gola Forest Communities' href='https://www.switsalone.com/39026_gef-small-grants-stories-swamp-farms-increase-food-security-and-prevent-deforestation-in-gola-forest-communities/' />
<link rel='next' title='Listen to “Self Luv remix” by Skillz ft Drizlik, Blaqbonze and Enam' href='https://www.switsalone.com/39045_listen-to-self-luv-remix-by-skillz-ft-drizlik-blaqbonze-and-enam/' />
<meta name="generator" content="WordPress 5.3.7" />
<link rel='shortlink' href='https://www.switsalone.com/?p=39042' />
<link rel="alternate" type="application/json+oembed" href="https://www.switsalone.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.switsalone.com%2F39042_sierra-leone-news-today-159%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.switsalone.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.switsalone.com%2F39042_sierra-leone-news-today-159%2F&#038;format=xml" />
<style type="text/css" id="et-bloom-custom-css">
					.et_bloom .et_bloom_optin_1 .et_bloom_form_content { background-color: #f2855e !important; } .et_bloom .et_bloom_optin_1 .et_bloom_form_container .et_bloom_form_header { background-color: #ffffff !important; } .et_bloom .et_bloom_optin_1 .et_bloom_form_content button { background-color: #1e73be !important; } .et_bloom .et_bloom_optin_1 .et_bloom_form_content button { background-color: #1e73be !important; } .et_bloom .et_bloom_optin_1 h2, .et_bloom .et_bloom_optin_1 h2 span, .et_bloom .et_bloom_optin_1 h2 strong { font-family: "Open Sans", Helvetica, Arial, Lucida, sans-serif; }.et_bloom .et_bloom_optin_1 p, .et_bloom .et_bloom_optin_1 p span, .et_bloom .et_bloom_optin_1 p strong, .et_bloom .et_bloom_optin_1 form input, .et_bloom .et_bloom_optin_1 form button span { font-family: "Open Sans", Helvetica, Arial, Lucida, sans-serif; } 
				</style><script type="text/javascript">
        jQuery(function($) {
            $('.date-pick').each(function() {
                var format = $(this).data('format') || 'mm/dd/yyyy';
                format = format.replace(/yyyy/i, 'yy');
                $(this).datepicker({
                    autoFocusNextInput: true,
                    constrainInput: false,
                    changeMonth: true,
                    changeYear: true,
                    beforeShow: function(input, inst) { $('#ui-datepicker-div').addClass('show'); },
                    dateFormat: format.toLowerCase(),
                });
            });
            d = new Date();
            $('.birthdate-pick').each(function() {
                var format = $(this).data('format') || 'mm/dd';
                format = format.replace(/yyyy/i, 'yy');
                $(this).datepicker({
                    autoFocusNextInput: true,
                    constrainInput: false,
                    changeMonth: true,
                    changeYear: false,
                    minDate: new Date(d.getFullYear(), 1-1, 1),
                    maxDate: new Date(d.getFullYear(), 12-1, 31),
                    beforeShow: function(input, inst) { $('#ui-datepicker-div').removeClass('show'); },
                    dateFormat: format.toLowerCase(),
                });

            });

        });
    </script>
<style type="text/css">
																													</style>
<style type="text/css">
																											</style>

<link rel="canonical" href="https://www.switsalone.com/39042_sierra-leone-news-today-159/" />
<meta name="description" content="President Bio appoints former Agriculture Minister as Finance Minister President Julius Maada Bio has on Friday, May 7, 2021, appointed Dr. Dennis Vandi as the country&#039;s new Minister of Finance replacing Jacob Jusu Saffa who is now Chief Minister. Dr. Vandi was the Minister of Agriculture a ..." />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.switsalone.com/39042_sierra-leone-news-today-159/" />
<meta property="og:title" content="Sierra Leone News Today | Sierra Leone News" />
<meta property="og:description" content="President Bio appoints former Agriculture Minister as Finance Minister President Julius Maada Bio has on Friday, May 7, 2021, appointed Dr. Dennis Vandi as the country&#039;s new Minister of Finance replacing Jacob Jusu Saffa who is now Chief Minister. Dr. Vandi was the Minister of Agriculture a ..." />
<meta property="og:image" content="https://www.switsalone.com/wp-content/uploads/2021/05/Dennis-Vandy-finance-minister.jpg" />
<meta property="og:image:width" content="400" />
<meta property="og:image:height" content="400" />
<meta property="article:published_time" content="2021-05-10T12:15:29" />
<meta property="article:author" content="Alhassan Lamin" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="Sierra Leone News Today | Sierra Leone News" />
<meta name="twitter:description" content="President Bio appoints former Agriculture Minister as Finance Minister President Julius Maada Bio has on Friday, May 7, 2021, appointed Dr. Dennis Vandi as the country&#039;s new Minister of Finance replacing Jacob Jusu Saffa who is now Chief Minister. Dr. Vandi was the Minister of Agriculture a ..." />
<meta name="twitter:image" content="https://www.switsalone.com/wp-content/uploads/2021/05/Dennis-Vandy-finance-minister.jpg" />
<script type="application/ld+json">[{"@context":"http:\/\/schema.org","@type":"WebSite","about":"Swit Salone","dateModified":"2021-05-12 15:09:44.000000","description":"Swit Salone","encoding":"UTF-8","headline":"Sierra Leone News","inLanguage":"en-US","name":"Sierra Leone News","publisher":{"@type":"Organization","name":"Sierra Leone News"},"url":"https:\/\/www.switsalone.com"},{"@context":"http:\/\/schema.org","@type":"Article","author":{"@type":"Person","name":"Alhassan Lamin","url":"https:\/\/www.switsalone.com\/author\/alhassan-lamin\/"},"commentCount":"0","dateModified":"2021-05-10T12:15:32","datePublished":"2021-05-10T12:15:29","description":"President Bio appoints former Agriculture Minister as Finance Minister President Julius Maada Bio has on Friday, May 7, 2021, appointed Dr. Dennis Vandi as the country&#039;s new Minister of Finance replacing Jacob Jusu Saffa who is now Chief Minister. Dr. Vandi was the Minister of Agriculture a ...","headline":"Sierra Leone News Today | Sierra Leone News","image":{"@context":"http:\/\/schema.org","@type":"ImageObject","height":400,"url":"https:\/\/www.switsalone.com\/wp-content\/uploads\/2021\/05\/Dennis-Vandy-finance-minister.jpg","width":400},"mainEntityOfPage":"https:\/\/www.switsalone.com\/39042_sierra-leone-news-today-159\/","name":"Sierra Leone News Today","publisher":{"@type":"Organization","name":"Sierra Leone News","logo":{"@type":"ImageObject","url":"https:\/\/secure.gravatar.com\/avatar\/?s=96&d=mm&r=r","height":60,"width":60}},"thumbnailUrl":"https:\/\/www.switsalone.com\/wp-content\/uploads\/2021\/05\/Dennis-Vandy-finance-minister.jpg","url":"https:\/\/www.switsalone.com\/39042_sierra-leone-news-today-159\/"}]</script>


<meta property="og:image" content="https://www.switsalone.com/wp-content/uploads/2021/05/Dennis-Vandy-finance-minister.jpg" />


<script>var portfolioDataJs = portfolioDataJs || [];</script> <style type="text/css">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</style>
<script>
var penciBlocksArray=[];
var portfolioDataJs = portfolioDataJs || [];var PENCILOCALCACHE = {};
		(function () {
				"use strict";
		
				PENCILOCALCACHE = {
					data: {},
					remove: function ( ajaxFilterItem ) {
						delete PENCILOCALCACHE.data[ajaxFilterItem];
					},
					exist: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data.hasOwnProperty( ajaxFilterItem ) && PENCILOCALCACHE.data[ajaxFilterItem] !== null;
					},
					get: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data[ajaxFilterItem];
					},
					set: function ( ajaxFilterItem, cachedData ) {
						PENCILOCALCACHE.remove( ajaxFilterItem );
						PENCILOCALCACHE.data[ajaxFilterItem] = cachedData;
					}
				};
			}
		)();function penciBlock() {
		    this.atts_json = '';
		    this.content = '';
		}</script>
<script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "organization",
    "@id": "#organization",
    "logo": {
        "@type": "ImageObject",
        "url": "https:\/\/www.switsalone.com\/wp-content\/uploads\/switsalone-new1s-logo.png"
    },
    "url": "https:\/\/www.switsalone.com\/",
    "name": "Sierra Leone News",
    "description": "Swit Salone"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "WebSite",
    "name": "Sierra Leone News",
    "alternateName": "Swit Salone",
    "url": "https:\/\/www.switsalone.com\/"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BlogPosting",
    "headline": "Sierra Leone News Today",
    "description": "President Bio appoints former Agriculture Minister as Finance Minister President Julius Maada Bio has&hellip;",
    "datePublished": "2021-05-10",
    "datemodified": "2021-05-10",
    "mainEntityOfPage": "https:\/\/www.switsalone.com\/39042_sierra-leone-news-today-159\/",
    "image": {
        "@type": "ImageObject",
        "url": "https:\/\/www.switsalone.com\/wp-content\/uploads\/2021\/05\/Dennis-Vandy-finance-minister.jpg",
        "width": 400,
        "height": 400
    },
    "publisher": {
        "@type": "Organization",
        "name": "Sierra Leone News",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/www.switsalone.com\/wp-content\/uploads\/switsalone-new1s-logo.png"
        }
    },
    "author": {
        "@type": "Person",
        "@id": "#person-AlhassanLamin",
        "name": "Alhassan Lamin"
    }
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BreadcrumbList",
    "itemListElement": [
        {
            "@type": "ListItem",
            "position": 1,
            "item": {
                "@id": "https:\/\/www.switsalone.com",
                "name": "Home"
            }
        },
        {
            "@type": "ListItem",
            "position": 2,
            "item": {
                "@id": "https:\/\/www.switsalone.com\/category\/news\/",
                "name": "News"
            }
        },
        {
            "@type": "ListItem",
            "position": 3,
            "item": {
                "@id": "https:\/\/www.switsalone.com\/39042_sierra-leone-news-today-159\/",
                "name": "Sierra Leone News Today"
            }
        }
    ]
}</script><meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress." />
<!--[if IE 8]><link rel="stylesheet" type="text/css" href="https://www.switsalone.com/wp-content/plugins/js_composer/assets/css/vc-ie8.css" media="screen"><![endif]--><script>
(function() {
	(function (i, s, o, g, r, a, m) {
		i['GoogleAnalyticsObject'] = r;
		i[r] = i[r] || function () {
				(i[r].q = i[r].q || []).push(arguments)
			}, i[r].l = 1 * new Date();
		a = s.createElement(o),
			m = s.getElementsByTagName(o)[0];
		a.async = 1;
		a.src = g;
		m.parentNode.insertBefore(a, m)
	})(window, document, 'script', 'https://google-analytics.com/analytics.js', 'ga');

	ga('create', 'UA-26764328-1', 'auto');
			ga('send', 'pageview');
	})();
</script>
<link rel="icon" href="https://www.switsalone.com/wp-content/uploads/cropped-switsalone-new-logo-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.switsalone.com/wp-content/uploads/cropped-switsalone-new-logo-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.switsalone.com/wp-content/uploads/cropped-switsalone-new-logo-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.switsalone.com/wp-content/uploads/cropped-switsalone-new-logo-1-270x270.png" />
<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>
<body data-rsssl=1 class="post-template-default single single-post postid-39042 single-format-standard et_bloom locale-en-us wpb-js-composer js-comp-ver-4.4.3 vc_responsive elementor-default elementor-kit-36814">
<a id="close-sidebar-nav" class="header-6"><i class="penci-faicon fa fa-close"></i></a>
<nav id="sidebar-nav" class="header-6" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">
<div id="sidebar-nav-logo">
<a href="https://www.switsalone.com/"><img class="penci-lazy" src="https://www.switsalone.com/wp-content/themes/soledad1/images/penci-holder.png" data-src="https://www.switsalone.com/wp-content/uploads/switsalone-new1s-logo.png" alt="Sierra Leone News" /></a>
</div>
<div class="header-social sidebar-nav-social">
<div class="inner-header-social">
<a href="https://www.facebook.com/switsalone" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-facebook"></i></a>
<a href="https://twitter.com/switsalone" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-twitter"></i></a>
<a href="https://www.instagram.com/switsalone/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-instagram"></i></a>
<a href="https://www.youtube.com/user/SwitSalone" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-youtube-play"></i></a>
</div> </div>
<ul id="menu-mmm" class="menu"><li id="menu-item-33840" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent penci-mega-menu menu-item-33840"><a href="https://www.switsalone.com/category/news-politics/">News &#038; Politics</a>
<ul class="sub-menu">
<li id="menu-item-0" class="menu-item-0"><div class="penci-megamenu">
<div class="penci-content-megamenu">
<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
<div class="penci-mega-row penci-mega-897 row-active">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/news-politics/">
News &amp; Politics </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2020/03/slnews-cover-510x390.jpeg" href="https://www.switsalone.com/39058_sierra-leone-news-today-161/" title="Sierra Leone News Today">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/39058_sierra-leone-news-today-161/" title="Sierra Leone News Today">Sierra Leone News Today</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-05-12T14:09:48+00:00">May 12, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/news-politics/">
News &amp; Politics </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/05/CG1-585x390.jpg" href="https://www.switsalone.com/39054_sierra-leone-news-today-160/" title="Sierra Leone News Today">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/39054_sierra-leone-news-today-160/" title="Sierra Leone News Today">Sierra Leone News Today</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-05-11T14:00:00+00:00">May 11, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/news-politics/">
News &amp; Politics </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/05/Dennis-Vandy-finance-minister-400x390.jpg" href="https://www.switsalone.com/39042_sierra-leone-news-today-159/" title="Sierra Leone News Today">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/39042_sierra-leone-news-today-159/" title="Sierra Leone News Today">Sierra Leone News Today</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-05-10T12:15:29+00:00">May 10, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/news-politics/">
News &amp; Politics </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/04/WhatsApp-Image-2021-04-01-at-16.48.13-e1617296835227-585x390.jpeg" href="https://www.switsalone.com/38891_sierra-leone-news-today-146/" title="Sierra Leone News Today">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/38891_sierra-leone-news-today-146/" title="Sierra Leone News Today">Sierra Leone News Today</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-04-01T17:10:24+00:00">April 1, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/news-politics/">
News &amp; Politics </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/Wizkid-Burna-Boy-585x390.png" href="https://www.switsalone.com/38766_nigerias-burna-boy-and-wizkid-win-grammy-awards/" title="Nigeria’s Burna Boy and Wizkid win Grammy Awards">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/38766_nigerias-burna-boy-and-wizkid-win-grammy-awards/" title="Nigeria’s Burna Boy and Wizkid win Grammy Awards">Nigeria’s Burna Boy and Wizkid win Grammy Awards</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-15T16:15:07+00:00">March 15, 2021</time></p>
</div>
</div>
</div>
</div>
</div>
</div></li>
</ul>
</li>
<li id="menu-item-33841" class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-33841"><a href="https://www.switsalone.com/category/entertainment/">Entertainment</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="penci-megamenu"> <div class="penci-mega-child-categories">
<a class="mega-cat-child" href="https://www.switsalone.com/category/entertainment/gossip-entertainment/" data-id="penci-mega-3269"><span>Gossip</span></a>
<a class="mega-cat-child cat-active all-style" href="https://www.switsalone.com/category/entertainment/" data-id="penci-mega-894"><span>All</span></a>
</div>
<div class="penci-content-megamenu">
<div class="penci-mega-latest-posts col-mn-4 mega-row-1">
<div class="penci-mega-row penci-mega-3269">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/entertainment/">Entertainment</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/Untitled-design-2-585x390.png" href="https://www.switsalone.com/38351_inside-salone-entertainment-whats-going-on-between-markmuday-and-samira/" title="Inside Salone Entertainment: What’s going on between Markmuday and Samira?">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/38351_inside-salone-entertainment-whats-going-on-between-markmuday-and-samira/" title="Inside Salone Entertainment: What’s going on between Markmuday and Samira?">Inside Salone Entertainment: What’s going on between Markmuday&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-02-05T14:00:49+00:00">February 5, 2021</time></p>
</div>
</div>
</div>
<div class="penci-mega-row penci-mega-894 row-active">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/entertainment/">Entertainment</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/05/181595404_308030017489129_2225981744003881725_n-526x390.jpg" href="https://www.switsalone.com/39045_listen-to-self-luv-remix-by-skillz-ft-drizlik-blaqbonze-and-enam/" title="Listen to “Self Luv remix” by Skillz ft Drizlik, Blaqbonze and Enam">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/39045_listen-to-self-luv-remix-by-skillz-ft-drizlik-blaqbonze-and-enam/" title="Listen to “Self Luv remix” by Skillz ft Drizlik, Blaqbonze and Enam">Listen to “Self Luv remix” by Skillz ft&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-05-10T16:57:26+00:00">May 10, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/entertainment/">Entertainment</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/04/NRP-Bringing_New_Audio_Formats_to_Facebook_header-585x390.jpg" href="https://www.switsalone.com/38955_facebook-announces-new-live-audio-experiences-and-monetization-feature/" title="Facebook Announces New Live Audio Experiences And Monetization Feature">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/38955_facebook-announces-new-live-audio-experiences-and-monetization-feature/" title="Facebook Announces New Live Audio Experiences And Monetization Feature">Facebook Announces New Live Audio Experiences And Monetization&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-04-21T17:11:11+00:00">April 21, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/entertainment/">Entertainment</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/161293257_803771033562373_4127832802742692878_n-400x390.jpg" href="https://www.switsalone.com/38789_breaking-news-president-bio-appoints-kao-denero-as-special-envoy-for-entertainment-in-sierra-leone/" title="Breaking News: President Bio appoints Kao Denero as Special Envoy for Entertainment in Sierra Leone">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/38789_breaking-news-president-bio-appoints-kao-denero-as-special-envoy-for-entertainment-in-sierra-leone/" title="Breaking News: President Bio appoints Kao Denero as Special Envoy for Entertainment in Sierra Leone">Breaking News: President Bio appoints Kao Denero as&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-16T20:47:50+00:00">March 16, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/entertainment/">Entertainment</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/EwH_9EtWYAEAU78-585x390.jpg" href="https://www.switsalone.com/38741_new-music-dj-rampage-releases-cum-featuring-tasha/" title="New Music: Dj Rampage releases “Cum” featuring Tasha">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/38741_new-music-dj-rampage-releases-cum-featuring-tasha/" title="New Music: Dj Rampage releases “Cum” featuring Tasha">New Music: Dj Rampage releases “Cum” featuring Tasha</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-10T18:56:26+00:00">March 10, 2021</time></p>
</div>
</div>
</div>
</div>
</div>
</div></li>
</ul>
</li>
<li id="menu-item-33843" class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-33843"><a href="https://www.switsalone.com/category/diaspora/">Diaspora</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="penci-megamenu">
<div class="penci-content-megamenu">
<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
<div class="penci-mega-row penci-mega-900 row-active">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/diaspora/">
Diaspora </a>
 </span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/05/African-Experts-FB-Instagram-585x390.png" href="https://www.switsalone.com/39011_african-expert-spotlight-meet-african-experts-show-guest-daniel-chaytor/" title="African Expert Spotlight: Meet African Experts Show Guest Daniel Chaytor">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/39011_african-expert-spotlight-meet-african-experts-show-guest-daniel-chaytor/" title="African Expert Spotlight: Meet African Experts Show Guest Daniel Chaytor">African Expert Spotlight: Meet African Experts Show Guest&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-05-05T15:05:26+00:00">May 5, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/diaspora/">
Diaspora </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/04/African-Experts-Twiiter-1-585x390.png" href="https://www.switsalone.com/38982_african-expert-spotlight-meet-african-experts-show-guest-leeann-rizk/" title="African Expert Spotlight: Meet African Experts Show Guest Leeann Rizk">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/38982_african-expert-spotlight-meet-african-experts-show-guest-leeann-rizk/" title="African Expert Spotlight: Meet African Experts Show Guest Leeann Rizk">African Expert Spotlight: Meet African Experts Show Guest&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-04-29T14:15:32+00:00">April 29, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/diaspora/">
Diaspora </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/2-585x390.png" href="https://www.switsalone.com/38858_african-expert-spotlight-meet-african-experts-show-guest-tamba-lamin/" title="African Expert Spotlight: Meet African Experts Show Guest Tamba Lamin">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/38858_african-expert-spotlight-meet-african-experts-show-guest-tamba-lamin/" title="African Expert Spotlight: Meet African Experts Show Guest Tamba Lamin">African Expert Spotlight: Meet African Experts Show Guest&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-26T19:37:53+00:00">March 26, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/diaspora/">
Diaspora </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/0_Alhaji-Sesayjfif-585x390.jpg" href="https://www.switsalone.com/38814_leone-stars-and-former-bristol-city-goalkeeper-sentenced-to-10-years-imprisonment-in-the-u-k/" title="Leone Stars and Former Bristol City Goalkeeper Sentenced to 10 Years Imprisonment in the U.K.">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/38814_leone-stars-and-former-bristol-city-goalkeeper-sentenced-to-10-years-imprisonment-in-the-u-k/" title="Leone Stars and Former Bristol City Goalkeeper Sentenced to 10 Years Imprisonment in the U.K.">Leone Stars and Former Bristol City Goalkeeper Sentenced&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-18T17:32:39+00:00">March 18, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/diaspora/">
Diaspora </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/ESWBQllXYAANyTo-585x390.jpg" href="https://www.switsalone.com/38695_world-book-day-celebrating-sierra-leonean-authors/" title="World Book Day: Celebrating Sierra Leonean authors">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/38695_world-book-day-celebrating-sierra-leonean-authors/" title="World Book Day: Celebrating Sierra Leonean authors">World Book Day: Celebrating Sierra Leonean authors</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-04T22:30:47+00:00">March 4, 2021</time></p>
</div>
</div>
</div>
</div>
</div>
</div></li>
</ul>
</li>
<li id="menu-item-33844" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent penci-mega-menu menu-item-33844"><a href="https://www.switsalone.com/category/people/">People</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="penci-megamenu"> <div class="penci-mega-child-categories">
<a class="mega-cat-child" href="https://www.switsalone.com/category/people/opinion/" data-id="penci-mega-2236"><span>Opinion</span></a>
<a class="mega-cat-child cat-active all-style" href="https://www.switsalone.com/category/people/" data-id="penci-mega-1391"><span>All</span></a>
</div>
<div class="penci-content-megamenu">
<div class="penci-mega-latest-posts col-mn-4 mega-row-1">
<div class="penci-mega-row penci-mega-2236">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/featured/">Featured</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/3-1-585x390.png" href="https://www.switsalone.com/38822_how-four-sierra-leonean-women-collaborated-to-end-period-poverty-for-300-girls/" title="How Four Sierra Leonean Women Collaborated to End Period Poverty for 300 Girls">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/38822_how-four-sierra-leonean-women-collaborated-to-end-period-poverty-for-300-girls/" title="How Four Sierra Leonean Women Collaborated to End Period Poverty for 300 Girls">How Four Sierra Leonean Women Collaborated to End&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-26T17:41:43+00:00">March 26, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/featured/">Featured</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/International-Womens-Day-2021-ChooseToChallenge-585x390.png" href="https://www.switsalone.com/38714_international-womens-day-2021-womens-rights-are-human-rights-choosetochallenge/" title="International Women’s Day 2021: Women’s rights are human rights #ChooseToChallenge">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/38714_international-womens-day-2021-womens-rights-are-human-rights-choosetochallenge/" title="International Women’s Day 2021: Women’s rights are human rights #ChooseToChallenge">International Women’s Day 2021: Women’s rights are human&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-08T18:11:06+00:00">March 8, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/entertainment/">Entertainment</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/Untitled-design-2-585x390.png" href="https://www.switsalone.com/38351_inside-salone-entertainment-whats-going-on-between-markmuday-and-samira/" title="Inside Salone Entertainment: What’s going on between Markmuday and Samira?">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/38351_inside-salone-entertainment-whats-going-on-between-markmuday-and-samira/" title="Inside Salone Entertainment: What’s going on between Markmuday and Samira?">Inside Salone Entertainment: What’s going on between Markmuday&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-02-05T14:00:49+00:00">February 5, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/featured/">Featured</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/ellakoblogulama-585x390.jpg" href="https://www.switsalone.com/38273_ella-koblo-gulama-day-the-queen-would-have-been-100-today/" title="Ella Koblo Gulama Day: The Queen would have been 100 today!">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/38273_ella-koblo-gulama-day-the-queen-would-have-been-100-today/" title="Ella Koblo Gulama Day: The Queen would have been 100 today!">Ella Koblo Gulama Day: The Queen would have&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-01-26T20:14:10+00:00">January 26, 2021</time></p>
</div>
</div>
</div>
<div class="penci-mega-row penci-mega-1391 row-active">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/people/">People</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2020/03/slnews-cover-510x390.jpeg" href="https://www.switsalone.com/39058_sierra-leone-news-today-161/" title="Sierra Leone News Today">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/39058_sierra-leone-news-today-161/" title="Sierra Leone News Today">Sierra Leone News Today</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-05-12T14:09:48+00:00">May 12, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/people/">People</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/05/CG1-585x390.jpg" href="https://www.switsalone.com/39054_sierra-leone-news-today-160/" title="Sierra Leone News Today">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/39054_sierra-leone-news-today-160/" title="Sierra Leone News Today">Sierra Leone News Today</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-05-11T14:00:00+00:00">May 11, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/people/">People</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/IMG_0159-585x390.jpg" href="https://www.switsalone.com/39049_sierra-leone-government-resolves-it-differences-with-sl-mining/" title="Sierra Leone Government resolved disputes with SL Mining">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/39049_sierra-leone-government-resolves-it-differences-with-sl-mining/" title="Sierra Leone Government resolved disputes with SL Mining">Sierra Leone Government resolved disputes with SL Mining</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-05-11T12:01:20+00:00">May 11, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/people/">People</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/05/181595404_308030017489129_2225981744003881725_n-526x390.jpg" href="https://www.switsalone.com/39045_listen-to-self-luv-remix-by-skillz-ft-drizlik-blaqbonze-and-enam/" title="Listen to “Self Luv remix” by Skillz ft Drizlik, Blaqbonze and Enam">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/39045_listen-to-self-luv-remix-by-skillz-ft-drizlik-blaqbonze-and-enam/" title="Listen to “Self Luv remix” by Skillz ft Drizlik, Blaqbonze and Enam">Listen to “Self Luv remix” by Skillz ft&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-05-10T16:57:26+00:00">May 10, 2021</time></p>
</div>
</div>
</div>
</div>
</div>
</div></li>
</ul>
</li>
<li id="menu-item-33846" class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-33846"><a href="https://www.switsalone.com/category/sports/">Sports</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="penci-megamenu">
<div class="penci-content-megamenu">
<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
<div class="penci-mega-row penci-mega-896 row-active">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/sports/">
Sports </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/05/WELCOME-Augustine-Williams_2021_1920x1080-585x390.jpg" href="https://www.switsalone.com/39023_la-galaxy-promotes-sierra-leonean-forward-augustine-williams-to-the-senior-team/" title="LA Galaxy promotes Sierra Leonean forward Augustine Williams to the senior team">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/39023_la-galaxy-promotes-sierra-leonean-forward-augustine-williams-to-the-senior-team/" title="LA Galaxy promotes Sierra Leonean forward Augustine Williams to the senior team">LA Galaxy promotes Sierra Leonean forward Augustine Williams&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-05-06T16:24:19+00:00">May 6, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/sports/">
Sports </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/05/Agric-Minister-Takes-Oath-of-Office-2-585x390.jpeg" href="https://www.switsalone.com/39019_sierra-leone-news-today-158/" title="Sierra Leone News Today">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/39019_sierra-leone-news-today-158/" title="Sierra Leone News Today">Sierra Leone News Today</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-05-06T13:20:52+00:00">May 6, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/sports/">
Sports </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/05/181610626_292943059003873_599082620011754406_n-585x390.jpg" href="https://www.switsalone.com/39002_sierra-leone-news-today-156/" title="Sierra Leone News Today">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/39002_sierra-leone-news-today-156/" title="Sierra Leone News Today">Sierra Leone News Today</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-05-04T14:55:24+00:00">May 4, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/sports/">
Sports </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/news-today-585x390.jpeg" href="https://www.switsalone.com/38976_sierra-leone-news-today-154/" title="Sierra Leone News Today">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/38976_sierra-leone-news-today-154/" title="Sierra Leone News Today">Sierra Leone News Today</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-04-26T15:07:11+00:00">April 26, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/sports/">
Sports </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/04/flag_yellow_high-585x390.jpg" href="https://www.switsalone.com/38941_sierra-leone-news-today-152/" title="Sierra Leone News Today">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/38941_sierra-leone-news-today-152/" title="Sierra Leone News Today">Sierra Leone News Today</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-04-20T13:38:07+00:00">April 20, 2021</time></p>
</div>
</div>
</div>
</div>
</div>
</div></li>
</ul>
</li>
</ul> </nav>
<div class="wrapper-boxed header-style-header-6">
<div class="penci-header-wrap"><div class="penci-top-bar topbar-menu">
<div class="container">
<div class="penci-headline" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">
<ul id="menu-topmen" class="penci-topbar-menu"><li id="menu-item-33862" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33862"><a href="https://www.switsalone.com/category/bars/">Bars</a></li>
<li id="menu-item-33863" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33863"><a href="https://www.switsalone.com/category/business-2/">Business</a></li>
<li id="menu-item-33864" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33864"><a href="https://www.switsalone.com/category/charity/">Charity</a></li>
<li id="menu-item-33865" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33865"><a href="https://www.switsalone.com/category/design/">Design</a></li>
<li id="menu-item-33866" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33866"><a href="https://www.switsalone.com/category/diaspora/">Diaspora</a></li>
<li id="menu-item-33867" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33867"><a href="https://www.switsalone.com/category/education/">Education</a></li>
<li id="menu-item-33868" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33868"><a href="https://www.switsalone.com/category/entertainment/">Entertainment</a></li>
<li id="menu-item-33869" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33869"><a href="https://www.switsalone.com/category/environment/">Environment</a></li>
<li id="menu-item-33870" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33870"><a href="https://www.switsalone.com/category/event-photos/">Event Photos</a></li>
<li id="menu-item-33871" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33871"><a href="https://www.switsalone.com/category/fashion-style/">Fashion &#038; Style</a></li>
<li id="menu-item-33872" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33872"><a href="https://www.switsalone.com/category/featured/">Featured</a></li>
<li id="menu-item-33873" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33873"><a href="https://www.switsalone.com/category/foodie/">Foodie</a></li>
<li id="menu-item-33874" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33874"><a href="https://www.switsalone.com/category/health-2/">Health</a></li>
<li id="menu-item-33875" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33875"><a href="https://www.switsalone.com/category/health-fitness/">Health &#038; Fitness</a></li>
<li id="menu-item-33876" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33876"><a href="https://www.switsalone.com/category/history/">History</a></li>
<li id="menu-item-33877" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33877"><a href="https://www.switsalone.com/category/hotels/">Hotels</a></li>
<li id="menu-item-33878" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33878"><a href="https://www.switsalone.com/category/lifestyle/">Lifestyle</a></li>
<li id="menu-item-33879" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-33879"><a href="https://www.switsalone.com/category/news/">News</a></li>
<li id="menu-item-33880" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-33880"><a href="https://www.switsalone.com/category/news-politics/">News &#038; Politics</a></li>
<li id="menu-item-33881" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-33881"><a href="https://www.switsalone.com/category/people/">People</a></li>
<li id="menu-item-33882" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33882"><a href="https://www.switsalone.com/category/people/opinion/">Opinion</a></li>
<li id="menu-item-33883" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33883"><a href="https://www.switsalone.com/category/places/">Places</a></li>
<li id="menu-item-33884" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33884"><a href="https://www.switsalone.com/category/politics-2/">Politics</a></li>
<li id="menu-item-33885" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33885"><a href="https://www.switsalone.com/category/recipes/">Recipes</a></li>
<li id="menu-item-33886" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33886"><a href="https://www.switsalone.com/category/love-and-relationships/">Relationships</a></li>
<li id="menu-item-33887" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33887"><a href="https://www.switsalone.com/category/religion/">Religion</a></li>
<li id="menu-item-33888" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33888"><a href="https://www.switsalone.com/category/restaurants/">Restaurants</a></li>
<li id="menu-item-33889" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33889"><a href="https://www.switsalone.com/category/sierraleoneweddings/">Sierra Leone Weddings</a></li>
<li id="menu-item-33890" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33890"><a href="https://www.switsalone.com/category/sports/">Sports</a></li>
<li id="menu-item-33891" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33891"><a href="https://www.switsalone.com/category/street-fashion/">Street Fashion</a></li>
<li id="menu-item-33892" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33892"><a href="https://www.switsalone.com/category/style-hunter/">Style Hunter</a></li>
<li id="menu-item-33893" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33893"><a href="https://www.switsalone.com/category/technology-2/">Technology</a></li>
<li id="menu-item-33894" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33894"><a href="https://www.switsalone.com/category/technology/">Technology</a></li>
<li id="menu-item-33895" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33895"><a href="https://www.switsalone.com/category/travel/">Travel</a></li>
<li id="menu-item-33896" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33896"><a href="https://www.switsalone.com/category/uncategorized/">Uncategorized</a></li>
<li id="menu-item-33897" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33897"><a href="https://www.switsalone.com/category/videos-2/">Videos</a></li>
<li id="menu-item-33898" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33898"><a href="https://www.switsalone.com/category/vogue/">Vogue</a></li>
<li id="menu-item-33899" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33899"><a href="https://www.switsalone.com/category/world/">World</a></li>
<li id="menu-item-33900" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33900"><a href="https://www.switsalone.com/category/youths/">youths</a></li>
</ul> <div class="penci-topbar-social">
<div class="inner-header-social">
<a href="https://www.facebook.com/switsalone" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-facebook"></i></a>
<a href="https://twitter.com/switsalone" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-twitter"></i></a>
<a href="https://www.instagram.com/switsalone/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-instagram"></i></a>
<a href="https://www.youtube.com/user/SwitSalone" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-youtube-play"></i></a>
</div> </div>
</div>
</div>
</div><header id="header" class="header-header-6 has-bottom-line" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
<nav id="navigation" class="header-layout-bottom header-6 menu-style-2 menu-item-padding" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">
<div class="container">
<div class="button-menu-mobile header-6"><i class="penci-faicon fa fa-bars"></i></div>
<div id="logo">
<a href="https://www.switsalone.com/">
<img class="penci-logo" src="https://www.switsalone.com/wp-content/uploads/switsalone-new1s-logo.png" alt="Sierra Leone News" />
</a>
</div><ul id="menu-mmm-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent penci-mega-menu menu-item-33840"><a href="https://www.switsalone.com/category/news-politics/">News &#038; Politics</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="penci-megamenu">
<div class="penci-content-megamenu">
<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
<div class="penci-mega-row penci-mega-897 row-active">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/news-politics/">
News &amp; Politics </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2020/03/slnews-cover-510x390.jpeg" href="https://www.switsalone.com/39058_sierra-leone-news-today-161/" title="Sierra Leone News Today">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/39058_sierra-leone-news-today-161/" title="Sierra Leone News Today">Sierra Leone News Today</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-05-12T14:09:48+00:00">May 12, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/news-politics/">
News &amp; Politics </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/05/CG1-585x390.jpg" href="https://www.switsalone.com/39054_sierra-leone-news-today-160/" title="Sierra Leone News Today">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/39054_sierra-leone-news-today-160/" title="Sierra Leone News Today">Sierra Leone News Today</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-05-11T14:00:00+00:00">May 11, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/news-politics/">
News &amp; Politics </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/05/Dennis-Vandy-finance-minister-400x390.jpg" href="https://www.switsalone.com/39042_sierra-leone-news-today-159/" title="Sierra Leone News Today">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/39042_sierra-leone-news-today-159/" title="Sierra Leone News Today">Sierra Leone News Today</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-05-10T12:15:29+00:00">May 10, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/news-politics/">
News &amp; Politics </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/04/WhatsApp-Image-2021-04-01-at-16.48.13-e1617296835227-585x390.jpeg" href="https://www.switsalone.com/38891_sierra-leone-news-today-146/" title="Sierra Leone News Today">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/38891_sierra-leone-news-today-146/" title="Sierra Leone News Today">Sierra Leone News Today</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-04-01T17:10:24+00:00">April 1, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/news-politics/">
News &amp; Politics </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/Wizkid-Burna-Boy-585x390.png" href="https://www.switsalone.com/38766_nigerias-burna-boy-and-wizkid-win-grammy-awards/" title="Nigeria’s Burna Boy and Wizkid win Grammy Awards">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/38766_nigerias-burna-boy-and-wizkid-win-grammy-awards/" title="Nigeria’s Burna Boy and Wizkid win Grammy Awards">Nigeria’s Burna Boy and Wizkid win Grammy Awards</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-15T16:15:07+00:00">March 15, 2021</time></p>
</div>
</div>
</div>
</div>
</div>
</div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-33841"><a href="https://www.switsalone.com/category/entertainment/">Entertainment</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="penci-megamenu"> <div class="penci-mega-child-categories">
<a class="mega-cat-child" href="https://www.switsalone.com/category/entertainment/gossip-entertainment/" data-id="penci-mega-3269"><span>Gossip</span></a>
<a class="mega-cat-child cat-active all-style" href="https://www.switsalone.com/category/entertainment/" data-id="penci-mega-894"><span>All</span></a>
</div>
<div class="penci-content-megamenu">
<div class="penci-mega-latest-posts col-mn-4 mega-row-1">
<div class="penci-mega-row penci-mega-3269">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/entertainment/">Entertainment</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/Untitled-design-2-585x390.png" href="https://www.switsalone.com/38351_inside-salone-entertainment-whats-going-on-between-markmuday-and-samira/" title="Inside Salone Entertainment: What’s going on between Markmuday and Samira?">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/38351_inside-salone-entertainment-whats-going-on-between-markmuday-and-samira/" title="Inside Salone Entertainment: What’s going on between Markmuday and Samira?">Inside Salone Entertainment: What’s going on between Markmuday&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-02-05T14:00:49+00:00">February 5, 2021</time></p>
</div>
</div>
</div>
<div class="penci-mega-row penci-mega-894 row-active">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/entertainment/">Entertainment</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/05/181595404_308030017489129_2225981744003881725_n-526x390.jpg" href="https://www.switsalone.com/39045_listen-to-self-luv-remix-by-skillz-ft-drizlik-blaqbonze-and-enam/" title="Listen to “Self Luv remix” by Skillz ft Drizlik, Blaqbonze and Enam">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/39045_listen-to-self-luv-remix-by-skillz-ft-drizlik-blaqbonze-and-enam/" title="Listen to “Self Luv remix” by Skillz ft Drizlik, Blaqbonze and Enam">Listen to “Self Luv remix” by Skillz ft&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-05-10T16:57:26+00:00">May 10, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/entertainment/">Entertainment</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/04/NRP-Bringing_New_Audio_Formats_to_Facebook_header-585x390.jpg" href="https://www.switsalone.com/38955_facebook-announces-new-live-audio-experiences-and-monetization-feature/" title="Facebook Announces New Live Audio Experiences And Monetization Feature">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/38955_facebook-announces-new-live-audio-experiences-and-monetization-feature/" title="Facebook Announces New Live Audio Experiences And Monetization Feature">Facebook Announces New Live Audio Experiences And Monetization&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-04-21T17:11:11+00:00">April 21, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
 <a href="https://www.switsalone.com/category/entertainment/">Entertainment</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/161293257_803771033562373_4127832802742692878_n-400x390.jpg" href="https://www.switsalone.com/38789_breaking-news-president-bio-appoints-kao-denero-as-special-envoy-for-entertainment-in-sierra-leone/" title="Breaking News: President Bio appoints Kao Denero as Special Envoy for Entertainment in Sierra Leone">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/38789_breaking-news-president-bio-appoints-kao-denero-as-special-envoy-for-entertainment-in-sierra-leone/" title="Breaking News: President Bio appoints Kao Denero as Special Envoy for Entertainment in Sierra Leone">Breaking News: President Bio appoints Kao Denero as&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-16T20:47:50+00:00">March 16, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/entertainment/">Entertainment</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/EwH_9EtWYAEAU78-585x390.jpg" href="https://www.switsalone.com/38741_new-music-dj-rampage-releases-cum-featuring-tasha/" title="New Music: Dj Rampage releases “Cum” featuring Tasha">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/38741_new-music-dj-rampage-releases-cum-featuring-tasha/" title="New Music: Dj Rampage releases “Cum” featuring Tasha">New Music: Dj Rampage releases “Cum” featuring Tasha</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-10T18:56:26+00:00">March 10, 2021</time></p>
</div>
</div>
</div>
</div>
</div>
</div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-33843"><a href="https://www.switsalone.com/category/diaspora/">Diaspora</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="penci-megamenu">
<div class="penci-content-megamenu">
<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
<div class="penci-mega-row penci-mega-900 row-active">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/diaspora/">
Diaspora </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/05/African-Experts-FB-Instagram-585x390.png" href="https://www.switsalone.com/39011_african-expert-spotlight-meet-african-experts-show-guest-daniel-chaytor/" title="African Expert Spotlight: Meet African Experts Show Guest Daniel Chaytor">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/39011_african-expert-spotlight-meet-african-experts-show-guest-daniel-chaytor/" title="African Expert Spotlight: Meet African Experts Show Guest Daniel Chaytor">African Expert Spotlight: Meet African Experts Show Guest&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-05-05T15:05:26+00:00">May 5, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
 <span class="mega-cat-name">
<a href="https://www.switsalone.com/category/diaspora/">
Diaspora </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/04/African-Experts-Twiiter-1-585x390.png" href="https://www.switsalone.com/38982_african-expert-spotlight-meet-african-experts-show-guest-leeann-rizk/" title="African Expert Spotlight: Meet African Experts Show Guest Leeann Rizk">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/38982_african-expert-spotlight-meet-african-experts-show-guest-leeann-rizk/" title="African Expert Spotlight: Meet African Experts Show Guest Leeann Rizk">African Expert Spotlight: Meet African Experts Show Guest&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-04-29T14:15:32+00:00">April 29, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/diaspora/">
Diaspora </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/2-585x390.png" href="https://www.switsalone.com/38858_african-expert-spotlight-meet-african-experts-show-guest-tamba-lamin/" title="African Expert Spotlight: Meet African Experts Show Guest Tamba Lamin">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/38858_african-expert-spotlight-meet-african-experts-show-guest-tamba-lamin/" title="African Expert Spotlight: Meet African Experts Show Guest Tamba Lamin">African Expert Spotlight: Meet African Experts Show Guest&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-26T19:37:53+00:00">March 26, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/diaspora/">
Diaspora </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/0_Alhaji-Sesayjfif-585x390.jpg" href="https://www.switsalone.com/38814_leone-stars-and-former-bristol-city-goalkeeper-sentenced-to-10-years-imprisonment-in-the-u-k/" title="Leone Stars and Former Bristol City Goalkeeper Sentenced to 10 Years Imprisonment in the U.K.">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/38814_leone-stars-and-former-bristol-city-goalkeeper-sentenced-to-10-years-imprisonment-in-the-u-k/" title="Leone Stars and Former Bristol City Goalkeeper Sentenced to 10 Years Imprisonment in the U.K.">Leone Stars and Former Bristol City Goalkeeper Sentenced&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-18T17:32:39+00:00">March 18, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/diaspora/">
Diaspora </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/ESWBQllXYAANyTo-585x390.jpg" href="https://www.switsalone.com/38695_world-book-day-celebrating-sierra-leonean-authors/" title="World Book Day: Celebrating Sierra Leonean authors">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/38695_world-book-day-celebrating-sierra-leonean-authors/" title="World Book Day: Celebrating Sierra Leonean authors">World Book Day: Celebrating Sierra Leonean authors</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-04T22:30:47+00:00">March 4, 2021</time></p>
</div>
</div>
</div>
</div>
</div>
</div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent penci-mega-menu menu-item-33844"><a href="https://www.switsalone.com/category/people/">People</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="penci-megamenu"> <div class="penci-mega-child-categories">
<a class="mega-cat-child" href="https://www.switsalone.com/category/people/opinion/" data-id="penci-mega-2236"><span>Opinion</span></a>
<a class="mega-cat-child cat-active all-style" href="https://www.switsalone.com/category/people/" data-id="penci-mega-1391"><span>All</span></a>
</div>
<div class="penci-content-megamenu">
<div class="penci-mega-latest-posts col-mn-4 mega-row-1">
<div class="penci-mega-row penci-mega-2236">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/featured/">Featured</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/3-1-585x390.png" href="https://www.switsalone.com/38822_how-four-sierra-leonean-women-collaborated-to-end-period-poverty-for-300-girls/" title="How Four Sierra Leonean Women Collaborated to End Period Poverty for 300 Girls">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/38822_how-four-sierra-leonean-women-collaborated-to-end-period-poverty-for-300-girls/" title="How Four Sierra Leonean Women Collaborated to End Period Poverty for 300 Girls">How Four Sierra Leonean Women Collaborated to End&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-26T17:41:43+00:00">March 26, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/featured/">Featured</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/International-Womens-Day-2021-ChooseToChallenge-585x390.png" href="https://www.switsalone.com/38714_international-womens-day-2021-womens-rights-are-human-rights-choosetochallenge/" title="International Women’s Day 2021: Women’s rights are human rights #ChooseToChallenge">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/38714_international-womens-day-2021-womens-rights-are-human-rights-choosetochallenge/" title="International Women’s Day 2021: Women’s rights are human rights #ChooseToChallenge">International Women’s Day 2021: Women’s rights are human&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-08T18:11:06+00:00">March 8, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
 <a href="https://www.switsalone.com/category/entertainment/">Entertainment</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/Untitled-design-2-585x390.png" href="https://www.switsalone.com/38351_inside-salone-entertainment-whats-going-on-between-markmuday-and-samira/" title="Inside Salone Entertainment: What’s going on between Markmuday and Samira?">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/38351_inside-salone-entertainment-whats-going-on-between-markmuday-and-samira/" title="Inside Salone Entertainment: What’s going on between Markmuday and Samira?">Inside Salone Entertainment: What’s going on between Markmuday&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-02-05T14:00:49+00:00">February 5, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/featured/">Featured</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/ellakoblogulama-585x390.jpg" href="https://www.switsalone.com/38273_ella-koblo-gulama-day-the-queen-would-have-been-100-today/" title="Ella Koblo Gulama Day: The Queen would have been 100 today!">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/38273_ella-koblo-gulama-day-the-queen-would-have-been-100-today/" title="Ella Koblo Gulama Day: The Queen would have been 100 today!">Ella Koblo Gulama Day: The Queen would have&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-01-26T20:14:10+00:00">January 26, 2021</time></p>
</div>
</div>
</div>
<div class="penci-mega-row penci-mega-1391 row-active">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/people/">People</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2020/03/slnews-cover-510x390.jpeg" href="https://www.switsalone.com/39058_sierra-leone-news-today-161/" title="Sierra Leone News Today">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/39058_sierra-leone-news-today-161/" title="Sierra Leone News Today">Sierra Leone News Today</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-05-12T14:09:48+00:00">May 12, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/people/">People</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/05/CG1-585x390.jpg" href="https://www.switsalone.com/39054_sierra-leone-news-today-160/" title="Sierra Leone News Today">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/39054_sierra-leone-news-today-160/" title="Sierra Leone News Today">Sierra Leone News Today</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-05-11T14:00:00+00:00">May 11, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/people/">People</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/IMG_0159-585x390.jpg" href="https://www.switsalone.com/39049_sierra-leone-government-resolves-it-differences-with-sl-mining/" title="Sierra Leone Government resolved disputes with SL Mining">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/39049_sierra-leone-government-resolves-it-differences-with-sl-mining/" title="Sierra Leone Government resolved disputes with SL Mining">Sierra Leone Government resolved disputes with SL Mining</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-05-11T12:01:20+00:00">May 11, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/people/">People</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/05/181595404_308030017489129_2225981744003881725_n-526x390.jpg" href="https://www.switsalone.com/39045_listen-to-self-luv-remix-by-skillz-ft-drizlik-blaqbonze-and-enam/" title="Listen to “Self Luv remix” by Skillz ft Drizlik, Blaqbonze and Enam">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/39045_listen-to-self-luv-remix-by-skillz-ft-drizlik-blaqbonze-and-enam/" title="Listen to “Self Luv remix” by Skillz ft Drizlik, Blaqbonze and Enam">Listen to “Self Luv remix” by Skillz ft&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-05-10T16:57:26+00:00">May 10, 2021</time></p>
</div>
</div>
</div>
</div>
</div>
</div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-33846"><a href="https://www.switsalone.com/category/sports/">Sports</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="penci-megamenu">
<div class="penci-content-megamenu">
<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
<div class="penci-mega-row penci-mega-896 row-active">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/sports/">
Sports </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/05/WELCOME-Augustine-Williams_2021_1920x1080-585x390.jpg" href="https://www.switsalone.com/39023_la-galaxy-promotes-sierra-leonean-forward-augustine-williams-to-the-senior-team/" title="LA Galaxy promotes Sierra Leonean forward Augustine Williams to the senior team">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/39023_la-galaxy-promotes-sierra-leonean-forward-augustine-williams-to-the-senior-team/" title="LA Galaxy promotes Sierra Leonean forward Augustine Williams to the senior team">LA Galaxy promotes Sierra Leonean forward Augustine Williams&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-05-06T16:24:19+00:00">May 6, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/sports/">
Sports </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/05/Agric-Minister-Takes-Oath-of-Office-2-585x390.jpeg" href="https://www.switsalone.com/39019_sierra-leone-news-today-158/" title="Sierra Leone News Today">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/39019_sierra-leone-news-today-158/" title="Sierra Leone News Today">Sierra Leone News Today</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-05-06T13:20:52+00:00">May 6, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/sports/">
Sports </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/05/181610626_292943059003873_599082620011754406_n-585x390.jpg" href="https://www.switsalone.com/39002_sierra-leone-news-today-156/" title="Sierra Leone News Today">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/39002_sierra-leone-news-today-156/" title="Sierra Leone News Today">Sierra Leone News Today</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-05-04T14:55:24+00:00">May 4, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/sports/">
Sports </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/news-today-585x390.jpeg" href="https://www.switsalone.com/38976_sierra-leone-news-today-154/" title="Sierra Leone News Today">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/38976_sierra-leone-news-today-154/" title="Sierra Leone News Today">Sierra Leone News Today</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-04-26T15:07:11+00:00">April 26, 2021</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.switsalone.com/category/sports/">
Sports </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2021/04/flag_yellow_high-585x390.jpg" href="https://www.switsalone.com/38941_sierra-leone-news-today-152/" title="Sierra Leone News Today">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.switsalone.com/38941_sierra-leone-news-today-152/" title="Sierra Leone News Today">Sierra Leone News Today</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2021-04-20T13:38:07+00:00">April 20, 2021</time></p>
</div>
</div>
</div>
</div>
</div>
</div></li>
</ul>
</li>
</ul><div id="top-search" class="dfdf">
<a class="search-click"><i class="penci-faicon fa fa-search"></i></a>
<div class="show-search">
<form role="search" method="get" id="searchform" action="https://www.switsalone.com/">
<div>
<input type="text" class="search-input" placeholder="Type and hit enter..." name="s" id="s" />
</div>
</form> <a class="search-click close-search"><i class="penci-faicon fa fa-close"></i></a>
</div>
</div>
</div>
</nav>
</header>

</div>
<div class="container penci-breadcrumb single-breadcrumb">
<span><a class="crumb" href="https://www.switsalone.com/">Home</a></span><i class="penci-faicon fa fa-angle-right"></i> <span><a class="crumb" href="https://www.switsalone.com/category/news/">News</a></span><i class="penci-faicon fa fa-angle-right"></i></i> <span>Sierra Leone News Today</span>
</div>
<div class="container container-single container-single-magazine penci_sidebar ">
<div id="main" class="penci-main-sticky-sidebar">
<div class="theiaStickySidebar">
<article id="post-39042" class="post type-post status-publish hentry">
<div class="header-standard header-classic single-header">
<div class="penci-standard-cat"><span class="cat"><a class="penci-cat-name" href="https://www.switsalone.com/category/news/" rel="category tag">News</a><a class="penci-cat-name" href="https://www.switsalone.com/category/news-politics/" rel="category tag">News &amp; Politics</a><a class="penci-cat-name" href="https://www.switsalone.com/category/people/" rel="category tag">People</a></span></div>
<h1 class="post-title single-post-title entry-title">Sierra Leone News Today</h1>
<div class="penci-hide-tagupdated">
<span class="author-italic author vcard">by <a class="url fn n" href="https://www.switsalone.com/author/alhassan-lamin/">Alhassan Lamin</a></span>
<time class="entry-date published" datetime="2021-05-10T12:15:29+00:00">May 10, 2021</time> </div>
<div class="post-box-meta-single">
<span class="author-post byline"><span class="author vcard">written by <a class="author-url url fn n" href="https://www.switsalone.com/author/alhassan-lamin/">Alhassan Lamin</a></span></span>
<span><time class="entry-date published" datetime="2021-05-10T12:15:29+00:00">May 10, 2021</time></span>
<span><i class="penci-post-countview-number">98</i> views</span>
</div>
</div>
<div class="post-image">
<img class="attachment-penci-full-thumb size-penci-full-thumb penci-lazy wp-post-image" src="https://www.switsalone.com/wp-content/themes/soledad1/images/penci2-holder.png" alt="" title="Dennis-Vandy-finance-minister" data-src="https://www.switsalone.com/wp-content/uploads/2021/05/Dennis-Vandy-finance-minister.jpg">
</div>
<div class="post-entry blockquote-style-2">
<div class="inner-post-entry entry-content" id="penci-post-entry-inner">
<p><strong>President Bio appoints former Agriculture Minister as Finance Minister</strong></p>
<p>President Julius Maada Bio has on Friday, May 7, 2021, appointed <a href="https://www.facebook.com/keketomayusuf/posts/10222769304714641">Dr. Dennis Vandi as the country&#8217;s new Minister of Finance replacing Jacob Jusu Saffa</a> who is now Chief Minister. Dr. Vandi was the Minister of Agriculture and was suspended from his duty after president Bio suspended all civil servants and public officials accused of acting improperly with respect to the use of public funds by the Commission of Inquiry. He was the Permanent Secretary at the Ministry of Education under the administration of the APC government. <br></p>
<p><strong>Government of Sierra Leone pay 50 percent salary increment to staff of tertiary institutions</strong></p>
<p>The Government of Sierra Leone through the Ministry of Finance and the Ministry of Technical and Higher Education has in a press release stated that the government has paid the <a href="https://www.facebook.com/amadulamrana.bah/posts/10158347737682523">50 percent salary increment to all staff of public tertiary institutions.</a> The payment is part of an agreement&nbsp; between President Julius Maada Bio and members of the Academic Staff Associations of different Tertiary Educational Institutions. Also, in the release it was stated that the government has paid subvention support to these institutions for the first quarter of 2021.&nbsp;<br></p>
<p><strong>800,000 youths corps to receive four months backlog stipends</strong></p>
<p>The Minister of Youth Affairs, Mohamed orman Bangura has confirmed that the <a href="https://www.facebook.com/SaloneYouth/posts/915143245994074">government has approved the payment for 800,000 youth corps </a>to receive a stipend for four months after being working for that period without stipends. According to the Minister the delay for the payment was a result of the unaccountability and his ministry not being transparent.  </p>
<p><strong>169 inmates released on Presidential pardon</strong></p>
<p>President Julius Maada Bio has permitted the release of 169 convicted inmates from correctional centers across the country. The list consists of 8 females and 161 males. These release are granted by constitution as the president is given the power to authorized the release of inmates based on reccommnedations of the correctional service for prisoners not serving jail term foer serious crimes such as robbery, murder, and many others. This is happening every year on New Year’s day and Independence Day.  <strong><br></strong></p>
<div class="crp_related  "><h3>Related Posts:</h3><ul><li><a href="https://www.switsalone.com/33775_todays-sierra-leone-print-news-roundup-acc-to-examine-auditor-generals-report-ayv-miss-university-holds-today-and-more/" class="crp_link post-33775"><span class="crp_title">Today's Sierra Leone Print news Roundup, ACC to&hellip;</span></a></li><li><a href="https://www.switsalone.com/33783_todays-sierra-leone-print-news-roundup-idris-elba-dismiss-fake-news-nassit-sponsor-sick-pikin-marathon-walk-and-more/" class="crp_link post-33783"><span class="crp_title">Today's Sierra Leone Print News roundup, Idris Elba&hellip;</span></a></li><li><a href="https://www.switsalone.com/35130_sierra-leone-news-today-5/" class="crp_link post-35130"><span class="crp_title">Sierra Leone News Today</span></a></li><li><a href="https://www.switsalone.com/35550_sierra-leone-news-today-13/" class="crp_link post-35550"><span class="crp_title">Sierra Leone News Today</span></a></li><li><a href="https://www.switsalone.com/34883_sierra-leone-news-today/" class="crp_link post-34883"><span class="crp_title">Sierra Leone News Today</span></a></li><li><a href="https://www.switsalone.com/34891_sierra-leone-news-today-2/" class="crp_link post-34891"><span class="crp_title">Sierra Leone News Today</span></a></li></ul><div class="crp_clear"></div></div><span class="et_bloom_bottom_trigger"></span>
<div class="penci-single-link-pages">
</div>
<div class="post-tags">
<a href="https://www.switsalone.com/tag/sierra-leone-news/" rel="tag">Sierra Leone news</a> </div>
</div>
</div>
<div class="tags-share-box center-box tags-share-box-s1">
<span class="single-comment-o"><i class="penci-faicon fa fa-comment-o"></i><span class="dsq-postid" data-dsqidentifier="39042 https://www.switsalone.com/?p=39042">0 comment</span></span>
<div class="post-share">
<span class="post-share-item post-share-plike"><span class="count-number-like">0</span><a class="penci-post-like single-like-button" data-post_id="39042" title="Like" data-like="Like" data-unlike="Unlike"><i class="penci-faicon fa fa-heart-o"></i></a></span>
<div class="list-posts-share"><a class="post-share-item post-share-facebook" target="_blank" rel="nofollow" href="https://www.facebook.com/sharer/sharer.php?u=https://www.switsalone.com/39042_sierra-leone-news-today-159/"><i class="penci-faicon fa fa-facebook"></i><span class="dt-share">Facebook</span></a><a class="post-share-item post-share-twitter" target="_blank" rel="nofollow" href="https://twitter.com/intent/tweet?text=Check%20out%20this%20article:%20Sierra%20Leone%20News%20Today%20-%20https://www.switsalone.com/39042_sierra-leone-news-today-159/"><i class="penci-faicon fa fa-twitter"></i><span class="dt-share">Twitter</span></a><a class="post-share-item post-share-pinterest" data-pin-do="none" rel="nofollow noreferrer noopener" onclick="var e=document.createElement('script');e.setAttribute('type','text/javascript');e.setAttribute('charset','UTF-8');e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e);"><i class="penci-faicon fa fa-pinterest"></i><span class="dt-share">Pinterest</span></a></div> </div>
</div>
<div class="post-pagination">
<div class="prev-post">
<a class="penci-post-nav-thumb penci-holder-load penci-lazy" href="https://www.switsalone.com/39026_gef-small-grants-stories-swamp-farms-increase-food-security-and-prevent-deforestation-in-gola-forest-communities/" data-src="https://www.switsalone.com/wp-content/uploads/2021/05/Gabriel-Fatoma-Grantee-150x100.jpg">
</a>
<div class="prev-post-inner">
<div class="prev-post-title">
<span>previous post</span>
</div>
<a href="https://www.switsalone.com/39026_gef-small-grants-stories-swamp-farms-increase-food-security-and-prevent-deforestation-in-gola-forest-communities/">
<div class="pagi-text">
<h5 class="prev-title">GEF Small Grants Stories: Swamp Farms increase Food Security, and Prevent Deforestation in Gola Forest Communities</h5>
</div>
</a>
</div>
</div>
<div class="next-post">
<a class="penci-post-nav-thumb penci-holder-load penci-lazy nav-thumb-next" href="https://www.switsalone.com/39045_listen-to-self-luv-remix-by-skillz-ft-drizlik-blaqbonze-and-enam/" data-src="https://www.switsalone.com/wp-content/uploads/2021/05/181595404_308030017489129_2225981744003881725_n-150x150.jpg">
</a>
<div class="next-post-inner">
<div class="prev-post-title next-post-title">
<span>next post</span>
</div>
<a href="https://www.switsalone.com/39045_listen-to-self-luv-remix-by-skillz-ft-drizlik-blaqbonze-and-enam/">
<div class="pagi-text">
<h5 class="next-title">Listen to “Self Luv remix” by Skillz ft Drizlik, Blaqbonze and Enam</h5>
</div>
</a>
</div>
</div>
</div>
<div class="post-related penci-posts-related-grid">
<div class="post-title-box"><h4 class="post-box-title">Related Articles</h4></div>
<div class="penci-related-carousel penci-related-grid-display">
<div class="item-related">
<a class="related-thumb penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/president-Bio-speaks-at-TED-1.jpg" href="https://www.switsalone.com/31497_ted-talk-a-vision-for-the-future-of-sierraleone-president-julius-maada-bio-watch-now/" title="Ted Talk: A vision for the future of #SierraLeone &#8211; President Julius Maada Bio (Watch Now)">
</a>
<h3><a href="https://www.switsalone.com/31497_ted-talk-a-vision-for-the-future-of-sierraleone-president-julius-maada-bio-watch-now/">Ted Talk: A vision for the future of...</a></h3>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2020/03/slnews-cover-510x390.jpeg" href="https://www.switsalone.com/36786_sierra-leone-news-today-57/" title="Sierra Leone News Today">
</a>
<h3><a href="https://www.switsalone.com/36786_sierra-leone-news-today-57/">Sierra Leone News Today</a></h3>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/12273763_10207809570975599_2925788735809763439_o.jpg" href="https://www.switsalone.com/24421_sierra-leones-fastest-woman-hafsatu-kamara-is-off-to-rio-olympics/" title="Sierra Leone&#8217;s fastest woman, Hafsatu Kamara, is off to Rio Olympics">
</a>
<h3><a href="https://www.switsalone.com/24421_sierra-leones-fastest-woman-hafsatu-kamara-is-off-to-rio-olympics/">Sierra Leone&#8217;s fastest woman, Hafsatu Kamara, is off...</a></h3>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2020/08/IMG_20170804_171554-585x351.jpg" href="https://www.switsalone.com/37119_sierra-leones-national-team-names-new-coach/" title="Sierra Leone’s National Team Names New Coach">
</a>
<h3><a href="https://www.switsalone.com/37119_sierra-leones-national-team-names-new-coach/">Sierra Leone’s National Team Names New Coach</a></h3>
</div>
<div class="item-related">
<h3><a href="https://www.switsalone.com/10095_after-months-of-delay-african-minerals/">After months of delay African Minerals secures $1.5bn...</a></h3>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/socialmediaforinstitutions-training-vrcmarketing-socialmedia.png" href="https://www.switsalone.com/25616_sierra-leone-vrc-marketing-launches-social-media-for-institutions-training-for-business/" title="Sierra Leone: VRC Marketing launches Social Media for Institutions, training for Business">
</a>
<h3><a href="https://www.switsalone.com/25616_sierra-leone-vrc-marketing-launches-social-media-for-institutions-training-for-business/">Sierra Leone: VRC Marketing launches Social Media for...</a></h3>
</div>
<div class="item-related">
<h3><a href="https://www.switsalone.com/10129_iron-ore-exports-will-boost-sierra/">Iron ore exports will boost Sierra Leone&#8217;s economy...</a></h3>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/2020/05/vandi-sombie-585x379.jpg" href="https://www.switsalone.com/36511_sierra-leone-lost-its-first-medical-front-liner-to-covid-19/" title="Sierra Leone lost its first medical front liner to COVID-19">
</a>
<h3><a href="https://www.switsalone.com/36511_sierra-leone-lost-its-first-medical-front-liner-to-covid-19/">Sierra Leone lost its first medical front liner...</a></h3>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder penci-lazy" data-src="https://www.switsalone.com/wp-content/uploads/Image-21.jpg" href="https://www.switsalone.com/15358_l-a-j-denero-end-hip-hop-rivalry-at-concert-in-sierra-leone/" title="L A J, Denero end hip hop rivalry at concert in Sierra Leone">
</a>
<h3><a href="https://www.switsalone.com/15358_l-a-j-denero-end-hip-hop-rivalry-at-concert-in-sierra-leone/">L A J, Denero end hip hop rivalry...</a></h3>
</div>
</div></div>
<div id="disqus_thread"></div>
</article> </div>
</div>
<div id="sidebar" class="penci-sidebar-right penci-sidebar-content style-2 pcalign-center penci-sticky-sidebar">
<div class="theiaStickySidebar">
<aside id="penci_social_widget-3" class="widget penci_social_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Social Media</span></h4>
<div class="widget-social pc_aligncenter show-text">
<a href="https://www.facebook.com/switsalone" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-facebook" style="font-size: 14px"></i><span style="font-size: 13px">Facebook</span></a>
<a href="https://twitter.com/switsalone" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-twitter" style="font-size: 14px"></i><span style="font-size: 13px">Twitter</span></a>
<a href="https://www.instagram.com/switsalone/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-instagram" style="font-size: 14px"></i><span style="font-size: 13px">Instagram</span></a>
<a href="https://www.youtube.com/user/SwitSalone" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-youtube-play" style="font-size: 14px"></i><span style="font-size: 13px">Youtube</span></a>
</div>
</aside><aside id="widget_sp_image-12" class="widget widget_sp_image"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Vickie Remoe&#8217;s Blog</span></h4><a href="http://www.vickieremoe.com" target="_self" class="widget_sp_image-image-link" title="Vickie Remoe&#8217;s Blog"><img width="925" height="925" alt="Vickie Remoe&#8217;s Blog" class="attachment-full" style="max-width: 100%;" srcset="https://www.switsalone.com/wp-content/uploads/VickieRemoe-VickieRemoeShow-AYVTV-SierraLeone.jpg 925w, https://www.switsalone.com/wp-content/uploads/VickieRemoe-VickieRemoeShow-AYVTV-SierraLeone-150x150.jpg 150w, https://www.switsalone.com/wp-content/uploads/VickieRemoe-VickieRemoeShow-AYVTV-SierraLeone-450x450.jpg 450w, https://www.switsalone.com/wp-content/uploads/VickieRemoe-VickieRemoeShow-AYVTV-SierraLeone-768x768.jpg 768w, https://www.switsalone.com/wp-content/uploads/VickieRemoe-VickieRemoeShow-AYVTV-SierraLeone-696x696.jpg 696w, https://www.switsalone.com/wp-content/uploads/VickieRemoe-VickieRemoeShow-AYVTV-SierraLeone-420x420.jpg 420w, https://www.switsalone.com/wp-content/uploads/VickieRemoe-VickieRemoeShow-AYVTV-SierraLeone-610x610.jpg 610w" sizes="(max-width: 925px) 100vw, 925px" src="https://www.switsalone.com/wp-content/uploads/VickieRemoe-VickieRemoeShow-AYVTV-SierraLeone.jpg" /></a></aside><aside id="widget_sp_image-5" class="widget widget_sp_image"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">VR&#038;C Marketing</span></h4><a href="http://www.vrcmarketing.com" target="_self" class="widget_sp_image-image-link" title="VR&#038;C Marketing"><img width="1136" height="623" alt="VR&#038;C Marketing" class="attachment-full" style="max-width: 100%;" srcset="https://www.switsalone.com/wp-content/uploads/socialmediaforinstitutions-training-vrcmarketing-socialmedia.png 1136w, https://www.switsalone.com/wp-content/uploads/socialmediaforinstitutions-training-vrcmarketing-socialmedia-450x247.png 450w, https://www.switsalone.com/wp-content/uploads/socialmediaforinstitutions-training-vrcmarketing-socialmedia-768x421.png 768w, https://www.switsalone.com/wp-content/uploads/socialmediaforinstitutions-training-vrcmarketing-socialmedia-696x382.png 696w, https://www.switsalone.com/wp-content/uploads/socialmediaforinstitutions-training-vrcmarketing-socialmedia-1068x586.png 1068w, https://www.switsalone.com/wp-content/uploads/socialmediaforinstitutions-training-vrcmarketing-socialmedia-766x420.png 766w, https://www.switsalone.com/wp-content/uploads/socialmediaforinstitutions-training-vrcmarketing-socialmedia-610x335.png 610w" sizes="(max-width: 1136px) 100vw, 1136px" src="https://www.switsalone.com/wp-content/uploads/socialmediaforinstitutions-training-vrcmarketing-socialmedia.png" /></a></aside><aside id="widget_sp_image-16" class="widget widget_sp_image"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Contact us for fascinating, meaningful, newsworthy, local content</span></h4><a href="http://www.vrcmarketing.com" target="_self" class="widget_sp_image-image-link" title="Contact us for fascinating, meaningful, newsworthy, local content"><img width="940" height="788" alt="Contact us for fascinating, meaningful, newsworthy, local content" class="attachment-full" style="max-width: 100%;" srcset="https://www.switsalone.com/wp-content/uploads/WanDeYa-VRC1.png 940w, https://www.switsalone.com/wp-content/uploads/WanDeYa-VRC1-450x377.png 450w, https://www.switsalone.com/wp-content/uploads/WanDeYa-VRC1-768x644.png 768w, https://www.switsalone.com/wp-content/uploads/WanDeYa-VRC1-610x511.png 610w, https://www.switsalone.com/wp-content/uploads/WanDeYa-VRC1-585x490.png 585w" sizes="(max-width: 940px) 100vw, 940px" src="https://www.switsalone.com/wp-content/uploads/WanDeYa-VRC1.png" /></a></aside> </div>
</div>
</div>
<div class="clear-footer"></div>
<div id="widget-area">
<div class="container">
<div class="footer-widget-wrapper footer-widget-style-1">
<aside id="text-5" class="widget widget_text"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">About switsalone</span></h4> <div class="textwidget"><p><img src="https://www.switsalone.com/wp-content/uploads/switsalone-newws-logo.png" alt="" width="697" height="161" class="alignleft size-full wp-image-33903" /><br />
Switsalone is your business, news, entertainment, fashion platform for Africans at home and in the diaspora.. We provide you with the latest breaking news and media content from the continent and beyond</p>
</div>
</aside><aside id="penci_social_widget-2" class="widget penci_social_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Keep in touch</span></h4>
<div class="widget-social pc_aligncenter">
<a href="https://www.facebook.com/switsalone" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-facebook" style="font-size: 14px"></i><span style="font-size: 13px">Facebook</span></a>
<a href="https://twitter.com/switsalone" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-twitter" style="font-size: 14px"></i><span style="font-size: 13px">Twitter</span></a>
<a href="https://www.instagram.com/switsalone/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-instagram" style="font-size: 14px"></i><span style="font-size: 13px">Instagram</span></a>
<a href="" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-pinterest" style="font-size: 14px"></i><span style="font-size: 13px">Pinterest</span></a>
</div>
</aside> </div>
<div class="footer-widget-wrapper footer-widget-style-1">
<aside id="penci_popular_news_widget-2" class="widget penci_popular_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Popular Posts</span></h4> <ul id="penci-popularwg-3454" class="side-newsfeed">
<li class="penci-feed featured-news">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/05/African-Experts-FB-Instagram-1-585x390.png" href="https://www.switsalone.com/39060_african-expert-spotlight-meet-african-experts-show-guest-paul-azunre/" title="African Expert Spotlight: Meet African Experts Show Guest Paul Azunre"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/39060_african-expert-spotlight-meet-african-experts-show-guest-paul-azunre/" rel="bookmark" title="African Expert Spotlight: Meet African Experts Show Guest Paul Azunre">
African Expert Spotlight: Meet African Experts Show Guest Paul Azunre </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/IMG_0159-263x175.jpg" href="https://www.switsalone.com/39049_sierra-leone-government-resolves-it-differences-with-sl-mining/" title="Sierra Leone Government resolved disputes with SL Mining"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
 <a href="https://www.switsalone.com/39049_sierra-leone-government-resolves-it-differences-with-sl-mining/" rel="bookmark" title="Sierra Leone Government resolved disputes with SL Mining">
Sierra Leone Government resolved disputes with SL Mining </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/05/Gabriel-Fatoma-Grantee-263x175.jpg" href="https://www.switsalone.com/39026_gef-small-grants-stories-swamp-farms-increase-food-security-and-prevent-deforestation-in-gola-forest-communities/" title="GEF Small Grants Stories: Swamp Farms increase Food Security, and Prevent Deforestation in Gola Forest Communities"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/39026_gef-small-grants-stories-swamp-farms-increase-food-security-and-prevent-deforestation-in-gola-forest-communities/" rel="bookmark" title="GEF Small Grants Stories: Swamp Farms increase Food Security, and Prevent Deforestation in Gola Forest Communities">
GEF Small Grants Stories: Swamp Farms increase Food Security, and Prevent Deforestation in Gola Forest Communities </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/05/WELCOME-Augustine-Williams_2021_1920x1080-263x175.jpg" href="https://www.switsalone.com/39023_la-galaxy-promotes-sierra-leonean-forward-augustine-williams-to-the-senior-team/" title="LA Galaxy promotes Sierra Leonean forward Augustine Williams to the senior team"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/39023_la-galaxy-promotes-sierra-leonean-forward-augustine-williams-to-the-senior-team/" rel="bookmark" title="LA Galaxy promotes Sierra Leonean forward Augustine Williams to the senior team">
LA Galaxy promotes Sierra Leonean forward Augustine Williams to the senior team </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/05/African-Experts-FB-Instagram-263x175.png" href="https://www.switsalone.com/39011_african-expert-spotlight-meet-african-experts-show-guest-daniel-chaytor/" title="African Expert Spotlight: Meet African Experts Show Guest Daniel Chaytor"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/39011_african-expert-spotlight-meet-african-experts-show-guest-daniel-chaytor/" rel="bookmark" title="African Expert Spotlight: Meet African Experts Show Guest Daniel Chaytor">
African Expert Spotlight: Meet African Experts Show Guest Daniel Chaytor </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/05/179778989_10165032268230297_3573771963317607610_n-263x175.jpg" href="https://www.switsalone.com/39005_government-of-sierra-leone-lifts-ban-on-overseas-recruitment/" title="Government of Sierra Leone lifts ban on overseas recruitment"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/39005_government-of-sierra-leone-lifts-ban-on-overseas-recruitment/" rel="bookmark" title="Government of Sierra Leone lifts ban on overseas recruitment">
Government of Sierra Leone lifts ban on overseas recruitment </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/Coat_of_arms_of_Sierra_Leone-263x175.png" href="https://www.switsalone.com/38988_government-of-sierra-leone-announces-new-cabinet-reshuffle-2/" title="Government of Sierra Leone Announces New Cabinet Reshuffle"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38988_government-of-sierra-leone-announces-new-cabinet-reshuffle-2/" rel="bookmark" title="Government of Sierra Leone Announces New Cabinet Reshuffle">
Government of Sierra Leone Announces New Cabinet Reshuffle </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/04/African-Experts-Twiiter-1-263x175.png" href="https://www.switsalone.com/38982_african-expert-spotlight-meet-african-experts-show-guest-leeann-rizk/" title="African Expert Spotlight: Meet African Experts Show Guest Leeann Rizk"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38982_african-expert-spotlight-meet-african-experts-show-guest-leeann-rizk/" rel="bookmark" title="African Expert Spotlight: Meet African Experts Show Guest Leeann Rizk">
African Expert Spotlight: Meet African Experts Show Guest Leeann Rizk </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/04/NRP-Bringing_New_Audio_Formats_to_Facebook_header-263x175.jpg" href="https://www.switsalone.com/38955_facebook-announces-new-live-audio-experiences-and-monetization-feature/" title="Facebook Announces New Live Audio Experiences And Monetization Feature"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38955_facebook-announces-new-live-audio-experiences-and-monetization-feature/" rel="bookmark" title="Facebook Announces New Live Audio Experiences And Monetization Feature">
Facebook Announces New Live Audio Experiences And Monetization Feature </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/04/African-Experts-Twiiter-263x175.png" href="https://www.switsalone.com/38932_african-expert-spotlight-meet-african-experts-show-guest-beatrice-chaytor/" title="African Expert Spotlight: Meet African Experts Show Guest Beatrice Chaytor"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38932_african-expert-spotlight-meet-african-experts-show-guest-beatrice-chaytor/" rel="bookmark" title="African Expert Spotlight: Meet African Experts Show Guest Beatrice Chaytor">
African Expert Spotlight: Meet African Experts Show Guest Beatrice Chaytor </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/04/EysfivuWUAAA4Wn-263x175.jpg" href="https://www.switsalone.com/38922_african-expert-spotlight-meet-african-experts-show-guest-tamu-thomas/" title="African Expert Spotlight: Meet African Experts Show Guest Tamu Thomas"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38922_african-expert-spotlight-meet-african-experts-show-guest-tamu-thomas/" rel="bookmark" title="African Expert Spotlight: Meet African Experts Show Guest Tamu Thomas">
African Expert Spotlight: Meet African Experts Show Guest Tamu Thomas </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/04/Gandoh-Practice-1-263x175.png" href="https://www.switsalone.com/38894_african-expert-spotlight-meet-african-experts-show-guest-franklin-ibemessie/" title="African Expert Spotlight: Meet African Experts Show Guest Franklin Ibemessie"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38894_african-expert-spotlight-meet-african-experts-show-guest-franklin-ibemessie/" rel="bookmark" title="African Expert Spotlight: Meet African Experts Show Guest Franklin Ibemessie">
African Expert Spotlight: Meet African Experts Show Guest Franklin Ibemessie </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/3-1-263x175.png" href="https://www.switsalone.com/38822_how-four-sierra-leonean-women-collaborated-to-end-period-poverty-for-300-girls/" title="How Four Sierra Leonean Women Collaborated to End Period Poverty for 300 Girls"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38822_how-four-sierra-leonean-women-collaborated-to-end-period-poverty-for-300-girls/" rel="bookmark" title="How Four Sierra Leonean Women Collaborated to End Period Poverty for 300 Girls">
How Four Sierra Leonean Women Collaborated to End Period Poverty for 300 Girls </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/unido-01-1024x850-1-263x175.jpg" href="https://www.switsalone.com/38852_unido-signs-3-88-million-agreement-to-establish-four-ultra-modern-automotive-centers/" title="UNIDO Signs $3.88 Million Agreement to Establish Four Ultra-Modern Automotive Centers"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38852_unido-signs-3-88-million-agreement-to-establish-four-ultra-modern-automotive-centers/" rel="bookmark" title="UNIDO Signs $3.88 Million Agreement to Establish Four Ultra-Modern Automotive Centers">
UNIDO Signs $3.88 Million Agreement to Establish Four Ultra-Modern Automotive Centers </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/164563003_794430147878098_7376313733205515128_n-1-263x175.jpg" href="https://www.switsalone.com/38839_devastating-fire-incident-in-susans-bay-left-thousands-of-people-homeless/" title="Devastating fire incident in Susan’s Bay leaves thousands of people homeless"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38839_devastating-fire-incident-in-susans-bay-left-thousands-of-people-homeless/" rel="bookmark" title="Devastating fire incident in Susan’s Bay leaves thousands of people homeless">
Devastating fire incident in Susan’s Bay leaves thousands of people homeless </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/leone-star-263x175.jpg" href="https://www.switsalone.com/38827_leone-stars-departs-for-lesotho-in-their-2021-african-cup-of-nations-qualification-bid/" title="Leone Stars Departs for Lesotho in their 2021 African Cup of Nations Qualification Bid"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38827_leone-stars-departs-for-lesotho-in-their-2021-african-cup-of-nations-qualification-bid/" rel="bookmark" title="Leone Stars Departs for Lesotho in their 2021 African Cup of Nations Qualification Bid">
Leone Stars Departs for Lesotho in their 2021 African Cup of Nations Qualification Bid </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/WhatsApp-Image-2021-03-24-at-4.29.31-AM-263x175.jpeg" href="https://www.switsalone.com/38832_sierra-leone-ends-12-months-state-of-public-health-emergency/" title="Sierra Leone ends 12 months State of Public Health Emergency"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38832_sierra-leone-ends-12-months-state-of-public-health-emergency/" rel="bookmark" title="Sierra Leone ends 12 months State of Public Health Emergency">
Sierra Leone ends 12 months State of Public Health Emergency </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/US-ambassador-263x175.jpg" href="https://www.switsalone.com/38806_who-is-david-reimer-the-new-u-s-ambassador-to-sierra-leone/" title="Who is  David Reimer the New U.S. Ambassador to Sierra Leone."></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38806_who-is-david-reimer-the-new-u-s-ambassador-to-sierra-leone/" rel="bookmark" title="Who is  David Reimer the New U.S. Ambassador to Sierra Leone.">
Who is David Reimer the New U.S. Ambassador to Sierra Leone. </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/WhatsApp-Image-2021-03-15-at-7.42.24-AM-263x175.jpeg" href="https://www.switsalone.com/38795_make-sierra-leone-famous-podcast-ep11-sierra-leoneans-who-shaped-history-with-akindele-decker/" title="Make Sierra Leone Famous Podcast Ep11 –Sierra Leoneans Who Shaped History with Akindele Decker"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38795_make-sierra-leone-famous-podcast-ep11-sierra-leoneans-who-shaped-history-with-akindele-decker/" rel="bookmark" title="Make Sierra Leone Famous Podcast Ep11 –Sierra Leoneans Who Shaped History with Akindele Decker">
Make Sierra Leone Famous Podcast Ep11 –Sierra Leoneans Who Shaped History with Akindele Decker </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/Agro-processing-263x175.jpg" href="https://www.switsalone.com/38800_25-agro-processing-smes-in-sierra-leone-benefit-from-usd-1-3-million-covid-19-relief-fund-grant/" title="25 Agro-Processing SMEs in Sierra Leone benefit from USD 1.3 Million Covid-19 Relief Fund Grant"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38800_25-agro-processing-smes-in-sierra-leone-benefit-from-usd-1-3-million-covid-19-relief-fund-grant/" rel="bookmark" title="25 Agro-Processing SMEs in Sierra Leone benefit from USD 1.3 Million Covid-19 Relief Fund Grant">
25 Agro-Processing SMEs in Sierra Leone benefit from USD 1.3 Million Covid-19 Relief Fund Grant </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/161293257_803771033562373_4127832802742692878_n-263x175.jpg" href="https://www.switsalone.com/38789_breaking-news-president-bio-appoints-kao-denero-as-special-envoy-for-entertainment-in-sierra-leone/" title="Breaking News: President Bio appoints Kao Denero as Special Envoy for Entertainment in Sierra Leone"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38789_breaking-news-president-bio-appoints-kao-denero-as-special-envoy-for-entertainment-in-sierra-leone/" rel="bookmark" title="Breaking News: President Bio appoints Kao Denero as Special Envoy for Entertainment in Sierra Leone">
Breaking News: President Bio appoints Kao Denero as Special Envoy for Entertainment in Sierra Leone </a>
</h4>
</div>
</div>
 </li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/President-Bio1-263x175.jpg" href="https://www.switsalone.com/38780_sierra-leone-rolls-out-covid-19-vaccination/" title="Sierra Leone Rolls Out Covid-19 Vaccination"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38780_sierra-leone-rolls-out-covid-19-vaccination/" rel="bookmark" title="Sierra Leone Rolls Out Covid-19 Vaccination">
Sierra Leone Rolls Out Covid-19 Vaccination </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/Wizkid-Burna-Boy-263x175.png" href="https://www.switsalone.com/38766_nigerias-burna-boy-and-wizkid-win-grammy-awards/" title="Nigeria’s Burna Boy and Wizkid win Grammy Awards"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38766_nigerias-burna-boy-and-wizkid-win-grammy-awards/" rel="bookmark" title="Nigeria’s Burna Boy and Wizkid win Grammy Awards">
Nigeria’s Burna Boy and Wizkid win Grammy Awards </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/Flutterwave_IMTC-263x175.jpg" href="https://www.switsalone.com/38751_nigerian-fintech-company-is-valued-at-usd-1-billion/" title="Nigerian Fintech Company is valued at USD 1 billion"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38751_nigerian-fintech-company-is-valued-at-usd-1-billion/" rel="bookmark" title="Nigerian Fintech Company is valued at USD 1 billion">
Nigerian Fintech Company is valued at USD 1 billion </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/G0012822_w-263x175.jpg" href="https://www.switsalone.com/38744_caf-lifts-ban-on-sierra-leones-national-stadium-temporarily/" title="CAF lifts ban on Sierra Leone’s national stadium temporarily"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38744_caf-lifts-ban-on-sierra-leones-national-stadium-temporarily/" rel="bookmark" title="CAF lifts ban on Sierra Leone’s national stadium temporarily">
CAF lifts ban on Sierra Leone’s national stadium temporarily </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/covax-sl-263x175.jpg" href="https://www.switsalone.com/38732_sierra-leone-receives-96000-astrazeneca-oxford-covid-19-vaccine-dose/" title="Sierra Leone receives 96,000 AstraZeneca-Oxford COVID-19 Vaccine Dose"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38732_sierra-leone-receives-96000-astrazeneca-oxford-covid-19-vaccine-dose/" rel="bookmark" title="Sierra Leone receives 96,000 AstraZeneca-Oxford COVID-19 Vaccine Dose">
Sierra Leone receives 96,000 AstraZeneca-Oxford COVID-19 Vaccine Dose </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/International-Womens-Day-2021-ChooseToChallenge-263x175.png" href="https://www.switsalone.com/38714_international-womens-day-2021-womens-rights-are-human-rights-choosetochallenge/" title="International Women’s Day 2021: Women’s rights are human rights #ChooseToChallenge"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38714_international-womens-day-2021-womens-rights-are-human-rights-choosetochallenge/" rel="bookmark" title="International Women’s Day 2021: Women’s rights are human rights #ChooseToChallenge">
International Women’s Day 2021: Women’s rights are human rights #ChooseToChallenge </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/EulaSkXXMAE69Uf-263x175.jpeg" href="https://www.switsalone.com/38700_a-petroleum-engineer-and-an-artist-meet-dr-shu-the-man-himself/" title="A Petroleum Engineer and an Artist Meet Dr. Shu “The Man Himself”"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38700_a-petroleum-engineer-and-an-artist-meet-dr-shu-the-man-himself/" rel="bookmark" title="A Petroleum Engineer and an Artist Meet Dr. Shu “The Man Himself”">
A Petroleum Engineer and an Artist Meet Dr. Shu “The Man Himself” </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/ESWBQllXYAANyTo-263x175.jpg" href="https://www.switsalone.com/38695_world-book-day-celebrating-sierra-leonean-authors/" title="World Book Day: Celebrating Sierra Leonean authors"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38695_world-book-day-celebrating-sierra-leonean-authors/" rel="bookmark" title="World Book Day: Celebrating Sierra Leonean authors">
World Book Day: Celebrating Sierra Leonean authors </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/89803697_104011557897025_9066356154296172544_n-263x175.jpg" href="https://www.switsalone.com/38693_slfa-payouts-usd-500-thousand-to-football-clubs-and-member-associations/" title="SLFA payouts USD 500 thousand to football clubs and member associations"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38693_slfa-payouts-usd-500-thousand-to-football-clubs-and-member-associations/" rel="bookmark" title="SLFA payouts USD 500 thousand to football clubs and member associations">
SLFA payouts USD 500 thousand to football clubs and member associations </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/FB_IMG_16147942338393893-263x175.jpg" href="https://www.switsalone.com/38686_new-music-star-zee-releases-life/" title="New Music: Star Zee releases “Life”"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38686_new-music-star-zee-releases-life/" rel="bookmark" title="New Music: Star Zee releases “Life”">
New Music: Star Zee releases “Life” </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/Food-Nutrients.jpg" href="https://www.switsalone.com/38674_sierra-leone-ranked-108-out-of-113-countries-in-2020-global-food-security-index/" title="Sierra Leone Ranked 108 Out of 113 Countries in 2020 Global Food Security Index"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38674_sierra-leone-ranked-108-out-of-113-countries-in-2020-global-food-security-index/" rel="bookmark" title="Sierra Leone Ranked 108 Out of 113 Countries in 2020 Global Food Security Index">
Sierra Leone Ranked 108 Out of 113 Countries in 2020 Global Food Security Index </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/FCC-1-263x175.jpg" href="https://www.switsalone.com/38625_massive-fire-outbreak-at-mount-aureol-community-leaves-over-200-people-homeless/" title="Freetown City Council donates Relief Items to Fire Victims at The Mount Aureol Community"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38625_massive-fire-outbreak-at-mount-aureol-community-leaves-over-200-people-homeless/" rel="bookmark" title="Freetown City Council donates Relief Items to Fire Victims at The Mount Aureol Community">
Freetown City Council donates Relief Items to Fire Victims at The Mount Aureol Community </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/G0012822_w-263x175.jpg" href="https://www.switsalone.com/38667_caf-bans-sierra-leones-national-stadium-from-playing-international-matches/" title="CAF bans Sierra Leone’s national stadium from playing international matches"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38667_caf-bans-sierra-leones-national-stadium-from-playing-international-matches/" rel="bookmark" title="CAF bans Sierra Leone’s national stadium from playing international matches">
CAF bans Sierra Leone’s national stadium from playing international matches </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/58dcbf62ddfbffbc2379e590395e2cebe2a874b99a5776d245e45b35676e45a0-263x175.jpeg" href="https://www.switsalone.com/38634_new-music-solos-beat-releases-debut-album-joanna/" title="New Music: Solo&#8217;s Beat Releases Debut Album &#8220;Joanna&#8221;"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38634_new-music-solos-beat-releases-debut-album-joanna/" rel="bookmark" title="New Music: Solo&#8217;s Beat Releases Debut Album &#8220;Joanna&#8221;">
New Music: Solo&#8217;s Beat Releases Debut Album &#8220;Joanna&#8221; </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/Eu-y5xvWYAEYBto-263x175.jpeg" href="https://www.switsalone.com/38580_ghana-is-the-first-country-in-africa-to-receive-covax-vaccines/" title="Ghana is the first country in Africa to receive Covax vaccines"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38580_ghana-is-the-first-country-in-africa-to-receive-covax-vaccines/" rel="bookmark" title="Ghana is the first country in Africa to receive Covax vaccines">
Ghana is the first country in Africa to receive Covax vaccines </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/89803697_104011557897025_9066356154296172544_n-263x175.jpg" href="https://www.switsalone.com/38572_slfa-postpones-upcoming-elective-congress/" title="SLFA postpones upcoming elective congress"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38572_slfa-postpones-upcoming-elective-congress/" rel="bookmark" title="SLFA postpones upcoming elective congress">
SLFA postpones upcoming elective congress </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/SierraLeone_0416_PrinceChristianMaternity_EHansen_crop-263x175.jpg" href="https://www.switsalone.com/38561_baby-dies-at-cottage-due-to-lack-of-surgical-equipment/" title="Baby Dies at Cottage Due to Lack of Surgical Equipment"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38561_baby-dies-at-cottage-due-to-lack-of-surgical-equipment/" rel="bookmark" title="Baby Dies at Cottage Due to Lack of Surgical Equipment">
Baby Dies at Cottage Due to Lack of Surgical Equipment </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/WhatsApp-Image-2021-02-22-at-3.58.34-AM-263x175.jpeg" href="https://www.switsalone.com/38555_new-music-alert-mello-seven-releases-joborti-featuring-rozzay/" title="New Music Alert: Mello Seven releases “Joborti” featuring Rozzay"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38555_new-music-alert-mello-seven-releases-joborti-featuring-rozzay/" rel="bookmark" title="New Music Alert: Mello Seven releases “Joborti” featuring Rozzay">
New Music Alert: Mello Seven releases “Joborti” featuring Rozzay </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/LadimaAcademy-1-263x175.jpg" href="https://www.switsalone.com/38540_ladima-foundation-launches-its-film-academy/" title="Ladima Foundation launches its Film Academy"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38540_ladima-foundation-launches-its-film-academy/" rel="bookmark" title="Ladima Foundation launches its Film Academy">
Ladima Foundation launches its Film Academy </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/A-timeline-of-Ebola-vaccine-development_wrbm_large-263x175.jpg" href="https://www.switsalone.com/38535_who-to-send-11000-ebola-vaccines-to-guinea/" title="WHO to send 11,000 Ebola vaccines to Guinea"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38535_who-to-send-11000-ebola-vaccines-to-guinea/" rel="bookmark" title="WHO to send 11,000 Ebola vaccines to Guinea">
WHO to send 11,000 Ebola vaccines to Guinea </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/Euc1QY_XcAM1PVz-263x175.jpg" href="https://www.switsalone.com/38529_freetown-mayor-yvonne-aki-sawyer-named-as-time100-next-most-influential-people/" title="Freetown Mayor Yvonne Aki Sawyer named as TIME100 Next Most Influential People"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38529_freetown-mayor-yvonne-aki-sawyer-named-as-time100-next-most-influential-people/" rel="bookmark" title="Freetown Mayor Yvonne Aki Sawyer named as TIME100 Next Most Influential People">
Freetown Mayor Yvonne Aki Sawyer named as TIME100 Next Most Influential People </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
 <div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/150785939_3893919440664551_649549856645799730_n-263x175.jpg" href="https://www.switsalone.com/38525_itribe-releases-debut-album-dis-feeling/" title="Itribe releases debut album “Dis Feeling”"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38525_itribe-releases-debut-album-dis-feeling/" rel="bookmark" title="Itribe releases debut album “Dis Feeling”">
Itribe releases debut album “Dis Feeling” </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/president-Bio-commemorates-armed-forces-day-263x175.jpg" href="https://www.switsalone.com/38521_armed-forces-day-here-are-facts-about-the-republic-of-sierra-leone-armed-forces-everyone-should-know/" title="Armed Forces Day: Here are Facts about The Republic of Sierra Leone Armed Forces Everyone should know"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38521_armed-forces-day-here-are-facts-about-the-republic-of-sierra-leone-armed-forces-everyone-should-know/" rel="bookmark" title="Armed Forces Day: Here are Facts about The Republic of Sierra Leone Armed Forces Everyone should know">
Armed Forces Day: Here are Facts about The Republic of Sierra Leone Armed Forces Everyone should know </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/KKY-263x175.jpg" href="https://www.switsalone.com/38494_kky-calls-on-parliament-to-probe-into-the-financial-allegations-of-the-office-of-the-president/" title="KKY calls on Parliament to Probe into the Financial Allegations of the Office of the President"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38494_kky-calls-on-parliament-to-probe-into-the-financial-allegations-of-the-office-of-the-president/" rel="bookmark" title="KKY calls on Parliament to Probe into the Financial Allegations of the Office of the President">
KKY calls on Parliament to Probe into the Financial Allegations of the Office of the President </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/IMG_0159-263x175.jpg" href="https://www.switsalone.com/38484_sl-mining-wins-case-against-sierra-leone-at-the-international-chamber-of-commerce/" title="SL Mining Wins Case Against Sierra Leone at the International Chamber of Commerce"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38484_sl-mining-wins-case-against-sierra-leone-at-the-international-chamber-of-commerce/" rel="bookmark" title="SL Mining Wins Case Against Sierra Leone at the International Chamber of Commerce">
SL Mining Wins Case Against Sierra Leone at the International Chamber of Commerce </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/5B5A3C6D-684E-4AC9-A4F2-988D09432954-263x175.jpg" href="https://www.switsalone.com/38467_pujehun-health-management-team-reports-a-suspected-ebola-case/" title="Pujehun Health Management Team Reports a Suspected Ebola Case"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38467_pujehun-health-management-team-reports-a-suspected-ebola-case/" rel="bookmark" title="Pujehun Health Management Team Reports a Suspected Ebola Case">
Pujehun Health Management Team Reports a Suspected Ebola Case </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/images282029-263x175.jpeg" href="https://www.switsalone.com/38455_meet-ngozi-okonjo-iweala-the-nigerian-economist-appointed-director-general-of-the-world-trade-organisation/" title="Meet Ngozi Okonjo-Iweala the Nigerian Economist Appointed Director-General of the World Trade Organisation"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38455_meet-ngozi-okonjo-iweala-the-nigerian-economist-appointed-director-general-of-the-world-trade-organisation/" rel="bookmark" title="Meet Ngozi Okonjo-Iweala the Nigerian Economist Appointed Director-General of the World Trade Organisation">
Meet Ngozi Okonjo-Iweala the Nigerian Economist Appointed Director-General of the World Trade Organisation </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/17911388_401-263x175.jpg" href="https://www.switsalone.com/38440_ebola-reemerges-in-guinea-for-the-first-time-since-2014-outbreak/" title="Ebola Reemerges in Guinea for the First Time Since 2014 Outbreak."></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38440_ebola-reemerges-in-guinea-for-the-first-time-since-2014-outbreak/" rel="bookmark" title="Ebola Reemerges in Guinea for the First Time Since 2014 Outbreak.">
Ebola Reemerges in Guinea for the First Time Since 2014 Outbreak. </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/130960879_3472569492812560_2229894350877702435_o-263x175.jpg" href="https://www.switsalone.com/38424_meet-sierra-leones-essential-workers-the-petty-trader/" title="Meet Sierra Leone&#8217;s Essential Workers: The  Petty Trader"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38424_meet-sierra-leones-essential-workers-the-petty-trader/" rel="bookmark" title="Meet Sierra Leone&#8217;s Essential Workers: The  Petty Trader">
Meet Sierra Leone&#8217;s Essential Workers: The Petty Trader </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/Austin-Demby-Large-263x175.jpg" href="https://www.switsalone.com/38419_who-is-dr-austin-demby-sierra-leones-new-health-minister/" title="Who is Dr. Austin Demby Sierra Leone’s New Health Minister"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38419_who-is-dr-austin-demby-sierra-leones-new-health-minister/" rel="bookmark" title="Who is Dr. Austin Demby Sierra Leone’s New Health Minister">
Who is Dr. Austin Demby Sierra Leone’s New Health Minister </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/130049742_3457393394330170_3268072506919433643_o-263x175.png" href="https://www.switsalone.com/38414_meet-sierra-leones-essential-workers-the-fruit-seller/" title="Meet Sierra Leone&#8217;s Essential Workers: The Fruit Seller"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38414_meet-sierra-leones-essential-workers-the-fruit-seller/" rel="bookmark" title="Meet Sierra Leone&#8217;s Essential Workers: The Fruit Seller">
Meet Sierra Leone&#8217;s Essential Workers: The Fruit Seller </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/130702745_3465000336902809_2290291026892218904_o-263x175.png" href="https://www.switsalone.com/38405_meet-sierra-leones-essential-workers-the-multimedia-producer/" title="Meet Sierra Leone&#8217;s Essential Workers: The Multimedia Producer"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38405_meet-sierra-leones-essential-workers-the-multimedia-producer/" rel="bookmark" title="Meet Sierra Leone&#8217;s Essential Workers: The Multimedia Producer">
Meet Sierra Leone&#8217;s Essential Workers: The Multimedia Producer </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/BeFunky-collage-263x175.jpg" href="https://www.switsalone.com/38382_new-books-by-sierra-leoneans-everyone-needs-in-2021/" title="New Books by Sierra Leoneans everyone needs in 2021"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38382_new-books-by-sierra-leoneans-everyone-needs-in-2021/" rel="bookmark" title="New Books by Sierra Leoneans everyone needs in 2021">
New Books by Sierra Leoneans everyone needs in 2021 </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
 <div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/Untitled-design-2-263x175.png" href="https://www.switsalone.com/38351_inside-salone-entertainment-whats-going-on-between-markmuday-and-samira/" title="Inside Salone Entertainment: What’s going on between Markmuday and Samira?"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38351_inside-salone-entertainment-whats-going-on-between-markmuday-and-samira/" rel="bookmark" title="Inside Salone Entertainment: What’s going on between Markmuday and Samira?">
Inside Salone Entertainment: What’s going on between Markmuday and Samira? </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/129480831_3451981438204699_1009571639432234374_o-263x175.png" href="https://www.switsalone.com/38345_meet-sierra-leones-essential-workers-the-communications-manager/" title="Meet Sierra Leone&#8217;s Essential Workers: The Communications Manager"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38345_meet-sierra-leones-essential-workers-the-communications-manager/" rel="bookmark" title="Meet Sierra Leone&#8217;s Essential Workers: The Communications Manager">
Meet Sierra Leone&#8217;s Essential Workers: The Communications Manager </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/Turad-Senessie-263x175.jpg" href="https://www.switsalone.com/38340_who-is-dr-turad-senesie-sierra-leones-new-lands-minister/" title="Who is Dr. Turad Senesie Sierra Leone’s new Lands Minister"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38340_who-is-dr-turad-senesie-sierra-leones-new-lands-minister/" rel="bookmark" title="Who is Dr. Turad Senesie Sierra Leone’s new Lands Minister">
Who is Dr. Turad Senesie Sierra Leone’s new Lands Minister </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/Coat_of_arms_of_Sierra_Leone-263x175.png" href="https://www.switsalone.com/38337_sierra-leone-moves-2-place-up-in-the-2020-transparency-int-corruption-index/" title="Sierra Leone Moves 2 Place Up in the 2020 Transparency Int. Corruption  Index"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38337_sierra-leone-moves-2-place-up-in-the-2020-transparency-int-corruption-index/" rel="bookmark" title="Sierra Leone Moves 2 Place Up in the 2020 Transparency Int. Corruption  Index">
Sierra Leone Moves 2 Place Up in the 2020 Transparency Int. Corruption Index </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/Celebrating-Black-History-Month_1200px-x-400px_v1-263x175.jpg" href="https://www.switsalone.com/38330_what-do-we-know-about-black-history-month/" title="5 Things You Should Know About Black History Month"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38330_what-do-we-know-about-black-history-month/" rel="bookmark" title="5 Things You Should Know About Black History Month">
5 Things You Should Know About Black History Month </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/release-263x175.jpg" href="https://www.switsalone.com/38322_the-national-covid-19-emergency-response-center-nacoverc-opens-6-new-covid-19-testing-centers-in-freetown/" title="The National Covid-19 Emergency Response Center (NaCOVERC) opens 6 New Covid-19 Testing Centers in Freetown"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38322_the-national-covid-19-emergency-response-center-nacoverc-opens-6-new-covid-19-testing-centers-in-freetown/" rel="bookmark" title="The National Covid-19 Emergency Response Center (NaCOVERC) opens 6 New Covid-19 Testing Centers in Freetown">
The National Covid-19 Emergency Response Center (NaCOVERC) opens 6 New Covid-19 Testing Centers in Freetown </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/Francis-Ben-Kaifala-33-1-263x175.png" href="https://www.switsalone.com/38313_sierra-leones-anti-corruption-commissioner-francis-ben-kaifala-included-in-the-list-of-100-most-influential-young-leaders-in-africa/" title="Sierra Leone’s Anti Corruption Commissioner, Francis Ben-Kaifala included in the list of 100 Most Influential Young Leaders in Africa"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38313_sierra-leones-anti-corruption-commissioner-francis-ben-kaifala-included-in-the-list-of-100-most-influential-young-leaders-in-africa/" rel="bookmark" title="Sierra Leone’s Anti Corruption Commissioner, Francis Ben-Kaifala included in the list of 100 Most Influential Young Leaders in Africa">
Sierra Leone’s Anti Corruption Commissioner, Francis Ben-Kaifala included in the list of 100 Most Influential Young Leaders in Africa </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/Esv5gPjXYAQxba6-263x175.jpg" href="https://www.switsalone.com/38311_hindolo-pokawa-completes-315-miles-walk-from-kailahun-to-freetown-in-solidarity-of-rape-and-sexual-violence-in-sierra-leone/" title="Hindolo Pokawa completes 315 miles walk from Kailahun to Freetown in Solidarity of Rape and Sexual Violence in Sierra Leone"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38311_hindolo-pokawa-completes-315-miles-walk-from-kailahun-to-freetown-in-solidarity-of-rape-and-sexual-violence-in-sierra-leone/" rel="bookmark" title="Hindolo Pokawa completes 315 miles walk from Kailahun to Freetown in Solidarity of Rape and Sexual Violence in Sierra Leone">
Hindolo Pokawa completes 315 miles walk from Kailahun to Freetown in Solidarity of Rape and Sexual Violence in Sierra Leone </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/Eslf6jvW8AAL6MG-263x175.jpeg" href="https://www.switsalone.com/38284_africa-podfest-international-podcast-day-presents-wheres-the-money-in-africa-podcasting-join-the-conversation/" title="Africa Podfest &#038; International Podcast Day Presents: “Where’s the money in Africa Podcasting” &#8211; Join the Conversation!"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38284_africa-podfest-international-podcast-day-presents-wheres-the-money-in-africa-podcasting-join-the-conversation/" rel="bookmark" title="Africa Podfest &#038; International Podcast Day Presents: “Where’s the money in Africa Podcasting” &#8211; Join the Conversation!">
Africa Podfest &#038; International Podcast Day Presents: “Where’s the money in Africa Podcasting” &#8211; Join the Conversation! </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/University-of-Sierra-Leone-2_1-263x175.jpg" href="https://www.switsalone.com/38280_academic-staff-association-of-usl-njala-and-ebkust-present-salary-review-document-to-government/" title="Academic Staff Association of USL, Njala, and EBKUST present Salary Review Document to Government"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38280_academic-staff-association-of-usl-njala-and-ebkust-present-salary-review-document-to-government/" rel="bookmark" title="Academic Staff Association of USL, Njala, and EBKUST present Salary Review Document to Government">
Academic Staff Association of USL, Njala, and EBKUST present Salary Review Document to Government </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/unnamed.png" href="https://www.switsalone.com/38270_sierra-leone-law-school-releases-results-for-the-2020-bar-examination/" title="Sierra Leone Law School releases results for the 2020 Bar Examination"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38270_sierra-leone-law-school-releases-results-for-the-2020-bar-examination/" rel="bookmark" title="Sierra Leone Law School releases results for the 2020 Bar Examination">
Sierra Leone Law School releases results for the 2020 Bar Examination </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/ellakoblogulama-263x175.jpg" href="https://www.switsalone.com/38273_ella-koblo-gulama-day-the-queen-would-have-been-100-today/" title="Ella Koblo Gulama Day: The Queen would have been 100 today!"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38273_ella-koblo-gulama-day-the-queen-would-have-been-100-today/" rel="bookmark" title="Ella Koblo Gulama Day: The Queen would have been 100 today!">
Ella Koblo Gulama Day: The Queen would have been 100 today! </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/Memuna-Konteh-on-Black-Diaspora-263x175.png" href="https://www.switsalone.com/38265_sierra-leonean-diasporas-need-to-check-their-privilege-when-returning-home-in-a-pandemic/" title="Sierra Leonean Diasporas need to check their privilege when returning home in a pandemic"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38265_sierra-leonean-diasporas-need-to-check-their-privilege-when-returning-home-in-a-pandemic/" rel="bookmark" title="Sierra Leonean Diasporas need to check their privilege when returning home in a pandemic">
Sierra Leonean Diasporas need to check their privilege when returning home in a pandemic </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/20210125_140429_0000-263x175.png" href="https://www.switsalone.com/38262_first-lady-fatima-bio-endorses-driziliks-mamas-nomination/" title="First Lady Fatima Bio endorses Drizilik’s MAMAs nomination"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38262_first-lady-fatima-bio-endorses-driziliks-mamas-nomination/" rel="bookmark" title="First Lady Fatima Bio endorses Drizilik’s MAMAs nomination">
First Lady Fatima Bio endorses Drizilik’s MAMAs nomination </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/slnja-263x175.jpg" href="https://www.switsalone.com/38251_love-story-gone-wrong-meet-the-sierra-leonean-woman-who-dropped-out-of-medical-school-because-of-love/" title="Love Story Gone Wrong: Meet The Sierra Leonean Woman Who Dropped Out Of Medical School Because of Love"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38251_love-story-gone-wrong-meet-the-sierra-leonean-woman-who-dropped-out-of-medical-school-because-of-love/" rel="bookmark" title="Love Story Gone Wrong: Meet The Sierra Leonean Woman Who Dropped Out Of Medical School Because of Love">
Love Story Gone Wrong: Meet The Sierra Leonean Woman Who Dropped Out Of Medical School Because of Love </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/Esauj9aU4AEfGB2-263x175.jpeg" href="https://www.switsalone.com/38247_legendary-american-talk-show-host-larry-king-dies-at-age-87/" title="Legendary American Talk Show Host Larry King dies at age 87"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38247_legendary-american-talk-show-host-larry-king-dies-at-age-87/" rel="bookmark" title="Legendary American Talk Show Host Larry King dies at age 87">
Legendary American Talk Show Host Larry King dies at age 87 </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/141747690_774889659783844_1934985398385784611_o-263x175.jpg" href="https://www.switsalone.com/38241_kao-denero-throw-shades-on-driziliks-mamas-nomination/" title="Kao Denero throw shades on Drizilik’s MAMAs nomination"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38241_kao-denero-throw-shades-on-driziliks-mamas-nomination/" rel="bookmark" title="Kao Denero throw shades on Drizilik’s MAMAs nomination">
Kao Denero throw shades on Drizilik’s MAMAs nomination </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/37353471_1322348424565600_6769944880379592704_n-263x175.jpg" href="https://www.switsalone.com/38235_sierra-leones-first-female-engineer-named-2021-imperial-college-distinguished-alumni-award/" title="Sierra Leone’s first Female Engineer named 2021 Imperial College Distinguished Alumni Award"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38235_sierra-leones-first-female-engineer-named-2021-imperial-college-distinguished-alumni-award/" rel="bookmark" title="Sierra Leone’s first Female Engineer named 2021 Imperial College Distinguished Alumni Award">
Sierra Leone’s first Female Engineer named 2021 Imperial College Distinguished Alumni Award </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/2021-01-20T165033Z_779931362_HP1EH1K1AS94N_RTRMADP_3_USA-BIDEN-INAUGURATION-1024x681-1-263x175.jpg" href="https://www.switsalone.com/38220_what-you-didnt-know-about-president-joe-biden-and-vice-president-kamala-harris-of-the-united-states/" title="What you didn’t know about President Joe Biden and Vice President Kamala Harris of the United States"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38220_what-you-didnt-know-about-president-joe-biden-and-vice-president-kamala-harris-of-the-united-states/" rel="bookmark" title="What you didn’t know about President Joe Biden and Vice President Kamala Harris of the United States">
What you didn’t know about President Joe Biden and Vice President Kamala Harris of the United States </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/EnMtK17XIAI9bZn-263x175.jpg" href="https://www.switsalone.com/38213_drizilik-nominated-for-the-2021-mamas-listeners-choice-awards/" title="Drizilik nominated for the 2021 MAMAs Listeners’ Choice Awards"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38213_drizilik-nominated-for-the-2021-mamas-listeners-choice-awards/" rel="bookmark" title="Drizilik nominated for the 2021 MAMAs Listeners’ Choice Awards">
Drizilik nominated for the 2021 MAMAs Listeners’ Choice Awards </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/9-3-263x175.jpg" href="https://www.switsalone.com/38209_sierra-leone-first-lady-fatima-bio-reacts-to-accusations-of-using-state-funds-for-personal-use/" title="Sierra Leone: First Lady Fatima Bio reacts to accusations of using state funds for personal use"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38209_sierra-leone-first-lady-fatima-bio-reacts-to-accusations-of-using-state-funds-for-personal-use/" rel="bookmark" title="Sierra Leone: First Lady Fatima Bio reacts to accusations of using state funds for personal use">
Sierra Leone: First Lady Fatima Bio reacts to accusations of using state funds for personal use </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/download-9-263x175.jpg" href="https://www.switsalone.com/38205_bidens-inauguration-donald-trump-leaves-the-white-house/" title="Biden’s Inauguration: Donald Trump leaves the White House"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38205_bidens-inauguration-donald-trump-leaves-the-white-house/" rel="bookmark" title="Biden’s Inauguration: Donald Trump leaves the White House">
Biden’s Inauguration: Donald Trump leaves the White House </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/9799_switsalone-loves-designs-by-christie/" rel="bookmark" title="SwitSalone LOVES designs by Christie Brown &amp; Cote Minou">
SwitSalone LOVES designs by Christie Brown &amp; Cote Minou </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2020/02/IMG-20200218-WA0033-263x175.jpg" href="https://www.switsalone.com/35403_2019-2020-top-20-rappers-in-africa/" title="2019/2020 top 20 rappers in Africa"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/35403_2019-2020-top-20-rappers-in-africa/" rel="bookmark" title="2019/2020 top 20 rappers in Africa">
2019/2020 top 20 rappers in Africa </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/Robert-Mugabe-Reuters.jpg" href="https://www.switsalone.com/32434_mugabe-dies-at-95/" title="Robert Mugabe, former Zimbabwe President dies at 95"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/32434_mugabe-dies-at-95/" rel="bookmark" title="Robert Mugabe, former Zimbabwe President dies at 95">
Robert Mugabe, former Zimbabwe President dies at 95 </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/O-Bar_Contact_Phone_FreetownBar.jpg" href="https://www.switsalone.com/560_the-o-bar-nightclub/" title="The O Bar &#038; Nightclub"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/560_the-o-bar-nightclub/" rel="bookmark" title="The O Bar &#038; Nightclub">
The O Bar &#038; Nightclub </a>
</h4>
</div>
</div>
</li>
</ul>
</aside> </div>
<div class="footer-widget-wrapper footer-widget-style-1 last">
<aside id="penci_latest_news_widget-2" class="widget penci_latest_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Recent Posts</span></h4> <ul id="penci-latestwg-4673" class="side-newsfeed penci-feed-2columns penci-2columns-feed">
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/05/African-Experts-FB-Instagram-1-263x175.png" href="https://www.switsalone.com/39060_african-expert-spotlight-meet-african-experts-show-guest-paul-azunre/" title="African Expert Spotlight: Meet African Experts Show Guest Paul Azunre"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/39060_african-expert-spotlight-meet-african-experts-show-guest-paul-azunre/" rel="bookmark" title="African Expert Spotlight: Meet African Experts Show Guest Paul Azunre">
African Expert Spotlight: Meet African Experts Show Guest Paul Azunre </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-05-12T15:09:44+00:00">May 12, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/IMG_0159-263x175.jpg" href="https://www.switsalone.com/39049_sierra-leone-government-resolves-it-differences-with-sl-mining/" title="Sierra Leone Government resolved disputes with SL Mining"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/39049_sierra-leone-government-resolves-it-differences-with-sl-mining/" rel="bookmark" title="Sierra Leone Government resolved disputes with SL Mining">
Sierra Leone Government resolved disputes with SL Mining </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-05-11T12:01:20+00:00">May 11, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/05/Gabriel-Fatoma-Grantee-263x175.jpg" href="https://www.switsalone.com/39026_gef-small-grants-stories-swamp-farms-increase-food-security-and-prevent-deforestation-in-gola-forest-communities/" title="GEF Small Grants Stories: Swamp Farms increase Food Security, and Prevent Deforestation in Gola Forest Communities"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/39026_gef-small-grants-stories-swamp-farms-increase-food-security-and-prevent-deforestation-in-gola-forest-communities/" rel="bookmark" title="GEF Small Grants Stories: Swamp Farms increase Food Security, and Prevent Deforestation in Gola Forest Communities">
GEF Small Grants Stories: Swamp Farms increase Food Security, and Prevent Deforestation in Gola Forest Communities </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-05-07T17:30:02+00:00">May 7, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/05/WELCOME-Augustine-Williams_2021_1920x1080-263x175.jpg" href="https://www.switsalone.com/39023_la-galaxy-promotes-sierra-leonean-forward-augustine-williams-to-the-senior-team/" title="LA Galaxy promotes Sierra Leonean forward Augustine Williams to the senior team"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/39023_la-galaxy-promotes-sierra-leonean-forward-augustine-williams-to-the-senior-team/" rel="bookmark" title="LA Galaxy promotes Sierra Leonean forward Augustine Williams to the senior team">
LA Galaxy promotes Sierra Leonean forward Augustine Williams to the senior team </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-05-06T16:24:19+00:00">May 6, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/05/African-Experts-FB-Instagram-263x175.png" href="https://www.switsalone.com/39011_african-expert-spotlight-meet-african-experts-show-guest-daniel-chaytor/" title="African Expert Spotlight: Meet African Experts Show Guest Daniel Chaytor"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/39011_african-expert-spotlight-meet-african-experts-show-guest-daniel-chaytor/" rel="bookmark" title="African Expert Spotlight: Meet African Experts Show Guest Daniel Chaytor">
African Expert Spotlight: Meet African Experts Show Guest Daniel Chaytor </a>
 </h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-05-05T15:05:26+00:00">May 5, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/05/179778989_10165032268230297_3573771963317607610_n-263x175.jpg" href="https://www.switsalone.com/39005_government-of-sierra-leone-lifts-ban-on-overseas-recruitment/" title="Government of Sierra Leone lifts ban on overseas recruitment"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/39005_government-of-sierra-leone-lifts-ban-on-overseas-recruitment/" rel="bookmark" title="Government of Sierra Leone lifts ban on overseas recruitment">
Government of Sierra Leone lifts ban on overseas recruitment </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-05-04T16:37:27+00:00">May 4, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/Coat_of_arms_of_Sierra_Leone-263x175.png" href="https://www.switsalone.com/38988_government-of-sierra-leone-announces-new-cabinet-reshuffle-2/" title="Government of Sierra Leone Announces New Cabinet Reshuffle"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38988_government-of-sierra-leone-announces-new-cabinet-reshuffle-2/" rel="bookmark" title="Government of Sierra Leone Announces New Cabinet Reshuffle">
Government of Sierra Leone Announces New Cabinet Reshuffle </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-04-30T19:03:13+00:00">April 30, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/04/African-Experts-Twiiter-1-263x175.png" href="https://www.switsalone.com/38982_african-expert-spotlight-meet-african-experts-show-guest-leeann-rizk/" title="African Expert Spotlight: Meet African Experts Show Guest Leeann Rizk"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38982_african-expert-spotlight-meet-african-experts-show-guest-leeann-rizk/" rel="bookmark" title="African Expert Spotlight: Meet African Experts Show Guest Leeann Rizk">
African Expert Spotlight: Meet African Experts Show Guest Leeann Rizk </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-04-29T14:15:32+00:00">April 29, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/04/NRP-Bringing_New_Audio_Formats_to_Facebook_header-263x175.jpg" href="https://www.switsalone.com/38955_facebook-announces-new-live-audio-experiences-and-monetization-feature/" title="Facebook Announces New Live Audio Experiences And Monetization Feature"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38955_facebook-announces-new-live-audio-experiences-and-monetization-feature/" rel="bookmark" title="Facebook Announces New Live Audio Experiences And Monetization Feature">
Facebook Announces New Live Audio Experiences And Monetization Feature </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-04-21T17:11:11+00:00">April 21, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/04/African-Experts-Twiiter-263x175.png" href="https://www.switsalone.com/38932_african-expert-spotlight-meet-african-experts-show-guest-beatrice-chaytor/" title="African Expert Spotlight: Meet African Experts Show Guest Beatrice Chaytor"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38932_african-expert-spotlight-meet-african-experts-show-guest-beatrice-chaytor/" rel="bookmark" title="African Expert Spotlight: Meet African Experts Show Guest Beatrice Chaytor">
African Expert Spotlight: Meet African Experts Show Guest Beatrice Chaytor </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-04-16T21:54:44+00:00">April 16, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/04/EysfivuWUAAA4Wn-263x175.jpg" href="https://www.switsalone.com/38922_african-expert-spotlight-meet-african-experts-show-guest-tamu-thomas/" title="African Expert Spotlight: Meet African Experts Show Guest Tamu Thomas"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38922_african-expert-spotlight-meet-african-experts-show-guest-tamu-thomas/" rel="bookmark" title="African Expert Spotlight: Meet African Experts Show Guest Tamu Thomas">
African Expert Spotlight: Meet African Experts Show Guest Tamu Thomas </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-04-13T16:14:23+00:00">April 13, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/04/Gandoh-Practice-1-263x175.png" href="https://www.switsalone.com/38894_african-expert-spotlight-meet-african-experts-show-guest-franklin-ibemessie/" title="African Expert Spotlight: Meet African Experts Show Guest Franklin Ibemessie"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38894_african-expert-spotlight-meet-african-experts-show-guest-franklin-ibemessie/" rel="bookmark" title="African Expert Spotlight: Meet African Experts Show Guest Franklin Ibemessie">
African Expert Spotlight: Meet African Experts Show Guest Franklin Ibemessie </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-04-01T17:30:41+00:00">April 1, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/3-1-263x175.png" href="https://www.switsalone.com/38822_how-four-sierra-leonean-women-collaborated-to-end-period-poverty-for-300-girls/" title="How Four Sierra Leonean Women Collaborated to End Period Poverty for 300 Girls"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38822_how-four-sierra-leonean-women-collaborated-to-end-period-poverty-for-300-girls/" rel="bookmark" title="How Four Sierra Leonean Women Collaborated to End Period Poverty for 300 Girls">
How Four Sierra Leonean Women Collaborated to End Period Poverty for 300 Girls </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-03-26T17:41:43+00:00">March 26, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/unido-01-1024x850-1-263x175.jpg" href="https://www.switsalone.com/38852_unido-signs-3-88-million-agreement-to-establish-four-ultra-modern-automotive-centers/" title="UNIDO Signs $3.88 Million Agreement to Establish Four Ultra-Modern Automotive Centers"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38852_unido-signs-3-88-million-agreement-to-establish-four-ultra-modern-automotive-centers/" rel="bookmark" title="UNIDO Signs $3.88 Million Agreement to Establish Four Ultra-Modern Automotive Centers">
UNIDO Signs $3.88 Million Agreement to Establish Four Ultra-Modern Automotive Centers </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-03-26T16:08:13+00:00">March 26, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/164563003_794430147878098_7376313733205515128_n-1-263x175.jpg" href="https://www.switsalone.com/38839_devastating-fire-incident-in-susans-bay-left-thousands-of-people-homeless/" title="Devastating fire incident in Susan’s Bay leaves thousands of people homeless"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38839_devastating-fire-incident-in-susans-bay-left-thousands-of-people-homeless/" rel="bookmark" title="Devastating fire incident in Susan’s Bay leaves thousands of people homeless">
Devastating fire incident in Susan’s Bay leaves thousands of people homeless </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-03-25T13:06:21+00:00">March 25, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/leone-star-263x175.jpg" href="https://www.switsalone.com/38827_leone-stars-departs-for-lesotho-in-their-2021-african-cup-of-nations-qualification-bid/" title="Leone Stars Departs for Lesotho in their 2021 African Cup of Nations Qualification Bid"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38827_leone-stars-departs-for-lesotho-in-their-2021-african-cup-of-nations-qualification-bid/" rel="bookmark" title="Leone Stars Departs for Lesotho in their 2021 African Cup of Nations Qualification Bid">
Leone Stars Departs for Lesotho in their 2021 African Cup of Nations Qualification Bid </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-03-24T19:53:01+00:00">March 24, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/WhatsApp-Image-2021-03-24-at-4.29.31-AM-263x175.jpeg" href="https://www.switsalone.com/38832_sierra-leone-ends-12-months-state-of-public-health-emergency/" title="Sierra Leone ends 12 months State of Public Health Emergency"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38832_sierra-leone-ends-12-months-state-of-public-health-emergency/" rel="bookmark" title="Sierra Leone ends 12 months State of Public Health Emergency">
Sierra Leone ends 12 months State of Public Health Emergency </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-03-24T16:13:22+00:00">March 24, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/US-ambassador-263x175.jpg" href="https://www.switsalone.com/38806_who-is-david-reimer-the-new-u-s-ambassador-to-sierra-leone/" title="Who is  David Reimer the New U.S. Ambassador to Sierra Leone."></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38806_who-is-david-reimer-the-new-u-s-ambassador-to-sierra-leone/" rel="bookmark" title="Who is  David Reimer the New U.S. Ambassador to Sierra Leone.">
Who is David Reimer the New U.S. Ambassador to Sierra Leone. </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-03-17T20:00:22+00:00">March 17, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/WhatsApp-Image-2021-03-15-at-7.42.24-AM-263x175.jpeg" href="https://www.switsalone.com/38795_make-sierra-leone-famous-podcast-ep11-sierra-leoneans-who-shaped-history-with-akindele-decker/" title="Make Sierra Leone Famous Podcast Ep11 –Sierra Leoneans Who Shaped History with Akindele Decker"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38795_make-sierra-leone-famous-podcast-ep11-sierra-leoneans-who-shaped-history-with-akindele-decker/" rel="bookmark" title="Make Sierra Leone Famous Podcast Ep11 –Sierra Leoneans Who Shaped History with Akindele Decker">
Make Sierra Leone Famous Podcast Ep11 –Sierra Leoneans Who Shaped History with Akindele Decker </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-03-17T19:00:30+00:00">March 17, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/Agro-processing-263x175.jpg" href="https://www.switsalone.com/38800_25-agro-processing-smes-in-sierra-leone-benefit-from-usd-1-3-million-covid-19-relief-fund-grant/" title="25 Agro-Processing SMEs in Sierra Leone benefit from USD 1.3 Million Covid-19 Relief Fund Grant"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38800_25-agro-processing-smes-in-sierra-leone-benefit-from-usd-1-3-million-covid-19-relief-fund-grant/" rel="bookmark" title="25 Agro-Processing SMEs in Sierra Leone benefit from USD 1.3 Million Covid-19 Relief Fund Grant">
25 Agro-Processing SMEs in Sierra Leone benefit from USD 1.3 Million Covid-19 Relief Fund Grant </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-03-17T18:00:00+00:00">March 17, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/161293257_803771033562373_4127832802742692878_n-263x175.jpg" href="https://www.switsalone.com/38789_breaking-news-president-bio-appoints-kao-denero-as-special-envoy-for-entertainment-in-sierra-leone/" title="Breaking News: President Bio appoints Kao Denero as Special Envoy for Entertainment in Sierra Leone"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38789_breaking-news-president-bio-appoints-kao-denero-as-special-envoy-for-entertainment-in-sierra-leone/" rel="bookmark" title="Breaking News: President Bio appoints Kao Denero as Special Envoy for Entertainment in Sierra Leone">
Breaking News: President Bio appoints Kao Denero as Special Envoy for Entertainment in Sierra Leone </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-03-16T20:47:50+00:00">March 16, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/President-Bio1-263x175.jpg" href="https://www.switsalone.com/38780_sierra-leone-rolls-out-covid-19-vaccination/" title="Sierra Leone Rolls Out Covid-19 Vaccination"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38780_sierra-leone-rolls-out-covid-19-vaccination/" rel="bookmark" title="Sierra Leone Rolls Out Covid-19 Vaccination">
Sierra Leone Rolls Out Covid-19 Vaccination </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-03-15T17:10:32+00:00">March 15, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/Wizkid-Burna-Boy-263x175.png" href="https://www.switsalone.com/38766_nigerias-burna-boy-and-wizkid-win-grammy-awards/" title="Nigeria’s Burna Boy and Wizkid win Grammy Awards"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38766_nigerias-burna-boy-and-wizkid-win-grammy-awards/" rel="bookmark" title="Nigeria’s Burna Boy and Wizkid win Grammy Awards">
Nigeria’s Burna Boy and Wizkid win Grammy Awards </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-03-15T16:15:07+00:00">March 15, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/Flutterwave_IMTC-263x175.jpg" href="https://www.switsalone.com/38751_nigerian-fintech-company-is-valued-at-usd-1-billion/" title="Nigerian Fintech Company is valued at USD 1 billion"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38751_nigerian-fintech-company-is-valued-at-usd-1-billion/" rel="bookmark" title="Nigerian Fintech Company is valued at USD 1 billion">
Nigerian Fintech Company is valued at USD 1 billion </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-03-11T19:00:43+00:00">March 11, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/G0012822_w-263x175.jpg" href="https://www.switsalone.com/38744_caf-lifts-ban-on-sierra-leones-national-stadium-temporarily/" title="CAF lifts ban on Sierra Leone’s national stadium temporarily"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38744_caf-lifts-ban-on-sierra-leones-national-stadium-temporarily/" rel="bookmark" title="CAF lifts ban on Sierra Leone’s national stadium temporarily">
CAF lifts ban on Sierra Leone’s national stadium temporarily </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-03-10T20:00:30+00:00">March 10, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/covax-sl-263x175.jpg" href="https://www.switsalone.com/38732_sierra-leone-receives-96000-astrazeneca-oxford-covid-19-vaccine-dose/" title="Sierra Leone receives 96,000 AstraZeneca-Oxford COVID-19 Vaccine Dose"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38732_sierra-leone-receives-96000-astrazeneca-oxford-covid-19-vaccine-dose/" rel="bookmark" title="Sierra Leone receives 96,000 AstraZeneca-Oxford COVID-19 Vaccine Dose">
Sierra Leone receives 96,000 AstraZeneca-Oxford COVID-19 Vaccine Dose </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-03-09T17:08:50+00:00">March 9, 2021</time></span>
 </div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/International-Womens-Day-2021-ChooseToChallenge-263x175.png" href="https://www.switsalone.com/38714_international-womens-day-2021-womens-rights-are-human-rights-choosetochallenge/" title="International Women’s Day 2021: Women’s rights are human rights #ChooseToChallenge"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38714_international-womens-day-2021-womens-rights-are-human-rights-choosetochallenge/" rel="bookmark" title="International Women’s Day 2021: Women’s rights are human rights #ChooseToChallenge">
International Women’s Day 2021: Women’s rights are human rights #ChooseToChallenge </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-03-08T18:11:06+00:00">March 8, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/EulaSkXXMAE69Uf-263x175.jpeg" href="https://www.switsalone.com/38700_a-petroleum-engineer-and-an-artist-meet-dr-shu-the-man-himself/" title="A Petroleum Engineer and an Artist Meet Dr. Shu “The Man Himself”"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38700_a-petroleum-engineer-and-an-artist-meet-dr-shu-the-man-himself/" rel="bookmark" title="A Petroleum Engineer and an Artist Meet Dr. Shu “The Man Himself”">
A Petroleum Engineer and an Artist Meet Dr. Shu “The Man Himself” </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-03-06T14:33:41+00:00">March 6, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/ESWBQllXYAANyTo-263x175.jpg" href="https://www.switsalone.com/38695_world-book-day-celebrating-sierra-leonean-authors/" title="World Book Day: Celebrating Sierra Leonean authors"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38695_world-book-day-celebrating-sierra-leonean-authors/" rel="bookmark" title="World Book Day: Celebrating Sierra Leonean authors">
World Book Day: Celebrating Sierra Leonean authors </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-03-04T22:30:47+00:00">March 4, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/89803697_104011557897025_9066356154296172544_n-263x175.jpg" href="https://www.switsalone.com/38693_slfa-payouts-usd-500-thousand-to-football-clubs-and-member-associations/" title="SLFA payouts USD 500 thousand to football clubs and member associations"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38693_slfa-payouts-usd-500-thousand-to-football-clubs-and-member-associations/" rel="bookmark" title="SLFA payouts USD 500 thousand to football clubs and member associations">
SLFA payouts USD 500 thousand to football clubs and member associations </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-03-04T18:02:38+00:00">March 4, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/FB_IMG_16147942338393893-263x175.jpg" href="https://www.switsalone.com/38686_new-music-star-zee-releases-life/" title="New Music: Star Zee releases “Life”"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38686_new-music-star-zee-releases-life/" rel="bookmark" title="New Music: Star Zee releases “Life”">
New Music: Star Zee releases “Life” </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-03-04T10:45:21+00:00">March 4, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/Food-Nutrients.jpg" href="https://www.switsalone.com/38674_sierra-leone-ranked-108-out-of-113-countries-in-2020-global-food-security-index/" title="Sierra Leone Ranked 108 Out of 113 Countries in 2020 Global Food Security Index"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38674_sierra-leone-ranked-108-out-of-113-countries-in-2020-global-food-security-index/" rel="bookmark" title="Sierra Leone Ranked 108 Out of 113 Countries in 2020 Global Food Security Index">
Sierra Leone Ranked 108 Out of 113 Countries in 2020 Global Food Security Index </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-03-02T21:00:11+00:00">March 2, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/FCC-1-263x175.jpg" href="https://www.switsalone.com/38625_massive-fire-outbreak-at-mount-aureol-community-leaves-over-200-people-homeless/" title="Freetown City Council donates Relief Items to Fire Victims at The Mount Aureol Community"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38625_massive-fire-outbreak-at-mount-aureol-community-leaves-over-200-people-homeless/" rel="bookmark" title="Freetown City Council donates Relief Items to Fire Victims at The Mount Aureol Community">
Freetown City Council donates Relief Items to Fire Victims at The Mount Aureol Community </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-03-02T17:03:00+00:00">March 2, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/G0012822_w-263x175.jpg" href="https://www.switsalone.com/38667_caf-bans-sierra-leones-national-stadium-from-playing-international-matches/" title="CAF bans Sierra Leone’s national stadium from playing international matches"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38667_caf-bans-sierra-leones-national-stadium-from-playing-international-matches/" rel="bookmark" title="CAF bans Sierra Leone’s national stadium from playing international matches">
CAF bans Sierra Leone’s national stadium from playing international matches </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-03-02T15:53:37+00:00">March 2, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/03/58dcbf62ddfbffbc2379e590395e2cebe2a874b99a5776d245e45b35676e45a0-263x175.jpeg" href="https://www.switsalone.com/38634_new-music-solos-beat-releases-debut-album-joanna/" title="New Music: Solo&#8217;s Beat Releases Debut Album &#8220;Joanna&#8221;"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38634_new-music-solos-beat-releases-debut-album-joanna/" rel="bookmark" title="New Music: Solo&#8217;s Beat Releases Debut Album &#8220;Joanna&#8221;">
New Music: Solo&#8217;s Beat Releases Debut Album &#8220;Joanna&#8221; </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-03-01T18:18:04+00:00">March 1, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/Eu-y5xvWYAEYBto-263x175.jpeg" href="https://www.switsalone.com/38580_ghana-is-the-first-country-in-africa-to-receive-covax-vaccines/" title="Ghana is the first country in Africa to receive Covax vaccines"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38580_ghana-is-the-first-country-in-africa-to-receive-covax-vaccines/" rel="bookmark" title="Ghana is the first country in Africa to receive Covax vaccines">
Ghana is the first country in Africa to receive Covax vaccines </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-02-24T14:24:06+00:00">February 24, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/89803697_104011557897025_9066356154296172544_n-263x175.jpg" href="https://www.switsalone.com/38572_slfa-postpones-upcoming-elective-congress/" title="SLFA postpones upcoming elective congress"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38572_slfa-postpones-upcoming-elective-congress/" rel="bookmark" title="SLFA postpones upcoming elective congress">
SLFA postpones upcoming elective congress  </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-02-23T18:19:14+00:00">February 23, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/SierraLeone_0416_PrinceChristianMaternity_EHansen_crop-263x175.jpg" href="https://www.switsalone.com/38561_baby-dies-at-cottage-due-to-lack-of-surgical-equipment/" title="Baby Dies at Cottage Due to Lack of Surgical Equipment"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38561_baby-dies-at-cottage-due-to-lack-of-surgical-equipment/" rel="bookmark" title="Baby Dies at Cottage Due to Lack of Surgical Equipment">
Baby Dies at Cottage Due to Lack of Surgical Equipment </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-02-23T17:56:12+00:00">February 23, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/WhatsApp-Image-2021-02-22-at-3.58.34-AM-263x175.jpeg" href="https://www.switsalone.com/38555_new-music-alert-mello-seven-releases-joborti-featuring-rozzay/" title="New Music Alert: Mello Seven releases “Joborti” featuring Rozzay"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38555_new-music-alert-mello-seven-releases-joborti-featuring-rozzay/" rel="bookmark" title="New Music Alert: Mello Seven releases “Joborti” featuring Rozzay">
New Music Alert: Mello Seven releases “Joborti” featuring Rozzay </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-02-22T13:30:24+00:00">February 22, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/LadimaAcademy-1-263x175.jpg" href="https://www.switsalone.com/38540_ladima-foundation-launches-its-film-academy/" title="Ladima Foundation launches its Film Academy"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38540_ladima-foundation-launches-its-film-academy/" rel="bookmark" title="Ladima Foundation launches its Film Academy">
Ladima Foundation launches its Film Academy </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-02-19T17:39:41+00:00">February 19, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/A-timeline-of-Ebola-vaccine-development_wrbm_large-263x175.jpg" href="https://www.switsalone.com/38535_who-to-send-11000-ebola-vaccines-to-guinea/" title="WHO to send 11,000 Ebola vaccines to Guinea"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38535_who-to-send-11000-ebola-vaccines-to-guinea/" rel="bookmark" title="WHO to send 11,000 Ebola vaccines to Guinea">
WHO to send 11,000 Ebola vaccines to Guinea </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-02-19T16:45:45+00:00">February 19, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/Euc1QY_XcAM1PVz-263x175.jpg" href="https://www.switsalone.com/38529_freetown-mayor-yvonne-aki-sawyer-named-as-time100-next-most-influential-people/" title="Freetown Mayor Yvonne Aki Sawyer named as TIME100 Next Most Influential People"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38529_freetown-mayor-yvonne-aki-sawyer-named-as-time100-next-most-influential-people/" rel="bookmark" title="Freetown Mayor Yvonne Aki Sawyer named as TIME100 Next Most Influential People">
Freetown Mayor Yvonne Aki Sawyer named as TIME100 Next Most Influential People </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-02-18T18:00:30+00:00">February 18, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/150785939_3893919440664551_649549856645799730_n-263x175.jpg" href="https://www.switsalone.com/38525_itribe-releases-debut-album-dis-feeling/" title="Itribe releases debut album “Dis Feeling”"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38525_itribe-releases-debut-album-dis-feeling/" rel="bookmark" title="Itribe releases debut album “Dis Feeling”">
Itribe releases debut album “Dis Feeling” </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-02-18T17:49:58+00:00">February 18, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/president-Bio-commemorates-armed-forces-day-263x175.jpg" href="https://www.switsalone.com/38521_armed-forces-day-here-are-facts-about-the-republic-of-sierra-leone-armed-forces-everyone-should-know/" title="Armed Forces Day: Here are Facts about The Republic of Sierra Leone Armed Forces Everyone should know"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38521_armed-forces-day-here-are-facts-about-the-republic-of-sierra-leone-armed-forces-everyone-should-know/" rel="bookmark" title="Armed Forces Day: Here are Facts about The Republic of Sierra Leone Armed Forces Everyone should know">
Armed Forces Day: Here are Facts about The Republic of Sierra Leone Armed Forces Everyone should know </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-02-18T11:13:22+00:00">February 18, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/KKY-263x175.jpg" href="https://www.switsalone.com/38494_kky-calls-on-parliament-to-probe-into-the-financial-allegations-of-the-office-of-the-president/" title="KKY calls on Parliament to Probe into the Financial Allegations of the Office of the President"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38494_kky-calls-on-parliament-to-probe-into-the-financial-allegations-of-the-office-of-the-president/" rel="bookmark" title="KKY calls on Parliament to Probe into the Financial Allegations of the Office of the President">
KKY calls on Parliament to Probe into the Financial Allegations of the Office of the President </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-02-17T18:52:35+00:00">February 17, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/IMG_0159-263x175.jpg" href="https://www.switsalone.com/38484_sl-mining-wins-case-against-sierra-leone-at-the-international-chamber-of-commerce/" title="SL Mining Wins Case Against Sierra Leone at the International Chamber of Commerce"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38484_sl-mining-wins-case-against-sierra-leone-at-the-international-chamber-of-commerce/" rel="bookmark" title="SL Mining Wins Case Against Sierra Leone at the International Chamber of Commerce">
SL Mining Wins Case Against Sierra Leone at the International Chamber of Commerce </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-02-17T10:19:30+00:00">February 17, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/5B5A3C6D-684E-4AC9-A4F2-988D09432954-263x175.jpg" href="https://www.switsalone.com/38467_pujehun-health-management-team-reports-a-suspected-ebola-case/" title="Pujehun Health Management Team Reports a Suspected Ebola Case"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38467_pujehun-health-management-team-reports-a-suspected-ebola-case/" rel="bookmark" title="Pujehun Health Management Team Reports a Suspected Ebola Case">
Pujehun Health Management Team Reports a Suspected Ebola Case </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-02-16T13:58:23+00:00">February 16, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/images282029-263x175.jpeg" href="https://www.switsalone.com/38455_meet-ngozi-okonjo-iweala-the-nigerian-economist-appointed-director-general-of-the-world-trade-organisation/" title="Meet Ngozi Okonjo-Iweala the Nigerian Economist Appointed Director-General of the World Trade Organisation"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38455_meet-ngozi-okonjo-iweala-the-nigerian-economist-appointed-director-general-of-the-world-trade-organisation/" rel="bookmark" title="Meet Ngozi Okonjo-Iweala the Nigerian Economist Appointed Director-General of the World Trade Organisation">
Meet Ngozi Okonjo-Iweala the Nigerian Economist Appointed Director-General of the World Trade Organisation </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-02-15T17:53:14+00:00">February 15, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/17911388_401-263x175.jpg" href="https://www.switsalone.com/38440_ebola-reemerges-in-guinea-for-the-first-time-since-2014-outbreak/" title="Ebola Reemerges in Guinea for the First Time Since 2014 Outbreak."></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38440_ebola-reemerges-in-guinea-for-the-first-time-since-2014-outbreak/" rel="bookmark" title="Ebola Reemerges in Guinea for the First Time Since 2014 Outbreak.">
Ebola Reemerges in Guinea for the First Time Since 2014 Outbreak. </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-02-15T13:36:52+00:00">February 15, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/130960879_3472569492812560_2229894350877702435_o-263x175.jpg" href="https://www.switsalone.com/38424_meet-sierra-leones-essential-workers-the-petty-trader/" title="Meet Sierra Leone&#8217;s Essential Workers: The  Petty Trader"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38424_meet-sierra-leones-essential-workers-the-petty-trader/" rel="bookmark" title="Meet Sierra Leone&#8217;s Essential Workers: The  Petty Trader">
Meet Sierra Leone&#8217;s Essential Workers: The Petty Trader </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-02-12T12:50:56+00:00">February 12, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/Austin-Demby-Large-263x175.jpg" href="https://www.switsalone.com/38419_who-is-dr-austin-demby-sierra-leones-new-health-minister/" title="Who is Dr. Austin Demby Sierra Leone’s New Health Minister"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38419_who-is-dr-austin-demby-sierra-leones-new-health-minister/" rel="bookmark" title="Who is Dr. Austin Demby Sierra Leone’s New Health Minister">
Who is Dr. Austin Demby Sierra Leone’s New Health Minister </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-02-11T15:06:37+00:00">February 11, 2021</time></span>
 </div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/130049742_3457393394330170_3268072506919433643_o-263x175.png" href="https://www.switsalone.com/38414_meet-sierra-leones-essential-workers-the-fruit-seller/" title="Meet Sierra Leone&#8217;s Essential Workers: The Fruit Seller"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38414_meet-sierra-leones-essential-workers-the-fruit-seller/" rel="bookmark" title="Meet Sierra Leone&#8217;s Essential Workers: The Fruit Seller">
Meet Sierra Leone&#8217;s Essential Workers: The Fruit Seller </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-02-11T11:39:25+00:00">February 11, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/130702745_3465000336902809_2290291026892218904_o-263x175.png" href="https://www.switsalone.com/38405_meet-sierra-leones-essential-workers-the-multimedia-producer/" title="Meet Sierra Leone&#8217;s Essential Workers: The Multimedia Producer"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38405_meet-sierra-leones-essential-workers-the-multimedia-producer/" rel="bookmark" title="Meet Sierra Leone&#8217;s Essential Workers: The Multimedia Producer">
Meet Sierra Leone&#8217;s Essential Workers: The Multimedia Producer </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-02-10T19:00:24+00:00">February 10, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/BeFunky-collage-263x175.jpg" href="https://www.switsalone.com/38382_new-books-by-sierra-leoneans-everyone-needs-in-2021/" title="New Books by Sierra Leoneans everyone needs in 2021"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38382_new-books-by-sierra-leoneans-everyone-needs-in-2021/" rel="bookmark" title="New Books by Sierra Leoneans everyone needs in 2021">
New Books by Sierra Leoneans everyone needs in 2021 </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-02-10T13:49:11+00:00">February 10, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/Untitled-design-2-263x175.png" href="https://www.switsalone.com/38351_inside-salone-entertainment-whats-going-on-between-markmuday-and-samira/" title="Inside Salone Entertainment: What’s going on between Markmuday and Samira?"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38351_inside-salone-entertainment-whats-going-on-between-markmuday-and-samira/" rel="bookmark" title="Inside Salone Entertainment: What’s going on between Markmuday and Samira?">
Inside Salone Entertainment: What’s going on between Markmuday and Samira? </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-02-05T14:00:49+00:00">February 5, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/129480831_3451981438204699_1009571639432234374_o-263x175.png" href="https://www.switsalone.com/38345_meet-sierra-leones-essential-workers-the-communications-manager/" title="Meet Sierra Leone&#8217;s Essential Workers: The Communications Manager"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38345_meet-sierra-leones-essential-workers-the-communications-manager/" rel="bookmark" title="Meet Sierra Leone&#8217;s Essential Workers: The Communications Manager">
Meet Sierra Leone&#8217;s Essential Workers: The Communications Manager </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-02-05T10:00:40+00:00">February 5, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/Turad-Senessie-263x175.jpg" href="https://www.switsalone.com/38340_who-is-dr-turad-senesie-sierra-leones-new-lands-minister/" title="Who is Dr. Turad Senesie Sierra Leone’s new Lands Minister"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38340_who-is-dr-turad-senesie-sierra-leones-new-lands-minister/" rel="bookmark" title="Who is Dr. Turad Senesie Sierra Leone’s new Lands Minister">
Who is Dr. Turad Senesie Sierra Leone’s new Lands Minister </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-02-04T18:14:38+00:00">February 4, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/Coat_of_arms_of_Sierra_Leone-263x175.png" href="https://www.switsalone.com/38337_sierra-leone-moves-2-place-up-in-the-2020-transparency-int-corruption-index/" title="Sierra Leone Moves 2 Place Up in the 2020 Transparency Int. Corruption  Index"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38337_sierra-leone-moves-2-place-up-in-the-2020-transparency-int-corruption-index/" rel="bookmark" title="Sierra Leone Moves 2 Place Up in the 2020 Transparency Int. Corruption  Index">
Sierra Leone Moves 2 Place Up in the 2020 Transparency Int. Corruption Index </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-02-04T11:58:18+00:00">February 4, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/Celebrating-Black-History-Month_1200px-x-400px_v1-263x175.jpg" href="https://www.switsalone.com/38330_what-do-we-know-about-black-history-month/" title="5 Things You Should Know About Black History Month"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38330_what-do-we-know-about-black-history-month/" rel="bookmark" title="5 Things You Should Know About Black History Month">
5 Things You Should Know About Black History Month </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-02-03T16:30:34+00:00">February 3, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/02/release-263x175.jpg" href="https://www.switsalone.com/38322_the-national-covid-19-emergency-response-center-nacoverc-opens-6-new-covid-19-testing-centers-in-freetown/" title="The National Covid-19 Emergency Response Center (NaCOVERC) opens 6 New Covid-19 Testing Centers in Freetown"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38322_the-national-covid-19-emergency-response-center-nacoverc-opens-6-new-covid-19-testing-centers-in-freetown/" rel="bookmark" title="The National Covid-19 Emergency Response Center (NaCOVERC) opens 6 New Covid-19 Testing Centers in Freetown">
The National Covid-19 Emergency Response Center (NaCOVERC) opens 6 New Covid-19 Testing Centers in Freetown </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-02-01T09:06:49+00:00">February 1, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/Francis-Ben-Kaifala-33-1-263x175.png" href="https://www.switsalone.com/38313_sierra-leones-anti-corruption-commissioner-francis-ben-kaifala-included-in-the-list-of-100-most-influential-young-leaders-in-africa/" title="Sierra Leone’s Anti Corruption Commissioner, Francis Ben-Kaifala included in the list of 100 Most Influential Young Leaders in Africa"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38313_sierra-leones-anti-corruption-commissioner-francis-ben-kaifala-included-in-the-list-of-100-most-influential-young-leaders-in-africa/" rel="bookmark" title="Sierra Leone’s Anti Corruption Commissioner, Francis Ben-Kaifala included in the list of 100 Most Influential Young Leaders in Africa">
Sierra Leone’s Anti Corruption Commissioner, Francis Ben-Kaifala included in the list of 100 Most Influential Young Leaders in Africa </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-01-29T14:52:56+00:00">January 29, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/Esv5gPjXYAQxba6-263x175.jpg" href="https://www.switsalone.com/38311_hindolo-pokawa-completes-315-miles-walk-from-kailahun-to-freetown-in-solidarity-of-rape-and-sexual-violence-in-sierra-leone/" title="Hindolo Pokawa completes 315 miles walk from Kailahun to Freetown in Solidarity of Rape and Sexual Violence in Sierra Leone"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38311_hindolo-pokawa-completes-315-miles-walk-from-kailahun-to-freetown-in-solidarity-of-rape-and-sexual-violence-in-sierra-leone/" rel="bookmark" title="Hindolo Pokawa completes 315 miles walk from Kailahun to Freetown in Solidarity of Rape and Sexual Violence in Sierra Leone">
Hindolo Pokawa completes 315 miles walk from Kailahun to Freetown in Solidarity of Rape and Sexual Violence in Sierra Leone </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-01-29T14:31:18+00:00">January 29, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/Eslf6jvW8AAL6MG-263x175.jpeg" href="https://www.switsalone.com/38284_africa-podfest-international-podcast-day-presents-wheres-the-money-in-africa-podcasting-join-the-conversation/" title="Africa Podfest &#038; International Podcast Day Presents: “Where’s the money in Africa Podcasting” &#8211; Join the Conversation!"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38284_africa-podfest-international-podcast-day-presents-wheres-the-money-in-africa-podcasting-join-the-conversation/" rel="bookmark" title="Africa Podfest &#038; International Podcast Day Presents: “Where’s the money in Africa Podcasting” &#8211; Join the Conversation!">
Africa Podfest &#038; International Podcast Day Presents: “Where’s the money in Africa Podcasting” &#8211; Join the Conversation! </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-01-27T19:40:37+00:00">January 27, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/University-of-Sierra-Leone-2_1-263x175.jpg" href="https://www.switsalone.com/38280_academic-staff-association-of-usl-njala-and-ebkust-present-salary-review-document-to-government/" title="Academic Staff Association of USL, Njala, and EBKUST present Salary Review Document to Government"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38280_academic-staff-association-of-usl-njala-and-ebkust-present-salary-review-document-to-government/" rel="bookmark" title="Academic Staff Association of USL, Njala, and EBKUST present Salary Review Document to Government">
Academic Staff Association of USL, Njala, and EBKUST present Salary Review Document to Government </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-01-27T13:36:30+00:00">January 27, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/unnamed.png" href="https://www.switsalone.com/38270_sierra-leone-law-school-releases-results-for-the-2020-bar-examination/" title="Sierra Leone Law School releases results for the 2020 Bar Examination"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38270_sierra-leone-law-school-releases-results-for-the-2020-bar-examination/" rel="bookmark" title="Sierra Leone Law School releases results for the 2020 Bar Examination">
Sierra Leone Law School releases results for the 2020 Bar Examination </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-01-26T20:26:56+00:00">January 26, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/ellakoblogulama-263x175.jpg" href="https://www.switsalone.com/38273_ella-koblo-gulama-day-the-queen-would-have-been-100-today/" title="Ella Koblo Gulama Day: The Queen would have been 100 today!"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38273_ella-koblo-gulama-day-the-queen-would-have-been-100-today/" rel="bookmark" title="Ella Koblo Gulama Day: The Queen would have been 100 today!">
Ella Koblo Gulama Day: The Queen would have been 100 today! </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-01-26T20:14:10+00:00">January 26, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/Memuna-Konteh-on-Black-Diaspora-263x175.png" href="https://www.switsalone.com/38265_sierra-leonean-diasporas-need-to-check-their-privilege-when-returning-home-in-a-pandemic/" title="Sierra Leonean Diasporas need to check their privilege when returning home in a pandemic"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38265_sierra-leonean-diasporas-need-to-check-their-privilege-when-returning-home-in-a-pandemic/" rel="bookmark" title="Sierra Leonean Diasporas need to check their privilege when returning home in a pandemic">
Sierra Leonean Diasporas need to check their privilege when returning home in a pandemic </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-01-26T12:10:58+00:00">January 26, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/20210125_140429_0000-263x175.png" href="https://www.switsalone.com/38262_first-lady-fatima-bio-endorses-driziliks-mamas-nomination/" title="First Lady Fatima Bio endorses Drizilik’s MAMAs nomination"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38262_first-lady-fatima-bio-endorses-driziliks-mamas-nomination/" rel="bookmark" title="First Lady Fatima Bio endorses Drizilik’s MAMAs nomination">
First Lady Fatima Bio endorses Drizilik’s MAMAs nomination </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-01-25T14:10:25+00:00">January 25, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/slnja-263x175.jpg" href="https://www.switsalone.com/38251_love-story-gone-wrong-meet-the-sierra-leonean-woman-who-dropped-out-of-medical-school-because-of-love/" title="Love Story Gone Wrong: Meet The Sierra Leonean Woman Who Dropped Out Of Medical School Because of Love"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38251_love-story-gone-wrong-meet-the-sierra-leonean-woman-who-dropped-out-of-medical-school-because-of-love/" rel="bookmark" title="Love Story Gone Wrong: Meet The Sierra Leonean Woman Who Dropped Out Of Medical School Because of Love">
Love Story Gone Wrong: Meet The Sierra Leonean Woman Who Dropped Out Of Medical School Because of Love </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-01-23T21:52:39+00:00">January 23, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/Esauj9aU4AEfGB2-263x175.jpeg" href="https://www.switsalone.com/38247_legendary-american-talk-show-host-larry-king-dies-at-age-87/" title="Legendary American Talk Show Host Larry King dies at age 87"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38247_legendary-american-talk-show-host-larry-king-dies-at-age-87/" rel="bookmark" title="Legendary American Talk Show Host Larry King dies at age 87">
Legendary American Talk Show Host Larry King dies at age 87 </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-01-23T18:41:17+00:00">January 23, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/141747690_774889659783844_1934985398385784611_o-263x175.jpg" href="https://www.switsalone.com/38241_kao-denero-throw-shades-on-driziliks-mamas-nomination/" title="Kao Denero throw shades on Drizilik’s MAMAs nomination"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38241_kao-denero-throw-shades-on-driziliks-mamas-nomination/" rel="bookmark" title="Kao Denero throw shades on Drizilik’s MAMAs nomination">
Kao Denero throw shades on Drizilik’s MAMAs nomination </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-01-23T11:41:22+00:00">January 23, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/37353471_1322348424565600_6769944880379592704_n-263x175.jpg" href="https://www.switsalone.com/38235_sierra-leones-first-female-engineer-named-2021-imperial-college-distinguished-alumni-award/" title="Sierra Leone’s first Female Engineer named 2021 Imperial College Distinguished Alumni Award"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38235_sierra-leones-first-female-engineer-named-2021-imperial-college-distinguished-alumni-award/" rel="bookmark" title="Sierra Leone’s first Female Engineer named 2021 Imperial College Distinguished Alumni Award">
Sierra Leone’s first Female Engineer named 2021 Imperial College Distinguished Alumni Award </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-01-22T16:38:15+00:00">January 22, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/2021-01-20T165033Z_779931362_HP1EH1K1AS94N_RTRMADP_3_USA-BIDEN-INAUGURATION-1024x681-1-263x175.jpg" href="https://www.switsalone.com/38220_what-you-didnt-know-about-president-joe-biden-and-vice-president-kamala-harris-of-the-united-states/" title="What you didn’t know about President Joe Biden and Vice President Kamala Harris of the United States"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38220_what-you-didnt-know-about-president-joe-biden-and-vice-president-kamala-harris-of-the-united-states/" rel="bookmark" title="What you didn’t know about President Joe Biden and Vice President Kamala Harris of the United States">
What you didn’t know about President Joe Biden and Vice President Kamala Harris of the United States </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-01-21T14:34:40+00:00">January 21, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/EnMtK17XIAI9bZn-263x175.jpg" href="https://www.switsalone.com/38213_drizilik-nominated-for-the-2021-mamas-listeners-choice-awards/" title="Drizilik nominated for the 2021 MAMAs Listeners’ Choice Awards"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38213_drizilik-nominated-for-the-2021-mamas-listeners-choice-awards/" rel="bookmark" title="Drizilik nominated for the 2021 MAMAs Listeners’ Choice Awards">
Drizilik nominated for the 2021 MAMAs Listeners’ Choice Awards </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-01-21T13:58:43+00:00">January 21, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/9-3-263x175.jpg" href="https://www.switsalone.com/38209_sierra-leone-first-lady-fatima-bio-reacts-to-accusations-of-using-state-funds-for-personal-use/" title="Sierra Leone: First Lady Fatima Bio reacts to accusations of using state funds for personal use"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38209_sierra-leone-first-lady-fatima-bio-reacts-to-accusations-of-using-state-funds-for-personal-use/" rel="bookmark" title="Sierra Leone: First Lady Fatima Bio reacts to accusations of using state funds for personal use">
Sierra Leone: First Lady Fatima Bio reacts to accusations of using state funds for personal use </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-01-21T11:47:52+00:00">January 21, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/01/download-9-263x175.jpg" href="https://www.switsalone.com/38205_bidens-inauguration-donald-trump-leaves-the-white-house/" title="Biden’s Inauguration: Donald Trump leaves the White House"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/38205_bidens-inauguration-donald-trump-leaves-the-white-house/" rel="bookmark" title="Biden’s Inauguration: Donald Trump leaves the White House">
Biden’s Inauguration: Donald Trump leaves the White House </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-01-20T16:07:34+00:00">January 20, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2020/03/slnews-cover-263x175.jpeg" href="https://www.switsalone.com/39058_sierra-leone-news-today-161/" title="Sierra Leone News Today"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/39058_sierra-leone-news-today-161/" rel="bookmark" title="Sierra Leone News Today">
Sierra Leone News Today </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-05-12T14:09:48+00:00">May 12, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.switsalone.com/wp-content/uploads/2021/05/CG1-263x175.jpg" href="https://www.switsalone.com/39054_sierra-leone-news-today-160/" title="Sierra Leone News Today"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.switsalone.com/39054_sierra-leone-news-today-160/" rel="bookmark" title="Sierra Leone News Today">
Sierra Leone News Today </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-05-11T14:00:00+00:00">May 11, 2021</time></span>
</div>
</div>
</li>
</ul>
</aside> </div>
</div>
</div>
<footer id="footer-section" class="penci-footer-social-media penci-lazy footer-social-remove-circle" itemscope itemtype="https://schema.org/WPFooter">
<div class="container">
<div class="footer-logo-copyright footer-not-logo footer-not-gotop">
<div id="footer-copyright">
<p>@2021 - All Right Reserved by Swit Salone</p>
</div>
</div>
<div class="penci-go-to-top-floating"><i class="penci-faicon fa fa-angle-up"></i></div>
</div>
</footer>
</div>
<div id="fb-root"></div>
<div class="et_bloom_popup et_bloom_optin et_bloom_resize et_bloom_optin_1 et_bloom_auto_popup et_bloom_trigger_bottom et_bloom_trigger_idle et_bloom_after_comment" data-delay="20" data-cookie_duration="1" data-idle_timeout="15">
<div class="et_bloom_form_container et_bloom_popup_container et_bloom_form_bottom with_edge breakout_edge et_bloom_rounded et_bloom_form_text_dark et_bloom_animation_fadein">
<div class="et_bloom_form_container_wrapper clearfix">
<div class="et_bloom_header_outer">
<div class="et_bloom_form_header split et_bloom_header_text_dark">
<img width="610" height="610" src="https://www.switsalone.com/wp-content/uploads/switsalone-news-logo-610x610.png" class=" et_bloom_image_slideup et_bloom_image" alt="" srcset="https://www.switsalone.com/wp-content/uploads/switsalone-news-logo-610x610.png 610w, https://www.switsalone.com/wp-content/uploads/switsalone-news-logo-150x150.png 150w, https://www.switsalone.com/wp-content/uploads/switsalone-news-logo-450x450.png 450w, https://www.switsalone.com/wp-content/uploads/switsalone-news-logo-768x768.png 768w, https://www.switsalone.com/wp-content/uploads/switsalone-news-logo-696x696.png 696w, https://www.switsalone.com/wp-content/uploads/switsalone-news-logo-420x420.png 420w, https://www.switsalone.com/wp-content/uploads/switsalone-news-logo.png 960w" sizes="(max-width: 610px) 100vw, 610px" />
<div class="et_bloom_form_text">
<h2>Subscribe To Our Newsletter</h2><p><span style="font-size: 24px;"><span style="font-family: georgia,times,times new roman,serif;"><span style="line-height: 21px;">KUSHE O! BE THE FIRST TO KNOW! Get Breaking News, and the latest trends from Sierra Leone's every week. If no to bot Salone wi no go eva mail yu!</span></span></span></p>
</div>
</div>
</div>
<div class="et_bloom_form_content et_bloom_1_field et_bloom_bottom_inline">
<form method="post" class="clearfix">
<p class="et_bloom_popup_input et_bloom_subscribe_email">
<input placeholder="Email">
</p>
<button data-optin_id="optin_1" data-service="mailchimp" data-list_id="fe1d8e9e48" data-page_id="39042" data-account="VRC2013" class="et_bloom_submit_subscription">
<span class="et_bloom_subscribe_loader"></span>
<span class="et_bloom_button_text et_bloom_button_text_color_light">SUBSCRIBE!</span>
</button>
</form>
<div class="et_bloom_success_container">
<span class="et_bloom_success_checkmark"></span>
</div>
<h2 class="et_bloom_success_message">You have Successfully Subscribed!</h2>
</div>
</div>
<span class="et_bloom_close_button"></span>
</div>
</div><link rel='stylesheet' id='et-gf-open-sans-css' href='https://fonts.googleapis.com/css?family=Open+Sans:300italic,400italic,600italic,700italic,800italic,400,300,600,700,800&#038;subset=latin,cyrillic-ext,greek-ext,greek,vietnamese,latin-ext,cyrillic' type='text/css' media='all' />
<script type='text/javascript' src='https://www.switsalone.com/wp-content/plugins/bloom/js/jquery.uniform.min.js?ver=1.0.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var bloomSettings = {"ajaxurl":"https:\/\/www.switsalone.com\/wp-admin\/admin-ajax.php","pageurl":"https:\/\/www.switsalone.com\/39042_sierra-leone-news-today-159\/","stats_nonce":"455152e24b","subscribe_nonce":"38f32af854"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/plugins/bloom/js/custom.js?ver=1.0.2'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/plugins/bloom/js/idle-timer.min.js?ver=1.0.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.switsalone.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.2.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"switsalone"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.21'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.21"},"disqusIdentifier":"39042 https:\/\/www.switsalone.com\/?p=39042","disqusShortname":"switsalone","disqusTitle":"Sierra Leone News Today","disqusUrl":"https:\/\/www.switsalone.com\/39042_sierra-leone-news-today-159\/","postId":"39042"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.21'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/plugins/penci-recipe/js/jquery.rateyo.min.js?ver=2.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var PENCI = {"ajaxUrl":"https:\/\/www.switsalone.com\/wp-admin\/admin-ajax.php","nonce":"d3249e9465"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/plugins/penci-recipe/js/rating_recipe.js?ver=2.2'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/plugins/penci-review/js/jquery.easypiechart.min.js?ver=1.0'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/plugins/penci-review/js/review.js?ver=1.0'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/themes/soledad1/js/libs-script.min.js?ver=7.2.0'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/themes/soledad1/js/smoothscroll.js?ver=1.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_var_more = {"url":"https:\/\/www.switsalone.com\/wp-admin\/admin-ajax.php","nonce":"d3249e9465","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/themes/soledad1/js/main.js?ver=7.2.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_var = {"url":"https:\/\/www.switsalone.com\/wp-admin\/admin-ajax.php","nonce":"d3249e9465","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/themes/soledad1/js/post-like.js?ver=7.2.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_var_more = {"url":"https:\/\/www.switsalone.com\/wp-admin\/admin-ajax.php","nonce":"d3249e9465","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/themes/soledad1/js/more-post-scroll.js?ver=1.0'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-includes/js/comment-reply.min.js?ver=5.3.7'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-includes/js/wp-embed.min.js?ver=5.3.7'></script>
</body>
</html>