 <!doctype html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="https://gmpg.org/xfn/11">
<title>Imatt College affiliates with USL to offer LLB | SwitSalone</title>

<meta property="og:title" content="Imatt College affiliates with USL to offer LLB" />
<meta property="og:description" content="Imatt College has been affiliated with the University of Sierra Leone (USL) to offer a Bachelor’s Degree in Law (LLB). The higher institution told Radio Democ" />
<meta property="og:url" content="https://www.switsalone.com/43306_imatt-college-affiliates-with-usl-to-offer-llb/" />
<meta property="og:image" content="http://www.switsalone.com/wp-content/uploads/2022/12/unnamed-4.png" />


<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="Imatt College affiliates with USL to offer LLB" />
<meta name="twitter:description" content="Imatt College has been affiliated with the University of Sierra Leone (USL) to offer a Bachelor’s Degree in Law (LLB). The higher institution told Radio Democ" />
<meta name="twitter:image" content="http://www.switsalone.com/wp-content/uploads/2022/12/unnamed-4.png" />

<meta name="author" content="Ibrahim Mansaray" />
<link rel='dns-prefetch' href='//platform-api.sharethis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="SwitSalone &raquo; Feed" href="https://www.switsalone.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="SwitSalone &raquo; Comments Feed" href="https://www.switsalone.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="SwitSalone &raquo; Imatt College affiliates with USL to offer LLB Comments Feed" href="https://www.switsalone.com/43306_imatt-college-affiliates-with-usl-to-offer-llb/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.switsalone.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.14"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='flick-css' href='https://www.switsalone.com/wp-content/plugins/mailchimp/css/flick/flick.css?ver=5.3.14' type='text/css' media='all' />
<link rel='stylesheet' id='mailchimpSF_main_css-css' href='https://www.switsalone.com/?mcsf_action=main_css&#038;ver=5.3.14' type='text/css' media='all' />
<!--[if IE]>
<link rel='stylesheet' id='mailchimpSF_ie_css-css'  href='https://www.switsalone.com/wp-content/plugins/mailchimp/css/ie.css?ver=5.3.14' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='sbi_styles-css' href='https://www.switsalone.com/wp-content/plugins/instagram-feed/css/sbi-styles.min.css?ver=6.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://www.switsalone.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.14' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css' href='https://www.switsalone.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='crp-style-rounded-thumbs-css' href='https://www.switsalone.com/wp-content/plugins/contextual-related-posts/css/rounded-thumbs.min.css?ver=1.0.1' type='text/css' media='all' />
<style id='crp-style-rounded-thumbs-inline-css' type='text/css'>

			.crp_related a {
			  width: 150px;
			  height: 150px;
			  text-decoration: none;
			}
			.crp_related img {
			  max-width: 150px;
			  margin: auto;
			}
			.crp_related .crp_title {
			  width: 100%;
			}
			
</style>
<link rel='stylesheet' id='penci-oswald-css' href='//fonts.googleapis.com/css?family=Oswald%3A400&#038;ver=5.3.14' type='text/css' media='all' />
<link rel='stylesheet' id='awsm-team-css' href='https://www.switsalone.com/wp-content/plugins/awsm-team/css/team.min.css?ver=1.3.0' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css' href='https://www.switsalone.com/wp-content/plugins/elementor/assets/lib/font-awesome/css/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css' href='https://www.switsalone.com/wp-content/themes/newsium-pro/assets/bootstrap/css/bootstrap.min.css?ver=5.3.14' type='text/css' media='all' />
<link rel='stylesheet' id='slick-css-css' href='https://www.switsalone.com/wp-content/themes/newsium-pro/assets/slick/css/slick.min.css?ver=5.3.14' type='text/css' media='all' />
<link rel='stylesheet' id='sidr-css' href='https://www.switsalone.com/wp-content/themes/newsium-pro/assets/sidr/css/jquery.sidr.dark.css?ver=5.3.14' type='text/css' media='all' />
<link rel='stylesheet' id='magnific-popup-css' href='https://www.switsalone.com/wp-content/themes/newsium-pro/assets/magnific-popup/magnific-popup.css?ver=5.3.14' type='text/css' media='all' />
<link rel='stylesheet' id='newsium-google-fonts-css' href='https://fonts.googleapis.com/css?family=Lato:400,300,400italic,900,700|Roboto:100,300,400,500,700&#038;subset=latin,latin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='newsium-style-css' href='https://www.switsalone.com/wp-content/themes/newsium-pro/style.css?ver=2.1.2' type='text/css' media='all' />
<style id='newsium-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='cff-css' href='https://www.switsalone.com/wp-content/plugins/custom-facebook-feed/assets/css/cff-style.min.css?ver=4.1.5' type='text/css' media='all' />
<link rel='stylesheet' id='sb-font-awesome-css' href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=5.3.14' type='text/css' media='all' />
<link rel='stylesheet' id='sab-font-css' href='https://fonts.googleapis.com/css?family=Abel:400,700,400italic,700italic&#038;subset=latin' type='text/css' media='all' />
<script type='text/javascript' src='https://www.switsalone.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/plugins/mailchimp/js/scrollTo.js?ver=1.5.8'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-includes/js/jquery/jquery.form.min.js?ver=4.2.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mailchimpSF = {"ajax_url":"https:\/\/www.switsalone.com\/"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/plugins/mailchimp/js/mailchimp.js?ver=1.5.8'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/plugins/mailchimp/js/datepicker.js?ver=5.3.14'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var append_link = {"read_more":"Read more at: %link%","prepend_break":"2","use_title":"true","add_site_name":"true","site_name":"SwitSalone","site_url":"https:\/\/www.switsalone.com","always_link_site":"false","page_title":"Imatt College affiliates with USL to offer LLB"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/plugins/append-link-on-copy/js/append_link.js?ver=5.3.14'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/plugins/stop-user-enumeration/frontend/js/frontend.js?ver=1.4.4'></script>
<script type='text/javascript' src='//platform-api.sharethis.com/js/sharethis.js#product=ga&#038;property=5c6f580819573f001129a74c'></script>
<link rel='https://api.w.org/' href='https://www.switsalone.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.switsalone.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.switsalone.com/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='Argentina beat France on penalties to win the 2022 World Cup' href='https://www.switsalone.com/43297_argentina-beat-france-on-penalties-to-win-the-2022-world-cup/' />
<link rel='next' title='Sierra Leone Weddings: Solo’s Beat marries Mary Grace Turay in Freetown!' href='https://www.switsalone.com/43309_sierra-leone-weddings-solos-beat-marries-mary-grace-turay-in-freetown/' />
<meta name="generator" content="WordPress 5.3.14" />
<link rel='shortlink' href='https://www.switsalone.com/?p=43306' />
<link rel="alternate" type="application/json+oembed" href="https://www.switsalone.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.switsalone.com%2F43306_imatt-college-affiliates-with-usl-to-offer-llb%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.switsalone.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.switsalone.com%2F43306_imatt-college-affiliates-with-usl-to-offer-llb%2F&#038;format=xml" />
<script type="text/javascript">
        jQuery(function($) {
            $('.date-pick').each(function() {
                var format = $(this).data('format') || 'mm/dd/yyyy';
                format = format.replace(/yyyy/i, 'yy');
                $(this).datepicker({
                    autoFocusNextInput: true,
                    constrainInput: false,
                    changeMonth: true,
                    changeYear: true,
                    beforeShow: function(input, inst) { $('#ui-datepicker-div').addClass('show'); },
                    dateFormat: format.toLowerCase(),
                });
            });
            d = new Date();
            $('.birthdate-pick').each(function() {
                var format = $(this).data('format') || 'mm/dd';
                format = format.replace(/yyyy/i, 'yy');
                $(this).datepicker({
                    autoFocusNextInput: true,
                    constrainInput: false,
                    changeMonth: true,
                    changeYear: false,
                    minDate: new Date(d.getFullYear(), 1-1, 1),
                    maxDate: new Date(d.getFullYear(), 12-1, 31),
                    beforeShow: function(input, inst) { $('#ui-datepicker-div').removeClass('show'); },
                    dateFormat: format.toLowerCase(),
                });

            });

        });
    </script>
<style type="text/css">
																													</style>
<style type="text/css">
																											</style>

<link rel="canonical" href="https://www.switsalone.com/43306_imatt-college-affiliates-with-usl-to-offer-llb/" />
<meta name="description" content="Imatt College has been affiliated with the University of Sierra Leone (USL) to offer a Bachelor’s Degree in Law (LLB). The higher institution told Radio Democracy that they added the programme to the list of programmes they offer to provide more options for high school leavers, as the USL cannot ..." />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.switsalone.com/43306_imatt-college-affiliates-with-usl-to-offer-llb/" />
<meta property="og:title" content="Imatt College affiliates with USL to offer LLB | SwitSalone" />
<meta property="og:description" content="Imatt College has been affiliated with the University of Sierra Leone (USL) to offer a Bachelor’s Degree in Law (LLB). The higher institution told Radio Democracy that they added the programme to the list of programmes they offer to provide more options for high school leavers, as the USL cannot ..." />
<meta property="og:image" content="https://www.switsalone.com/wp-content/uploads/2022/12/unnamed-4.png" />
<meta property="article:published_time" content="2022-12-19T13:12:14" />
<meta property="article:author" content="Ibrahim Mansaray" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="vickieremoe" />
<meta name="twitter:title" content="Imatt College affiliates with USL to offer LLB | SwitSalone" />
<meta name="twitter:description" content="Imatt College has been affiliated with the University of Sierra Leone (USL) to offer a Bachelor’s Degree in Law (LLB). The higher institution told Radio Democracy that they added the programme to the list of programmes they offer to provide more options for high school leavers, as the USL cannot ..." />
<meta name="twitter:image" content="https://www.switsalone.com/wp-content/uploads/2022/12/unnamed-4.png" />
<script type="application/ld+json">[{"@context":"http:\/\/schema.org","@type":"WebSite","about":"Sierra Leone Entertainment News","dateModified":"2022-12-19 18:00:14.000000","description":"Sierra Leone Entertainment News","encoding":"UTF-8","headline":"SwitSalone","inLanguage":"en-US","name":"SwitSalone News","publisher":{"@type":"Person","name":"Vickie Remoe"},"url":"https:\/\/www.switsalone.com"},{"@context":"http:\/\/schema.org","@type":"Article","author":{"@type":"Person","name":"Ibrahim Mansaray","url":"https:\/\/www.switsalone.com\/author\/ibrahim-mansaray\/"},"commentCount":"0","dateModified":"2022-12-19T13:12:19","datePublished":"2022-12-19T13:12:14","description":"Imatt College has been affiliated with the University of Sierra Leone (USL) to offer a Bachelor\u2019s Degree in Law (LLB). The higher institution told Radio Democracy that they added the programme to the list of programmes they offer to provide more options for high school leavers, as the USL cannot ...","headline":"Imatt College affiliates with USL to offer LLB | SwitSalone","image":{"@context":"http:\/\/schema.org","@type":"ImageObject","height":285,"url":"https:\/\/www.switsalone.com\/wp-content\/uploads\/2022\/12\/unnamed-4.png","width":512},"mainEntityOfPage":"https:\/\/www.switsalone.com\/43306_imatt-college-affiliates-with-usl-to-offer-llb\/","name":"Imatt College affiliates with USL to offer LLB","publisher":{"@type":"Organization","name":"Vickie Remoe","logo":{"@type":"ImageObject","url":"https:\/\/secure.gravatar.com\/avatar\/?s=96&d=mm&r=r","height":60,"width":60}},"thumbnailUrl":"https:\/\/www.switsalone.com\/wp-content\/uploads\/2022\/12\/unnamed-4.png","url":"https:\/\/www.switsalone.com\/43306_imatt-college-affiliates-with-usl-to-offer-llb\/"}]</script>


<meta property="og:image" content="https://www.switsalone.com/wp-content/uploads/2022/12/unnamed-4.png" />


<script>var portfolioDataJs = portfolioDataJs || [];</script><style type="text/css">.saboxplugin-wrap{ border-top-style:solid !important; border-top-color:#3D2C2C !important; border-bottom-style:solid !important; border-bottom-color:#3D2C2C !important; border-left-style:solid !important; border-left-color:#3D2C2C !important; border-right-style:solid !important; border-right-color:#3D2C2C !important;}.saboxplugin-authorname .sabox-job-title{font-family:Abel;font-size:12px;opacity:.7;display: inline-block;margin-left: 10px;}</style><link rel="pingback" href="https://www.switsalone.com/xmlrpc.php"><script>
(function() {
	(function (i, s, o, g, r, a, m) {
		i['GoogleAnalyticsObject'] = r;
		i[r] = i[r] || function () {
				(i[r].q = i[r].q || []).push(arguments)
			}, i[r].l = 1 * new Date();
		a = s.createElement(o),
			m = s.getElementsByTagName(o)[0];
		a.async = 1;
		a.src = g;
		m.parentNode.insertBefore(a, m)
	})(window, document, 'script', 'https://google-analytics.com/analytics.js', 'ga');

	ga('create', 'UA-26764328-1', 'auto');
			ga('send', 'pageview');
	})();
</script>
<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress." />
<style type="text/css">
                        .site-title,
            .site-description {
                position: absolute;
                clip: rect(1px, 1px, 1px, 1px);
                display: none;
            }

            
            

        </style>
<style type="text/css">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</style><style type="text/css">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</style><script>(function ($) {
            $(document).ready(function () {
                $(".saboxplugin-tabs-wrapper").on("click", "li", function () {
                    $(this).parents(".saboxplugin-wrap").children(".saboxplugin-tab").hide();
                    $(this).parents(".saboxplugin-wrap").children(".saboxplugin-tab-" + $(this).data("tab")).show();
                });
            });
        })(jQuery);</script><link rel="icon" href="https://www.switsalone.com/wp-content/uploads/cropped-switsalone-new-logo-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.switsalone.com/wp-content/uploads/cropped-switsalone-new-logo-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.switsalone.com/wp-content/uploads/cropped-switsalone-new-logo-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.switsalone.com/wp-content/uploads/cropped-switsalone-new-logo-1-270x270.png" />
<style type="text/css" id="wp-custom-css">
			/* Forms */	
input[type="text"],
input[type="email"],
textarea, select
{
	background-color: #fff;
  color: #000;
  width: 100%;
	padding: 5px;
	margin: 4px;
	box-shadow: 2px 0.5px;
	border: 2px solid #000;
}

select {
	height: 40px;
}

.formLabel {
	color: black;
	font-weight: 500;
	margin: 4px;
}

button, input[type="button"], input[type="reset"], input[type="submit"] {
	margin: 4px;
	font-weight: 600;
}

button:hover, input[type="button"]:hover, input[type="reset"]:hover, input[type="submit"]:hover {
	margin: 4px;
	font-weight: 700;
	background: black !important;
	color: white;
}

/***** Home *****/
@media only screen and (max-width: 420px) {
	.read-title h4 a {
		font-size: 20px;
		line-height: 1;
	}
}

/**** About ****/
.page-id-3605 .comments-area {
	display: none !important;
}

.page-id-3605 .attachment-newsium-featured {
	display: none !important
}		</style>
<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript> </head>
<body class="post-template-default single single-post postid-43306 single-format-standard wp-custom-logo wp-embed-responsive aft-default-mode aft-sticky-sidebar aft-hide-comment-count-in-list aft-hide-minutes-read-in-list aft-hide-date-author-in-list default-content-layout single-content-mode-default full-width-content wpb-js-composer js-comp-ver-6.10.0 vc_responsive elementor-default elementor-kit-36814">
<div id="page" class="site">
<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
<header id="masthead" class="header-style1 header-layout-1">
<div class="top-header">
<div class="container-wrapper">
<div class="top-bar-flex">
<div class="top-bar-left col-2">
<div class="date-bar-left">
<span class="topbar-date">
December 20, 2022 </span>
</div>
</div>
<div class="top-bar-right col-2">
<span class="aft-small-social-menu">
<div class="social-navigation"><ul id="social-menu" class="menu"><li id="menu-item-42991" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42991"><a href="https://www.facebook.com/SwitSalone/"><span class="screen-reader-text">Facebook</span></a></li>
<li id="menu-item-42992" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42992"><a href="https://www.instagram.com/switsalone/"><span class="screen-reader-text">Instagram</span></a></li>
<li id="menu-item-42993" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42993"><a href="https://twitter.com/switsalone"><span class="screen-reader-text">Twitter</span></a></li>
</ul></div>
</span>
</div>
</div>
</div>
</div>
<div class="main-header  " data-background="">
<div class="container-wrapper">
<div class="af-container-row af-flex-container">
<div class="col-3 float-l pad">
<div class="logo-brand">
<div class="site-branding">
<a href="https://www.switsalone.com/" class="custom-logo-link" rel="home"><img width="859" height="296" src="https://www.switsalone.com/wp-content/uploads/2022/06/cropped-SwitSalone-SierraLeoneNewsBlog-2.png" class="custom-logo" alt="SwitSalone" srcset="https://www.switsalone.com/wp-content/uploads/2022/06/cropped-SwitSalone-SierraLeoneNewsBlog-2.png 859w, https://www.switsalone.com/wp-content/uploads/2022/06/cropped-SwitSalone-SierraLeoneNewsBlog-2-450x155.png 450w, https://www.switsalone.com/wp-content/uploads/2022/06/cropped-SwitSalone-SierraLeoneNewsBlog-2-150x52.png 150w, https://www.switsalone.com/wp-content/uploads/2022/06/cropped-SwitSalone-SierraLeoneNewsBlog-2-768x265.png 768w, https://www.switsalone.com/wp-content/uploads/2022/06/cropped-SwitSalone-SierraLeoneNewsBlog-2-610x210.png 610w" sizes="(max-width: 859px) 100vw, 859px" /></a> <p class="site-title font-family-1">
<a href="https://www.switsalone.com/" rel="home">SwitSalone</a>
</p>
<p class="site-description">Sierra Leone Entertainment News</p>
</div>
</div>
</div>
<div class="col-66 float-l pad">
</div>
</div>
</div>
</div>
<div class="header-menu-part">
<div id="main-navigation-bar" class="bottom-bar">
<div class="navigation-section-wrapper">
<div class="container-wrapper">
<div class="header-middle-part">
<div class="navigation-container">
<nav class="main-navigation clearfix">
<span class="aft-home-icon">
<a href="https://www.switsalone.com">
<i class="fa fa-home" aria-hidden="true"></i>
</a>
</span>
<span class="toggle-menu" aria-controls="primary-menu" aria-expanded="false">
<a href="javascript:void(0)" class="aft-void-menu">
<span class="screen-reader-text">
Primary Menu </span>
<i class="ham"></i>
</a>
</span>
<div class="menu main-menu menu-desktop show-menu-border"><ul id="primary-menu" class="menu"><li id="menu-item-33841" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33841"><a href="https://www.switsalone.com/category/entertainment/">Entertainment</a></li>
<li id="menu-item-33840" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33840"><a href="https://www.switsalone.com/category/news-politics/">News &#038; Politics</a></li>
<li id="menu-item-33843" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33843"><a href="https://www.switsalone.com/category/diaspora/">Diaspora</a></li>
<li id="menu-item-33844" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-33844"><a href="https://www.switsalone.com/category/people/">People</a></li>
<li id="menu-item-33846" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33846"><a href="https://www.switsalone.com/category/sports/">Sports</a></li>
</ul></div> </nav>
 </div>
</div>
<div class="header-right-part">
<div class="af-search-wrap">
<div class="search-overlay">
<a href="#" title="Search" class="search-icon">
<i class="fa fa-search"></i>
</a>
<div class="af-search-form">
<form role="search" method="get" class="search-form" action="https://www.switsalone.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form> </div>
</div>
</div>
<div class="popular-tags-dropdown">
<a href="javascript:void(0)"><i class="fa fa-fire" aria-hidden="true"></i></a>
<div class="aft-popular-tags">
<div class="aft-popular-taxonomies-lists clearfix"><strong>Popular Tags</strong><ul><li><a href="https://www.switsalone.com/tag/sierra-leone/">Sierra Leone<span class="tag-count">828</span></a></li><li><a href="https://www.switsalone.com/tag/africa/">Africa<span class="tag-count">173</span></a></li><li><a href="https://www.switsalone.com/tag/sierra-leone-news/">Sierra Leone news<span class="tag-count">155</span></a></li><li><a href="https://www.switsalone.com/tag/diaspora-2/">diaspora<span class="tag-count">142</span></a></li><li><a href="https://www.switsalone.com/tag/vickie-remoe/">Vickie Remoe<span class="tag-count">115</span></a></li><li><a href="https://www.switsalone.com/tag/freetown/">freetown<span class="tag-count">113</span></a></li><li><a href="https://www.switsalone.com/tag/music/">music<span class="tag-count">105</span></a></li></ul></div> </div>
</div>
</div>
</div>
</div>
</div>
</div>
</header>

<header class="entry-header pos-rel single-full-header-wrap ">
<div class="container-wrapper ">
<div class="read-details af-container-block-wrapper">
<div class="entry-header-details">
<div class="figure-categories figure-categories-bg">
<ul class="cat-links"><li class="meta-category">
<a class="newsium-categories category-color-1" href="https://www.switsalone.com/category/education/" alt="View all posts in Education">
Education
</a>
</li><li class="meta-category">
<a class="newsium-categories category-color-1" href="https://www.switsalone.com/category/news/" alt="View all posts in News">
News
</a>
</li><li class="meta-category">
<a class="newsium-categories category-color-1" href="https://www.switsalone.com/category/people/" alt="View all posts in People">
People
</a>
</li><li class="meta-category">
 <a class="newsium-categories category-color-1" href="https://www.switsalone.com/category/youths/" alt="View all posts in youths">
youths
</a>
</li></ul>
</div>
<h1 class="entry-title">Imatt College affiliates with USL to offer LLB</h1>
</div>
</div>
</div>
</header>

<div id="content" class="container-wrapper ">
<div class="af-container-block-wrapper clearfix">
<div id="primary" class="content-area ">
<main id="main" class="site-main ">
<article id="post-43306" class="af-single-article post-43306 post type-post status-publish format-standard has-post-thumbnail hentry category-education category-news category-people category-youths tag-imatt-college tag-university-of-sierra-leone">
<div class="entry-content-wrap read-single">
<div class="post-meta-share-wrapper">
<div class="post-meta-detail">
<span class="min-read-post-format">
</span>
<span class="entry-meta">
<span class="item-metadata posts-author byline">
<i class="fa fa-pencil-square-o"></i>
<a href="https://www.switsalone.com/author/ibrahim-mansaray/">
Ibrahim Mansaray </a>
</span>
</span>
<span class="item-metadata posts-date">
<i class="fa fa-clock-o"></i>
20 hours ago </span>
<span class="min-read">2 min read</span> </div>
</div>
<div class="read-img pos-rel">
<div class="post-thumbnail full-width-image">
<img width="512" height="285" src="https://www.switsalone.com/wp-content/uploads/2022/12/unnamed-4.png" class="attachment-newsium-featured size-newsium-featured wp-post-image" alt="" srcset="https://www.switsalone.com/wp-content/uploads/2022/12/unnamed-4.png 512w, https://www.switsalone.com/wp-content/uploads/2022/12/unnamed-4-450x250.png 450w, https://www.switsalone.com/wp-content/uploads/2022/12/unnamed-4-150x83.png 150w" sizes="(max-width: 512px) 100vw, 512px" /> </div>
<span class="min-read-post-format">
</span>
</div>
<div class="entry-content read-details">
<p><a href="https://imatcollege.com/">Imatt College</a> has been affiliated with the University of Sierra Leone (USL) to offer a Bachelor’s Degree in Law (LLB). The higher institution told Radio Democracy that they added the programme to the list of programmes they offer to provide more options for high school leavers, as the USL cannot provide space for all its applicants.</p>
<p>In October, <a href="https://www.switsalone.com/42538_university-of-sierra-leone-turns-to-entrance-exams-as-thousands-seek-entry-after-record-setting-wassce-results/#:~:text=Featured-,University%20of%20Sierra%20Leone%20Turns%20To%20Entrance%20Exams%20As%20Thousands,After%20Record%2DSetting%20WASSCE%20Results&amp;text=The%20University%20of%20Sierra%20Leone,of%20Technical%20and%20Higher%20Education.">USL announced that, after engagements with the Ministry of Technical and Higher Education, it would conduct a “selection test” because it received more applications than it could admit</a>. This was an opportunity to jump on for the institution which started operations in 2009 as a teaching syndicate for public exams, then transitioned to a technical and vocational institute, and later a teaching college for the law degree offered by the University of London.</p>
<p>For a start, they offered programmes in Information Technology, Marketing, Business Administration and Human Resource Management. They also pride themselves as the country’s best place to learn foreign languages, which include French and Spanish.</p>
<p>The college’s board chairperson, Amadu Justice Bah said their priority areas had been high-quality teaching, being target-oriented, best students’ study experiences and leadership. Bah said modules offered under their law programme will be taught by Sierra Leonean lecturers, in their state-of-the-art classrooms.&nbsp;</p>
<p>He said, as approved by the Ministry of Technical and Higher Education, and the Tertiary Education Commission, course requirements, duration, and degree standard are the same as what USL offers to students who study with them.&nbsp;</p>
<p>Bah further said they provide tuition for graduates with LLB to prepare them for law school. This, he said, has helped a lot of students to ace the bar exams. He added that they are also affiliated with the University of Mines and Technology in Ghana to offer programmes in Mineral Technology.</p>
<p>The college has also been performing in competitions with other higher-learning institutions. In November, <a href="https://www.switsalone.com/42560_imat-college-defeats-unimak-to-win-the-frances-claudia-wright-inter-collegiate-moot-competition/">they defeated the University of Makeni to win the Claudia Wright intercollegiate moot court competition</a>. In June 2023, they will be representing Sierra Leone at the International Criminal Court Tribunal. Bah said they are pleased about this, and they will make Sierra Leone proud. </p>
<div class="crp_related  "><h3>Related Posts:</h3><ul><li><a href="https://www.switsalone.com/37985_milton-margai-college-attains-university-status/" class="crp_link post-37985"><span class="crp_title">Milton Margai College attains university status</span></a></li><li><a href="https://www.switsalone.com/38301_student-union-of-fbc-gives-president-bio-ultimatum-for-the-resumption-of-college/" class="crp_link post-38301"><span class="crp_title">Student Union of FBC gives President Bio Ultimatum&hellip;</span></a></li><li><a href="https://www.switsalone.com/41871_president-bio-commissioned-the-newly-constructed-tunde-cole-building-at-fourah-bay-college-campus/" class="crp_link post-41871"><span class="crp_title">President Bio commissioned the newly constructed&hellip;</span></a></li><li><a href="https://www.switsalone.com/38235_sierra-leones-first-female-engineer-named-2021-imperial-college-distinguished-alumni-award/" class="crp_link post-38235"><span class="crp_title">Sierra Leone’s first Female Engineer named 2021&hellip;</span></a></li><li><a href="https://www.switsalone.com/42560_imat-college-defeats-unimak-to-win-the-frances-claudia-wright-inter-collegiate-moot-competition/" class="crp_link post-42560"><span class="crp_title">IMAT College defeats UNIMAK to win the Frances&hellip;</span></a></li></ul><div class="crp_clear"></div></div> <div class="post-item-metadata entry-meta">
<span class="tags-links">Tags: <a href="https://www.switsalone.com/tag/imatt-college/" rel="tag">IMATT College</a> <a href="https://www.switsalone.com/tag/university-of-sierra-leone/" rel="tag">University of Sierra Leone</a></span> </div>
<nav class="navigation post-navigation" role="navigation" aria-label="Continue Reading">
<h2 class="screen-reader-text">Continue Reading</h2>
<div class="nav-links"><div class="nav-previous"><a href="https://www.switsalone.com/43297_argentina-beat-france-on-penalties-to-win-the-2022-world-cup/" rel="prev"><span class="em-post-navigation">Previous</span> Argentina beat France on penalties to win the 2022 World Cup</a></div><div class="nav-next"><a href="https://www.switsalone.com/43309_sierra-leone-weddings-solos-beat-marries-mary-grace-turay-in-freetown/" rel="next"><span class="em-post-navigation">Next</span> Sierra Leone Weddings: Solo’s Beat marries Mary Grace Turay in Freetown!</a></div></div>
</nav> </div>
</div>
<div class="aft-comment-related-wrap">
<div id="disqus_thread"></div>
<div class="promotionspace enable-promotionspace">
<div class="af-reated-posts grid-layout">
<h4 class="widget-title header-after1">
<span class="header-after">
More Stories </span>
</h4>
<div class="af-container-row clearfix">
<div class="col-3 float-l pad latest-posts-grid af-sec-post" data-mh="latest-posts-grid">
<div class="read-single color-pad af-category-inside-img">
<div class="read-img pos-rel read-bg-img">
<a href="https://www.switsalone.com/43309_sierra-leone-weddings-solos-beat-marries-mary-grace-turay-in-freetown/">
<img width="720" height="475" src="https://www.switsalone.com/wp-content/uploads/2022/12/320710666_1321225008644202_6271354516425459983_n-720x475.jpg" class="attachment-newsium-medium size-newsium-medium wp-post-image" alt="" /> </a>
<div class="read-categories">
<ul class="cat-links"><li class="meta-category">
<a class="newsium-categories category-color-1" href="https://www.switsalone.com/category/entertainment/" alt="View all posts in Entertainment">
Entertainment
</a>
</li><li class="meta-category">
<a class="newsium-categories category-color-1" href="https://www.switsalone.com/category/people/" alt="View all posts in People">
People
</a>
</li><li class="meta-category">
<a class="newsium-categories category-color-1" href="https://www.switsalone.com/category/sierraleoneweddings/" alt="View all posts in Sierra Leone Weddings">
Sierra Leone Weddings
</a>
</li></ul> </div>
<span class="min-read-post-format af-with-category">
<span class="min-read">1 min read</span>
</span>
</div>
<div class="read-details color-tp-pad no-color-pad">
<div class="read-title">
<h4>
<a href="https://www.switsalone.com/43309_sierra-leone-weddings-solos-beat-marries-mary-grace-turay-in-freetown/">Sierra Leone Weddings: Solo’s Beat marries Mary Grace Turay in Freetown!</a>
</h4>
</div>
<div class="entry-meta">
<span class="author-links">
<span class="item-metadata posts-date">
<i class="fa fa-clock-o"></i>
15 hours ago </span>
<span class="item-metadata posts-author byline">
<i class="fa fa-pencil-square-o"></i>
<a href="https://www.switsalone.com/author/alhassan-lamin/">
Lamin Kargbo </a>
</span>
<span class="min-read-post-comment">
<a class="af-comment-count" href="https://www.switsalone.com/43309_sierra-leone-weddings-solos-beat-marries-mary-grace-turay-in-freetown/">
1 </a>
</span>
</span>
</div>
</div>
</div>
</div>
<div class="col-3 float-l pad latest-posts-grid af-sec-post" data-mh="latest-posts-grid">
<div class="read-single color-pad af-category-inside-img">
<div class="read-img pos-rel read-bg-img">
<a href="https://www.switsalone.com/43297_argentina-beat-france-on-penalties-to-win-the-2022-world-cup/">
<img width="680" height="475" src="https://www.switsalone.com/wp-content/uploads/2022/12/FkU9F-KWYAMoTRD-680x475.jpeg" class="attachment-newsium-medium size-newsium-medium wp-post-image" alt="" /> </a>
<div class="read-categories">
<ul class="cat-links"><li class="meta-category">
<a class="newsium-categories category-color-1" href="https://www.switsalone.com/category/sports/football/" alt="View all posts in Football">
Football
</a>
</li><li class="meta-category">
<a class="newsium-categories category-color-1" href="https://www.switsalone.com/category/news/" alt="View all posts in News">
News
</a>
</li><li class="meta-category">
<a class="newsium-categories category-color-1" href="https://www.switsalone.com/category/people/" alt="View all posts in People">
People
</a>
</li><li class="meta-category">
<a class="newsium-categories category-color-1" href="https://www.switsalone.com/category/sports/" alt="View all posts in Sports">
Sports
</a>
</li><li class="meta-category">
<a class="newsium-categories category-color-1" href="https://www.switsalone.com/category/world/" alt="View all posts in World">
World
</a>
</li></ul> </div>
<span class="min-read-post-format af-with-category">
<span class="min-read">1 min read</span>
</span>
</div>
<div class="read-details color-tp-pad no-color-pad">
<div class="read-title">
<h4>
<a href="https://www.switsalone.com/43297_argentina-beat-france-on-penalties-to-win-the-2022-world-cup/">Argentina beat France on penalties to win the 2022 World Cup</a>
</h4>
</div>
<div class="entry-meta">
<span class="author-links">
<span class="item-metadata posts-date">
<i class="fa fa-clock-o"></i>
 23 hours ago </span>
<span class="item-metadata posts-author byline">
<i class="fa fa-pencil-square-o"></i>
<a href="https://www.switsalone.com/author/alhassan-lamin/">
Lamin Kargbo </a>
</span>
</span>
</div>
</div>
</div>
</div>
<div class="col-3 float-l pad latest-posts-grid af-sec-post" data-mh="latest-posts-grid">
<div class="read-single color-pad af-category-inside-img">
<div class="read-img pos-rel read-bg-img">
<a href="https://www.switsalone.com/43291_top-10-most-viewed-sierra-leonean-artists-on-youtube/">
<img width="720" height="475" src="https://www.switsalone.com/wp-content/uploads/2022/12/Top-10-Most-Streamed-Sierra-Leonean-Artists-3-720x475.png" class="attachment-newsium-medium size-newsium-medium wp-post-image" alt="" /> </a>
<div class="read-categories">
<ul class="cat-links"><li class="meta-category">
<a class="newsium-categories category-color-1" href="https://www.switsalone.com/category/entertainment/" alt="View all posts in Entertainment">
Entertainment
</a>
</li><li class="meta-category">
<a class="newsium-categories category-color-1" href="https://www.switsalone.com/category/people/" alt="View all posts in People">
People
</a>
</li></ul> </div>
<span class="min-read-post-format af-with-category">
<span class="min-read">1 min read</span>
</span>
</div>
<div class="read-details color-tp-pad no-color-pad">
<div class="read-title">
<h4>
<a href="https://www.switsalone.com/43291_top-10-most-viewed-sierra-leonean-artists-on-youtube/">Top 10 Most Viewed Sierra Leonean Artists on YouTube</a>
</h4>
</div>
<div class="entry-meta">
<span class="author-links">
<span class="item-metadata posts-date">
<i class="fa fa-clock-o"></i>
4 days ago </span>
<span class="item-metadata posts-author byline">
<i class="fa fa-pencil-square-o"></i>
<a href="https://www.switsalone.com/author/alhassan-lamin/">
Lamin Kargbo </a>
</span>
<span class="min-read-post-comment">
<a class="af-comment-count" href="https://www.switsalone.com/43291_top-10-most-viewed-sierra-leonean-artists-on-youtube/">
1 </a>
</span>
</span>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</article>
</main>
</div>
</div>
</div>
<div class="af-main-banner-latest-posts grid-layout">
<div class="container-wrapper">
<div class="af-container-block-wrapper pad-20">
<div class="widget-title-section">
<h4 class="widget-title header-after1">
<span class="header-after">
You may have missed </span>
</h4>
</div>
<div class="af-container-row clearfix">
<div class="col-4 pad float-l" data-mh="you-may-have-missed">
<div class="read-single color-pad af-category-inside-img">
<div class="read-img pos-rel read-bg-img">
<a href="https://www.switsalone.com/43309_sierra-leone-weddings-solos-beat-marries-mary-grace-turay-in-freetown/">
<img width="720" height="475" src="https://www.switsalone.com/wp-content/uploads/2022/12/320710666_1321225008644202_6271354516425459983_n-720x475.jpg" class="attachment-newsium-medium size-newsium-medium wp-post-image" alt="" /> </a>
<div class="read-categories">
<ul class="cat-links"><li class="meta-category">
<a class="newsium-categories category-color-1" href="https://www.switsalone.com/category/entertainment/" alt="View all posts in Entertainment">
Entertainment
</a>
</li><li class="meta-category">
<a class="newsium-categories category-color-1" href="https://www.switsalone.com/category/people/" alt="View all posts in People">
People
</a>
</li><li class="meta-category">
<a class="newsium-categories category-color-1" href="https://www.switsalone.com/category/sierraleoneweddings/" alt="View all posts in Sierra Leone Weddings">
Sierra Leone Weddings
</a>
</li></ul> </div>
<span class="min-read-post-format af-with-category">
<span class="min-read">1 min read</span> </span>
</div>
<div class="read-details color-tp-pad">
<div class="read-title">
<h4>
<a href="https://www.switsalone.com/43309_sierra-leone-weddings-solos-beat-marries-mary-grace-turay-in-freetown/">Sierra Leone Weddings: Solo’s Beat marries Mary Grace Turay in Freetown!</a>
</h4>
</div>
<div class="entry-meta">
<span class="author-links">
<span class="item-metadata posts-date">
<i class="fa fa-clock-o"></i>
15 hours ago </span>
<span class="item-metadata posts-author byline">
<i class="fa fa-pencil-square-o"></i>
<a href="https://www.switsalone.com/author/alhassan-lamin/">
Lamin Kargbo </a>
</span>
<span class="min-read-post-comment">
 <a class="af-comment-count" href="https://www.switsalone.com/43309_sierra-leone-weddings-solos-beat-marries-mary-grace-turay-in-freetown/">
1 </a>
</span>
</span>
</div>
</div>
</div>
</div>
<div class="col-4 pad float-l" data-mh="you-may-have-missed">
<div class="read-single color-pad af-category-inside-img">
<div class="read-img pos-rel read-bg-img">
<a href="https://www.switsalone.com/43306_imatt-college-affiliates-with-usl-to-offer-llb/">
<img width="512" height="285" src="https://www.switsalone.com/wp-content/uploads/2022/12/unnamed-4.png" class="attachment-newsium-medium size-newsium-medium wp-post-image" alt="" srcset="https://www.switsalone.com/wp-content/uploads/2022/12/unnamed-4.png 512w, https://www.switsalone.com/wp-content/uploads/2022/12/unnamed-4-450x250.png 450w, https://www.switsalone.com/wp-content/uploads/2022/12/unnamed-4-150x83.png 150w" sizes="(max-width: 512px) 100vw, 512px" /> </a>
<div class="read-categories">
<ul class="cat-links"><li class="meta-category">
<a class="newsium-categories category-color-1" href="https://www.switsalone.com/category/education/" alt="View all posts in Education">
Education
</a>
</li><li class="meta-category">
<a class="newsium-categories category-color-1" href="https://www.switsalone.com/category/news/" alt="View all posts in News">
News
</a>
</li><li class="meta-category">
<a class="newsium-categories category-color-1" href="https://www.switsalone.com/category/people/" alt="View all posts in People">
People
</a>
</li><li class="meta-category">
<a class="newsium-categories category-color-1" href="https://www.switsalone.com/category/youths/" alt="View all posts in youths">
youths
</a>
</li></ul> </div>
<span class="min-read-post-format af-with-category">
<span class="min-read">2 min read</span> </span>
</div>
<div class="read-details color-tp-pad">
<div class="read-title">
<h4>
<a href="https://www.switsalone.com/43306_imatt-college-affiliates-with-usl-to-offer-llb/">Imatt College affiliates with USL to offer LLB</a>
</h4>
</div>
<div class="entry-meta">
<span class="author-links">
<span class="item-metadata posts-date">
<i class="fa fa-clock-o"></i>
20 hours ago </span>
<span class="item-metadata posts-author byline">
<i class="fa fa-pencil-square-o"></i>
<a href="https://www.switsalone.com/author/ibrahim-mansaray/">
Ibrahim Mansaray </a>
</span>
</span>
</div>
</div>
</div>
</div>
<div class="col-4 pad float-l" data-mh="you-may-have-missed">
<div class="read-single color-pad af-category-inside-img">
<div class="read-img pos-rel read-bg-img">
<a href="https://www.switsalone.com/43297_argentina-beat-france-on-penalties-to-win-the-2022-world-cup/">
<img width="680" height="475" src="https://www.switsalone.com/wp-content/uploads/2022/12/FkU9F-KWYAMoTRD-680x475.jpeg" class="attachment-newsium-medium size-newsium-medium wp-post-image" alt="" /> </a>
<div class="read-categories">
<ul class="cat-links"><li class="meta-category">
<a class="newsium-categories category-color-1" href="https://www.switsalone.com/category/sports/football/" alt="View all posts in Football">
Football
</a>
</li><li class="meta-category">
<a class="newsium-categories category-color-1" href="https://www.switsalone.com/category/news/" alt="View all posts in News">
News
</a>
</li><li class="meta-category">
<a class="newsium-categories category-color-1" href="https://www.switsalone.com/category/people/" alt="View all posts in People">
People
</a>
</li><li class="meta-category">
<a class="newsium-categories category-color-1" href="https://www.switsalone.com/category/sports/" alt="View all posts in Sports">
Sports
</a>
</li><li class="meta-category">
<a class="newsium-categories category-color-1" href="https://www.switsalone.com/category/world/" alt="View all posts in World">
World
</a>
</li></ul> </div>
<span class="min-read-post-format af-with-category">
<span class="min-read">1 min read</span> </span>
</div>
<div class="read-details color-tp-pad">
<div class="read-title">
<h4>
<a href="https://www.switsalone.com/43297_argentina-beat-france-on-penalties-to-win-the-2022-world-cup/">Argentina beat France on penalties to win the 2022 World Cup</a>
</h4>
</div>
<div class="entry-meta">
<span class="author-links">
<span class="item-metadata posts-date">
<i class="fa fa-clock-o"></i>
23 hours ago </span>
<span class="item-metadata posts-author byline">
<i class="fa fa-pencil-square-o"></i>
<a href="https://www.switsalone.com/author/alhassan-lamin/">
Lamin Kargbo </a>
</span>
</span>
</div>
</div>
</div>
</div>
<div class="col-4 pad float-l" data-mh="you-may-have-missed">
<div class="read-single color-pad af-category-inside-img">
<div class="read-img pos-rel read-bg-img">
<a href="https://www.switsalone.com/43291_top-10-most-viewed-sierra-leonean-artists-on-youtube/">
<img width="720" height="475" src="https://www.switsalone.com/wp-content/uploads/2022/12/Top-10-Most-Streamed-Sierra-Leonean-Artists-3-720x475.png" class="attachment-newsium-medium size-newsium-medium wp-post-image" alt="" /> </a>
<div class="read-categories">
<ul class="cat-links"><li class="meta-category">
<a class="newsium-categories category-color-1" href="https://www.switsalone.com/category/entertainment/" alt="View all posts in Entertainment">
Entertainment
</a>
</li><li class="meta-category">
<a class="newsium-categories category-color-1" href="https://www.switsalone.com/category/people/" alt="View all posts in People">
People
</a>
</li></ul> </div>
<span class="min-read-post-format af-with-category">
<span class="min-read">1 min read</span> </span>
</div>
<div class="read-details color-tp-pad">
<div class="read-title">
<h4>
<a href="https://www.switsalone.com/43291_top-10-most-viewed-sierra-leonean-artists-on-youtube/">Top 10 Most Viewed Sierra Leonean Artists on YouTube</a>
</h4>
</div>
<div class="entry-meta">
<span class="author-links">
<span class="item-metadata posts-date">
<i class="fa fa-clock-o"></i>
4 days ago </span>
<span class="item-metadata posts-author byline">
<i class="fa fa-pencil-square-o"></i>
<a href="https://www.switsalone.com/author/alhassan-lamin/">
Lamin Kargbo </a>
</span>
<span class="min-read-post-comment">
<a class="af-comment-count" href="https://www.switsalone.com/43291_top-10-most-viewed-sierra-leonean-artists-on-youtube/">
1 </a>
</span>
</span>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<footer class="site-footer">
<div class="secondary-footer">
<div class="container-wrapper">
<div class="af-container-row clearfix af-flex-container">
<div class="float-l pad color-pad col-2">
<div class="footer-nav-wrapper">
<div class="footer-navigation"><ul id="footer-menu" class="menu"><li id="menu-item-42996" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-42996"><a href="https://www.switsalone.com/about-us-2/">About Us</a></li>
<li id="menu-item-43027" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43027"><a href="https://www.switsalone.com/contact-us/">Contact Us</a></li>
<li id="menu-item-43002" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43002"><a href="https://www.switsalone.com/privacy-policy/">Privacy Policy</a></li>
</ul></div> </div>
</div>
<div class="float-l pad color-pad col-2">
<div class="footer-social-wrapper">
<div class="aft-small-social-menu">
<div class="social-navigation"><ul id="social-menu" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42991"><a href="https://www.facebook.com/SwitSalone/"><span class="screen-reader-text">Facebook</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42992"><a href="https://www.instagram.com/switsalone/"><span class="screen-reader-text">Instagram</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42993"><a href="https://twitter.com/switsalone"><span class="screen-reader-text">Twitter</span></a></li>
</ul></div> </div>
</div>
</div>
</div>
</div>
</div>
<div class="site-info">
<div class="container-wrapper">
<div class="af-container-row">
<div class="col-1 color-pad">
Copyright © 2022. All rights reserved. </div>
</div>
</div>
</div>
</footer>
</div>
<a id="scroll-up" class="secondary-color">
<i class="fa fa-angle-up"></i>
</a>

<script type="text/javascript">var cffajaxurl = "https://www.switsalone.com/wp-admin/admin-ajax.php";
var cfflinkhashtags = "true";
</script>

<script type="text/javascript">
var sbiajaxurl = "https://www.switsalone.com/wp-admin/admin-ajax.php";
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.switsalone.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.2.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"switsalone"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.22'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.22"},"disqusIdentifier":"43306 http:\/\/www.switsalone.com\/?p=43306","disqusShortname":"switsalone","disqusTitle":"Imatt College affiliates with USL to offer LLB","disqusUrl":"https:\/\/www.switsalone.com\/43306_imatt-college-affiliates-with-usl-to-offer-llb\/","postId":"43306"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.22'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/plugins/penci-recipe/js/jquery.rateyo.min.js?ver=2.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var PENCI = {"ajaxUrl":"https:\/\/www.switsalone.com\/wp-admin\/admin-ajax.php","nonce":"75082961e4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/plugins/penci-recipe/js/rating_recipe.js?ver=2.2'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/plugins/penci-review/js/jquery.easypiechart.min.js?ver=1.0'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/plugins/penci-review/js/review.js?ver=1.0'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/plugins/awsm-team/js/team.min.js?ver=1.3.0'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/themes/newsium-pro/js/navigation.js?ver=20151215'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/themes/newsium-pro/js/skip-link-focus-fix.js?ver=20151215'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/themes/newsium-pro/assets/slick/js/slick.min.js?ver=5.3.14'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/themes/newsium-pro/assets/video-script.js?ver=5.3.14'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/themes/newsium-pro/assets/bootstrap/js/bootstrap.min.js?ver=5.3.14'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/themes/newsium-pro/assets/sidr/js/jquery.sidr.min.js?ver=5.3.14'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/themes/newsium-pro/assets/magnific-popup/jquery.magnific-popup.min.js?ver=5.3.14'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/themes/newsium-pro/assets/jquery-match-height/jquery.matchHeight.min.js?ver=5.3.14'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/themes/newsium-pro/assets/marquee/jquery.marquee.js?ver=5.3.14'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/themes/newsium-pro/assets/theiaStickySidebar/theia-sticky-sidebar.min.js?ver=5.3.14'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-includes/js/masonry.min.js?ver=3.3.2'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/themes/newsium-pro/assets/script.js?ver=5.3.14'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var AFurl = {"nonce":"072dde981e","ajaxurl":"https:\/\/www.switsalone.com\/wp-admin\/admin-ajax.php","dir":"left"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/themes/newsium-pro/assets/pagination-script.js?ver=5.3.14'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-includes/js/comment-reply.min.js?ver=5.3.14'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var cffOptions = {"placeholder":"https:\/\/www.switsalone.com\/wp-content\/plugins\/custom-facebook-feed\/assets\/img\/placeholder.png"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.switsalone.com/wp-content/plugins/custom-facebook-feed/assets/js/cff-scripts.js?ver=4.1.5'></script>
<script type='text/javascript' src='https://www.switsalone.com/wp-includes/js/wp-embed.min.js?ver=5.3.14'></script>
</body>
</html>
